aboutsummaryrefslogtreecommitdiff
path: root/emulators/qtemu
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-01-07 02:07:26 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-01-07 02:07:26 +0000
commit5dd37213f549b0d2fd158b1fa8024daeda2acfb2 (patch)
tree4e5353da2c1d4f4f59bf9fc12fe364c7887a9f49 /emulators/qtemu
parent5fa1ec89fceb95ba8e0ff259f73e7e55da5383c2 (diff)
downloadports-5dd37213f549b0d2fd158b1fa8024daeda2acfb2.tar.gz
ports-5dd37213f549b0d2fd158b1fa8024daeda2acfb2.zip
- Update DESKTOP_ENTRIES:
* rephrase Comment field or use port ${COMMENT} if appropriate * adjust Icon field according to the Desktop Entry Specification * update Categories field: remove deprecated category Application; set main category, if missing - Remove indefinite article and/or rephrase COMMENT - Trim Makefile header - Other minor changes
Notes
Notes: svn path=/head/; revision=310020
Diffstat (limited to 'emulators/qtemu')
-rw-r--r--emulators/qtemu/Makefile19
1 files changed, 3 insertions, 16 deletions
diff --git a/emulators/qtemu/Makefile b/emulators/qtemu/Makefile
index 790a65f525f5..d8318563a976 100644
--- a/emulators/qtemu/Makefile
+++ b/emulators/qtemu/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: qtemu
-# Date created: 2007-03-20
-# Whom: Max Brazhnikov <makc@issp.ac.ru>
-#
# $FreeBSD$
-#
PORTNAME= qtemu
PORTVERSION= 1.0.5
@@ -12,7 +7,7 @@ CATEGORIES= emulators
MASTER_SITES= SF
MAINTAINER= makc@FreeBSD.org
-COMMENT= A Qt4 front-end to Qemu
+COMMENT= Qt4-based frontend for QEMU
USE_BZIP2= yes
USE_QT4= gui xml uic_build moc_build qmake_build rcc_build
@@ -25,8 +20,7 @@ DESKTOP_ENTRIES="QtEmu" "QEMU frontend" "" \
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-#USE_QT4+= linguist
-BUILD_DEPENDS+= ${LOCALBASE}/bin/lupdate-qt4:${PORTSDIR}/devel/qt4-linguist
+USE_QT4+= linguist_build
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
@@ -34,14 +28,7 @@ PLIST_SUB+= NLS="@comment "
do-configure:
(cd ${WRKSRC} && ${LOCALBASE}/bin/lrelease-qt4 -verbose qtemu.pro \
- && ${SETENV} ${CONFIGURE_ENV} ${QMAKE})
-
-post-configure:
- @${REINPLACE_CMD} -e \
- 's|^CC .*|CC=${CC}|; \
- s|^CXX .*|CXX=${CXX}|; \
- s|^LINK .*|LINK=${CXX}|' \
- ${WRKSRC}/Makefile
+ && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS})
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/qtemu ${PREFIX}/bin/qtemu