aboutsummaryrefslogtreecommitdiff
path: root/emulators/sdlmess
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-04-22 22:43:27 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-04-22 22:43:27 +0000
commit1ab76a704dc587a87ef4df1cefa498409d1460d3 (patch)
tree65d505d34cea2e3336d611ffc77f7e51139af81c /emulators/sdlmess
parente5fbe30dd1dc90a03ad3fd1c4118bb822b206986 (diff)
downloadports-1ab76a704dc587a87ef4df1cefa498409d1460d3.tar.gz
ports-1ab76a704dc587a87ef4df1cefa498409d1460d3.zip
- Update to version 0.114.
- Fix installation. - Remove BROKEN.
Notes
Notes: svn path=/head/; revision=190655
Diffstat (limited to 'emulators/sdlmess')
-rw-r--r--emulators/sdlmess/Makefile9
-rw-r--r--emulators/sdlmess/distinfo6
-rw-r--r--emulators/sdlmess/files/patch-makefile.sdl38
-rw-r--r--emulators/sdlmess/pkg-plist28
4 files changed, 20 insertions, 61 deletions
diff --git a/emulators/sdlmess/Makefile b/emulators/sdlmess/Makefile
index 97c0d7a1b795..f9427fcc53c0 100644
--- a/emulators/sdlmess/Makefile
+++ b/emulators/sdlmess/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sdlmess
-PORTVERSION= 0.113
+PORTVERSION= 0.114
CATEGORIES= emulators
MASTER_SITES= http://rbelmont.mameworld.info/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
@@ -14,8 +14,6 @@ DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
MAINTAINER= alepulver@FreeBSD.org
COMMENT= SDL port of MESS (Multiple Emulator Super System)
-BROKEN= Install fails
-
USE_ZIP= yes
USE_GL= yes
USE_GMAKE= yes
@@ -29,11 +27,10 @@ do-install:
${MKDIR} ${PREFIX}/libexec/${PORTNAME}
.for f in obj/sdlmess/file2str sdlmess testkeys dat2html messtest messdocs \
imgtool romcmp chdman jedutil makemeta regrep
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/${f:S/sdl//}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/${f:T:S/sdl//}
.endfor
${MKDIR} ${DATADIR}
-.for f in artwork cfg ctrlr hash ini memcard nvram snap software tools \
- sysinfo.dat
+.for f in artwork hash keymaps sysinfo.dat
${CP} -R ${WRKSRC}/${f} ${DATADIR}
.endfor
.if !defined(NOPORTDOCS)
diff --git a/emulators/sdlmess/distinfo b/emulators/sdlmess/distinfo
index f5c0bf8a3839..1c3a38aa3cd7 100644
--- a/emulators/sdlmess/distinfo
+++ b/emulators/sdlmess/distinfo
@@ -1,3 +1,3 @@
-MD5 (sdlmess0113.zip) = d73b55eda07d0615a558f767c440546f
-SHA256 (sdlmess0113.zip) = b5228907ea9b335573f7d5a88a7a98d7637b39dfb138ed8c0bda87621c6cb0af
-SIZE (sdlmess0113.zip) = 28302634
+MD5 (sdlmess0114.zip) = 24447a6a85c21764fe23f8e696668e01
+SHA256 (sdlmess0114.zip) = 9530397e1c358f77f0769b35a50292d3b022cd4fa7cfbc078618972657103d54
+SIZE (sdlmess0114.zip) = 25484229
diff --git a/emulators/sdlmess/files/patch-makefile.sdl b/emulators/sdlmess/files/patch-makefile.sdl
index b59a75950026..3c10642277e0 100644
--- a/emulators/sdlmess/files/patch-makefile.sdl
+++ b/emulators/sdlmess/files/patch-makefile.sdl
@@ -1,17 +1,8 @@
---- ./makefile.sdl.orig Fri Mar 9 01:10:42 2007
-+++ ./makefile.sdl Sun Apr 8 20:07:08 2007
-@@ -52,7 +52,7 @@
- # for SDLMAME, set this to linux, freebsd, win32, or macosx (lowercase is important!)
- #------------------------------------------------------------------------------------
-
--SUBARCH = linux
-+SUBARCH = freebsd
-
-
- #-------------------------------------------------
+--- makefile.sdl.orig Thu Apr 12 22:23:24 2007
++++ makefile.sdl Sat Apr 21 13:35:00 2007
@@ -63,11 +63,13 @@
# uncomment next line to include the debugger
- #DEBUG = 1
+ # DEBUG = 1
+ifeq ($(ARCH),i386)
# uncomment next line to use DRC MIPS3 engine
@@ -117,11 +108,11 @@
+
+ifeq ($(ARCH),i386)
+DEFS += -DX86_ASM
-+endif
+ endif
+
+ifeq ($(ARCH),powerpc)
+DEFS += -DPPC_ASM -Dbool=int
- endif
++endif
+
+ifneq ($(shell echo $(ARCH) | grep -v 64),)
+PTR64 = yes
@@ -142,7 +133,7 @@
$(OPT_FLAGS) \
-std=gnu89 \
-I$(SRC)/$(TARGET) \
-@@ -286,6 +240,7 @@
+@@ -287,6 +241,7 @@
-I$(SRC)/lib/util \
-I$(SRC)/osd \
-I$(SRC)/osd/$(MAMEOS) \
@@ -150,7 +141,7 @@
ifdef MESS
CFLAGS += \
-@@ -304,7 +259,7 @@
+@@ -305,7 +260,7 @@
endif # PPC
endif # SYMBOLS
@@ -159,7 +150,7 @@
-Wall \
-Wpointer-arith \
-Wbad-function-cast \
-@@ -316,7 +271,7 @@
+@@ -317,7 +272,7 @@
-Wdeclaration-after-statement
ifneq ($(OPTIMIZE),0)
@@ -168,7 +159,7 @@
endif
CFLAGS += -O$(OPTIMIZE)
-@@ -329,11 +284,9 @@
+@@ -325,11 +280,9 @@
# extra options needed *only* for the osd files
CFLAGSOSDEPEND = $(CFLAGS)
@@ -182,14 +173,3 @@
LDFLAGS += -s
endif
-@@ -402,6 +355,10 @@
-
- ifeq ($(SUBARCH),linux)
- CFLAGS += -DSDLMAME_LINUX
-+endif
-+
-+ifeq ($(SUBARCH),freebsd)
-+CFLAGS += -DSDLMAME_FREEBSD -DSDLMAME_NO64BITIO
- endif
-
- ifeq ($(SUBARCH),freebsd)
diff --git a/emulators/sdlmess/pkg-plist b/emulators/sdlmess/pkg-plist
index 506379eac8db..7a422b3f51ad 100644
--- a/emulators/sdlmess/pkg-plist
+++ b/emulators/sdlmess/pkg-plist
@@ -19,9 +19,7 @@ libexec/testkeys
%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/messnew.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/messroms.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/newvideo.txt
-%%PORTDOCS%%%%DOCSDIR%%/docs/style.css
%%PORTDOCS%%%%DOCSDIR%%/docs/windows.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/choice.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/compile.htm
@@ -66,12 +64,6 @@ libexec/testkeys
%%DATADIR%%/artwork/pc1403.zip
%%DATADIR%%/artwork/ssystem3.zip
%%DATADIR%%/artwork/thomson.lay
-%%DATADIR%%/cfg/dir.txt
-%%DATADIR%%/ctrlr/hotrod.cfg
-%%DATADIR%%/ctrlr/hotrodse.cfg
-%%DATADIR%%/ctrlr/slikstik.cfg
-%%DATADIR%%/ctrlr/standard.cfg
-%%DATADIR%%/ctrlr/xarcade.cfg
%%DATADIR%%/hash/a2600.hsi
%%DATADIR%%/hash/a5200.hsi
%%DATADIR%%/hash/a7800.hsi
@@ -104,7 +96,7 @@ libexec/testkeys
%%DATADIR%%/hash/exidy.hsi
%%DATADIR%%/hash/gameboy.hsi
%%DATADIR%%/hash/gamegear.hsi
-%%DATADIR%%/hash/gen_usa.hsi
+%%DATADIR%%/hash/genesis.hsi
%%DATADIR%%/hash/ibmpc.hsi
%%DATADIR%%/hash/ibmpcjr.hsi
%%DATADIR%%/hash/intv.hsi
@@ -143,22 +135,12 @@ libexec/testkeys
%%DATADIR%%/hash/vectrex.hsi
%%DATADIR%%/hash/vic20.hsi
%%DATADIR%%/hash/wswan.hsi
-%%DATADIR%%/ini/dir.txt
-%%DATADIR%%/memcard/dir.txt
-%%DATADIR%%/nvram/dir.txt
-%%DATADIR%%/snap/dir.txt
-%%DATADIR%%/software/dir.txt
+%%DATADIR%%/keymaps/km-ch.txt
+%%DATADIR%%/keymaps/km-fr-OSX.txt
+%%DATADIR%%/keymaps/km-fr.txt
%%DATADIR%%/sysinfo.dat
-%%DATADIR%%/tools/dir.txt
-@dirrm %%DATADIR%%/tools
-@dirrm %%DATADIR%%/software
-@dirrm %%DATADIR%%/snap
-@dirrm %%DATADIR%%/nvram
-@dirrm %%DATADIR%%/memcard
-@dirrm %%DATADIR%%/ini
+@dirrm %%DATADIR%%/keymaps
@dirrm %%DATADIR%%/hash
-@dirrm %%DATADIR%%/ctrlr
-@dirrm %%DATADIR%%/cfg
@dirrm %%DATADIR%%/artwork
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/windows/images