aboutsummaryrefslogtreecommitdiff
path: root/emulators/simh
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-11-05 12:36:25 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-11-05 12:36:25 +0000
commit065c026fe5e21a269bbaae0ce69307c7308acbea (patch)
tree9cbf2a263e7841be76898ae832e7bfb273d3fd08 /emulators/simh
parent6d6314e20da82ad66b7b278eee92373caa9ab746 (diff)
downloadports-065c026fe5e21a269bbaae0ce69307c7308acbea.tar.gz
ports-065c026fe5e21a269bbaae0ce69307c7308acbea.zip
Fix ports that confused the meaning of WRKDIR and WRKSRC.
PR: 204056 Submitted by: mat Reviewed by: bapt Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D2735
Notes
Notes: svn path=/head/; revision=400848
Diffstat (limited to 'emulators/simh')
-rw-r--r--emulators/simh/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/emulators/simh/Makefile b/emulators/simh/Makefile
index dab48f079f88..df78e0c08311 100644
--- a/emulators/simh/Makefile
+++ b/emulators/simh/Makefile
@@ -39,14 +39,14 @@ post-patch:
's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/VAX/vax_sysdev.c
do-install:
- (cd ${WRKDIR}/BIN && ${INSTALL_PROGRAM} ${BIN_FILES} \
+ (cd ${WRKSRC}/BIN && ${INSTALL_PROGRAM} ${BIN_FILES} \
${STAGEDIR}${PREFIX}/bin)
# eclipse conflicts with java/eclipse, install it as simh-eclipse
- ${INSTALL_PROGRAM} ${WRKDIR}/BIN/eclipse \
+ ${INSTALL_PROGRAM} ${WRKSRC}/BIN/eclipse \
${STAGEDIR}${PREFIX}/bin/simh-eclipse
@${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${WRKDIR}/VAX/ka655x.bin ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/VAX/ka655x.bin ${STAGEDIR}${DATADIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKDIR} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>