aboutsummaryrefslogtreecommitdiff
path: root/emulators/snes9x-gtk
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-03-01 22:41:24 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-03-01 22:41:24 +0000
commitf85fa6ccefc1425ed59bcbc079a6e8a4bb9f1a73 (patch)
treed88e154726001e5ee2a35f43835dafbcd4d1d59f /emulators/snes9x-gtk
parent20c8775694eab7a1a52bc5f6adbaa9dadcca8389 (diff)
downloadports-f85fa6ccefc1425ed59bcbc079a6e8a4bb9f1a73.tar.gz
ports-f85fa6ccefc1425ed59bcbc079a6e8a4bb9f1a73.zip
- Update to 1.52r79
PR: ports/144249 Submitted by: okeeblow <root@cooltrainer.org> (maintainer) Approved by: itetcu (mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=250474
Diffstat (limited to 'emulators/snes9x-gtk')
-rw-r--r--emulators/snes9x-gtk/Makefile7
-rw-r--r--emulators/snes9x-gtk/distinfo6
-rw-r--r--emulators/snes9x-gtk/files/patch-screenshot.cpp10
3 files changed, 16 insertions, 7 deletions
diff --git a/emulators/snes9x-gtk/Makefile b/emulators/snes9x-gtk/Makefile
index 90212b46224d..860f3f7e19aa 100644
--- a/emulators/snes9x-gtk/Makefile
+++ b/emulators/snes9x-gtk/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= snes9x
-PORTVERSION= 1.51r78
-PORTREVISION= 1
+PORTVERSION= 1.52r79
CATEGORIES= emulators
MASTER_SITES= http://snes9x-gtk.googlecode.com/files/
PKGNAMESUFFIX= -gtk
-DISTNAME= snes9x-1.51-src-gtk-78
+DISTNAME= snes9x-1.52-src
MAINTAINER= root@cooltrainer.org
COMMENT= Super Nintendo Entertainment System(SNES) Emulator
@@ -29,7 +28,7 @@ USE_SDL= sdl
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-WRKSRC= ${WRKDIR}/snes9x-1.51-src/gtk
+WRKSRC= ${WRKDIR}/${DISTNAME}/gtk
OPTIONS= DEBUG "Enable debug information" off \
OPENGL "Enable OpenGL support" off \
diff --git a/emulators/snes9x-gtk/distinfo b/emulators/snes9x-gtk/distinfo
index e6a855b4e961..858effd412a1 100644
--- a/emulators/snes9x-gtk/distinfo
+++ b/emulators/snes9x-gtk/distinfo
@@ -1,3 +1,3 @@
-MD5 (snes9x-1.51-src-gtk-78.tar.bz2) = 900abc119e874b59f364fc9f5187c724
-SHA256 (snes9x-1.51-src-gtk-78.tar.bz2) = 543001d7a84b05e9bd4159b10bc42f87e36b555ef715e2db1ebaaf1586143c88
-SIZE (snes9x-1.51-src-gtk-78.tar.bz2) = 894388
+MD5 (snes9x-1.52-src.tar.bz2) = 813bd3a0f99732ee0238a2c8ab417725
+SHA256 (snes9x-1.52-src.tar.bz2) = 36e09b2da62b9210feb224cfd183047a151a71c1d5e5f92749dc28bd4b7ff1cb
+SIZE (snes9x-1.52-src.tar.bz2) = 1720137
diff --git a/emulators/snes9x-gtk/files/patch-screenshot.cpp b/emulators/snes9x-gtk/files/patch-screenshot.cpp
new file mode 100644
index 000000000000..dd19fa6db61a
--- /dev/null
+++ b/emulators/snes9x-gtk/files/patch-screenshot.cpp
@@ -0,0 +1,10 @@
+--- ../screenshot.cpp.orig 2010-02-23 00:19:36.132640984 -0500
++++ ../screenshot.cpp 2010-02-23 00:19:59.151074837 -0500
+@@ -182,6 +182,7 @@
+ #include "memmap.h"
+ #include "display.h"
+ #include "screenshot.h"
++#include <unistd.h>
+
+
+ bool8 S9xDoScreenshot (int width, int height)