aboutsummaryrefslogtreecommitdiff
path: root/emulators/snes9x
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>1999-12-28 04:27:57 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>1999-12-28 04:27:57 +0000
commit397ab3211ddffc1b7c2fe14f5993f749cb2d0584 (patch)
tree99e23d0782b5519701e8a5c7a28c3203e00782bb /emulators/snes9x
parent9069523d7779bfbb48d1bafb752a2e04c65eca80 (diff)
downloadports-397ab3211ddffc1b7c2fe14f5993f749cb2d0584.tar.gz
ports-397ab3211ddffc1b7c2fe14f5993f749cb2d0584.zip
Update to 1.26
Notes
Notes: svn path=/head/; revision=24193
Diffstat (limited to 'emulators/snes9x')
-rw-r--r--emulators/snes9x/Makefile8
-rw-r--r--emulators/snes9x/distinfo2
-rw-r--r--emulators/snes9x/files/patch-ae50
3 files changed, 29 insertions, 31 deletions
diff --git a/emulators/snes9x/Makefile b/emulators/snes9x/Makefile
index de7f442b0bf0..e19a67f3aab1 100644
--- a/emulators/snes9x/Makefile
+++ b/emulators/snes9x/Makefile
@@ -1,17 +1,17 @@
# New ports collection makefile for: snes9x
-# Version required: 119a
+# Version required: 1.26
# Date created: 20 July 1997
# Whom: Yukihiro Nakai<Nakai@Mlab.t.u-tokyo.ac.jp>
#
# $FreeBSD$
#
-DISTNAME= s9xs125
-PKGNAME= snes9x-1.25
+DISTNAME= s9xs126
+PKGNAME= snes9x-1.26
CATEGORIES= emulators
MASTER_SITES= http://www.snes9x.com/zips/
-MAINTAINER= nacai@iname.com
+MAINTAINER= nakai@FreeBSD.org
.if ${MACHINE_ARCH} == i386
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
diff --git a/emulators/snes9x/distinfo b/emulators/snes9x/distinfo
index eb6ab28be26c..b90b0f1de820 100644
--- a/emulators/snes9x/distinfo
+++ b/emulators/snes9x/distinfo
@@ -1 +1 @@
-MD5 (s9xs125.zip) = 522ec53df3c3531349cc44357215f084
+MD5 (s9xs126.zip) = 8abfad0ff46c230b65f5d56b132748cb
diff --git a/emulators/snes9x/files/patch-ae b/emulators/snes9x/files/patch-ae
index 480c4a0ed998..42af8887b9c5 100644
--- a/emulators/snes9x/files/patch-ae
+++ b/emulators/snes9x/files/patch-ae
@@ -1,18 +1,19 @@
diff -ruN ./Makefile ../release/Makefile
--- ./Makefile Wed Sep 15 17:22:32 1999
+++ ../release/Makefile Sun Sep 19 18:41:45 1999
-@@ -3,8 +3,8 @@
+@@ -3,9 +3,9 @@
#SPC700ASM=1
NETPLAY=1
UNZIP=1
-GLIDE=1
--GUI=1
+#GLIDE=1
-+#GUI=1
+ #GUI=1
+-THREAD_SOUND=1
++#THREAD_SOUND=1
ifdef ZSNESFX
FXOBJ=i386/fxemu2b.o i386/fxemu2.o i386/fxemu2c.o i386/fxtable.o i386/sfxproc.o i386/zsnes.o
-@@ -67,13 +67,13 @@
+@@ -73,13 +73,13 @@
endif
MOC = $(QTDIR)/bin/moc
@@ -29,7 +30,7 @@ diff -ruN ./Makefile ../release/Makefile
#OPTIMISE=-g -fno-exceptions
#-DMITSHM
-@@ -81,7 +81,6 @@
+@@ -87,7 +87,6 @@
-Ii386 \
-I. \
-Iunzip \
@@ -37,7 +38,7 @@ diff -ruN ./Makefile ../release/Makefile
-DZLIB \
-DNO_INLINE_SET_GET \
-DVAR_CYCLES \
-@@ -94,7 +93,8 @@
+@@ -100,7 +99,8 @@
$(NETPLAYDEFINES) \
$(UNZIPDEFINES) \
$(GLIDEDEFINES) \
@@ -47,7 +48,7 @@ diff -ruN ./Makefile ../release/Makefile
#-DSOUND
#-DDEBUGGER
-@@ -106,12 +106,12 @@
+@@ -112,12 +112,12 @@
CFLAGS=$(CCFLAGS)
.SUFFIXES: .o .cpp .c .cc .h .m .i .S .asm
@@ -63,7 +64,7 @@ diff -ruN ./Makefile ../release/Makefile
endif
#ggisnes9x
-@@ -230,5 +230,4 @@
+@@ -236,5 +236,4 @@
snaporig.o: cpuexec.h
unix/x11.o: snes9x.h port.h
unix/glide.o: snes9x.h port.h 3d.h
@@ -441,19 +442,19 @@ Binary files ./snes9x and ../release/snes9x differ
diff -ruN ./unix/unix.cpp ../release/unix/unix.cpp
--- ./unix/unix.cpp Sat Sep 18 09:18:08 1999
+++ ../release/unix/unix.cpp Sun Sep 19 18:41:45 1999
-@@ -48,18 +48,21 @@
- #include <sys/types.h>
+@@ -49,7 +49,7 @@
#include <ctype.h>
+
-#if defined(__linux) || defined(__sun)
+#if defined(__linux) || defined(__sun) || defined(__FreeBSD__)
+ #undef USE_THREADS
+ #define USE_THREADS
#include <unistd.h>
- #include <sys/types.h>
- #include <sys/ioctl.h>
- #include <sys/time.h>
- #include <signal.h>
--#endif
--
+@@ -66,8 +66,12 @@
+ pthread_mutex_t mutex;
+ #endif
+
+#ifndef __sun
#ifdef __linux
#include <sys/soundcard.h>
@@ -462,11 +463,8 @@ diff -ruN ./unix/unix.cpp ../release/unix/unix.cpp
+#endif
#include <sys/mman.h>
#endif
-+#endif
- #ifdef __sun
- #ifdef __SVR4
-@@ -73,6 +76,10 @@
+@@ -83,6 +87,10 @@
typedef void (*SIG_PF)();
#endif
@@ -477,7 +475,7 @@ diff -ruN ./unix/unix.cpp ../release/unix/unix.cpp
#include "snes9x.h"
#include "memmap.h"
#include "debug.h"
-@@ -149,7 +156,7 @@
+@@ -159,7 +167,7 @@
char *rom_filename = NULL;
char *snapshot_filename = NULL;
@@ -486,7 +484,7 @@ diff -ruN ./unix/unix.cpp ../release/unix/unix.cpp
static void sigbrkhandler(int)
{
#ifdef DEBUGGER
-@@ -392,7 +399,7 @@
+@@ -402,7 +410,7 @@
#if !defined(__MSDOS) && defined(DEBUGGER)
#if defined(__unix) && !defined(__NeXT__)
struct sigaction sa;
@@ -495,7 +493,7 @@ diff -ruN ./unix/unix.cpp ../release/unix/unix.cpp
sa.sa_handler = sigbrkhandler;
#else
sa.sa_handler = (SIG_PF) sigbrkhandler;
-@@ -1379,7 +1386,7 @@
+@@ -1397,7 +1405,7 @@
}
#endif
@@ -504,7 +502,7 @@ diff -ruN ./unix/unix.cpp ../release/unix/unix.cpp
static int Rates[8] =
{
0, 8192, 11025, 16500, 22050, 29300, 36600, 44000
-@@ -1496,7 +1503,7 @@
+@@ -1514,7 +1522,7 @@
}
#endif
@@ -513,9 +511,9 @@ diff -ruN ./unix/unix.cpp ../release/unix/unix.cpp
void S9xUnixProcessSound (void)
{
}
-@@ -1579,7 +1586,7 @@
+@@ -1613,7 +1621,7 @@
- void S9xProcessSound ()
+ void *S9xProcessSound (void *)
{
-#ifdef __linux
+#if defined(__linux) || defined(__FreeBSD__)