aboutsummaryrefslogtreecommitdiff
path: root/emulators/snes9x
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1999-03-31 14:01:19 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1999-03-31 14:01:19 +0000
commit468b815704aca7d7920a2bf4454b3ec5f037b261 (patch)
treef3e3755a208980145b2ef91af3550c167c90641d /emulators/snes9x
parentaf42b6bd12935be648cdd060bb31387512b56f45 (diff)
downloadports-468b815704aca7d7920a2bf4454b3ec5f037b261.tar.gz
ports-468b815704aca7d7920a2bf4454b3ec5f037b261.zip
Update to 118e
Now it comes with sound! But disabled the joystick PR: ports/10852 Submitted by: nakai@internetsolutions.co.jp
Notes
Notes: svn path=/head/; revision=17497
Diffstat (limited to 'emulators/snes9x')
-rw-r--r--emulators/snes9x/Makefile9
-rw-r--r--emulators/snes9x/distinfo2
-rw-r--r--emulators/snes9x/files/patch-aa57
-rw-r--r--emulators/snes9x/files/patch-ab45
-rw-r--r--emulators/snes9x/files/patch-ad11
5 files changed, 44 insertions, 80 deletions
diff --git a/emulators/snes9x/Makefile b/emulators/snes9x/Makefile
index e8e012d05eab..1aad7d0ef3fa 100644
--- a/emulators/snes9x/Makefile
+++ b/emulators/snes9x/Makefile
@@ -1,13 +1,13 @@
# New ports collection makefile for: snes9x
-# Version required: 116a
+# Version required: 118e
# Date created: 20 July 1997
# Whom: Yukihiro Nakai<Nakai@Mlab.t.u-tokyo.ac.jp>
#
-# $Id: Makefile,v 1.6 1999/01/12 16:51:07 vanilla Exp $
+# $Id: Makefile,v 1.7 1999/02/03 11:11:42 asami Exp $
#
-DISTNAME= snes116a
-PKGNAME= snes9x-116a
+DISTNAME= snes118e
+PKGNAME= snes9x-118e
CATEGORIES= emulators
MASTER_SITES= http://www.snes9x.com/zips/
EXTRACT_SUFX= .zip
@@ -23,6 +23,7 @@ ONLY_FOR_ARCHS= i386
USE_GMAKE= YES
USE_X_PREFIX= YES
MAKEFILE= Makefile.linux
+ALL_TARGET= snes9x s9xserver
EXTRACT_CMD= unzip
EXTRACT_BEFORE_ARGS= # empty
diff --git a/emulators/snes9x/distinfo b/emulators/snes9x/distinfo
index 4d85d227f6cd..397ae1a38610 100644
--- a/emulators/snes9x/distinfo
+++ b/emulators/snes9x/distinfo
@@ -1 +1 @@
-MD5 (snes116a.zip) = 76487bcdd362065bdf6877413f895243
+MD5 (snes118e.zip) = 676e4509c80031e8dd9938cd6e68f5d1
diff --git a/emulators/snes9x/files/patch-aa b/emulators/snes9x/files/patch-aa
index ba1cca9505e1..9014e7a7f906 100644
--- a/emulators/snes9x/files/patch-aa
+++ b/emulators/snes9x/files/patch-aa
@@ -1,16 +1,23 @@
---- Makefile.linux.orig Mon Dec 21 14:40:08 1998
-+++ Makefile.linux Sun Jan 10 10:32:23 1999
-@@ -1,8 +1,8 @@
--ZSNESFX=1
-+#ZSNESFX=1
- ASMCPU=1
- #SPC700ASM=1
- NETPLAY=1
--UNZIP=1
-+#UNZIP=1
+--- Makefile.linux.orig Sat Mar 27 15:19:07 1999
++++ Makefile.linux Sat Mar 27 15:31:11 1999
+@@ -5,7 +5,7 @@
+ UNZIP=1
ifdef ZSNESFX
- FXOBJ=i386/zsnes.o
+-FXOBJ=i386/zsnes.o
++FXOBJ=i386/zsnes.o fxinst.o fxemu.o fxdbg.o
+ FXDEFINES=-DZSNES_FX -DEXECUTE_SUPERFX_PER_LINE
+ FXDEPENDS=zsnes_fx
+ FXNO_DEPENDS=c_fx
+@@ -16,7 +16,7 @@
+ FXNO_DEPENDS=zsnes_fx
+ endif
+
+-LINUXDEFINES=-DUSE_DGA_EXTENSION -DUSE_VIDMODE_EXTENSION
++LINUXDEFINES=-DUSE_DGA_EXTENSION -DUSE_VIDMODE_EXTENSION -D__linux
+
+ ifdef ASMCPU
+ ifdef SPC700ASM
@@ -47,8 +47,8 @@
UNZIPDEFINES=-DUNZIP_SUPPORT
endif
@@ -22,37 +29,11 @@
NASM = nasm
INCLUDES=-I/usr/X11R6/include -I/usr/local/include
-@@ -58,7 +58,7 @@
+@@ -59,7 +59,6 @@
-Ii386 \
-I. \
-Iunzip \
--DJOYSTICK_SUPPORT \
-+#-DJOYSTICK_SUPPORT \
-DZLIB \
-DNO_INLINE_SET_GET \
-DVAR_CYCLES \
-@@ -84,9 +84,9 @@
- LDLIBS = -L/usr/X11R6/lib
-
- ifdef NETPLAY
--all: offsets snes9x ssnes9x s9xserver
-+all: offsets snes9x s9xserver
- else
--all: offsets snes9x ssnes9x
-+all: offsets snes9x
- endif
-
- #ggisnes9x
-@@ -101,10 +101,10 @@
- ./offsets >i386/offsets.h
-
- snes9x: $(OBJECTS) unix/x11.o
-- $(CCC) $(INCLUDES) -o $@ $(OBJECTS) unix/x11.o $(LDLIBS) -lXext -lX11 -lXxf86dga -lXxf86vm -lgz -lm
-+ $(CCC) $(INCLUDES) -o $@ $(OBJECTS) unix/x11.o $(LDLIBS) -lXext -lX11 -lXxf86dga -lXxf86vm -lz -lm
-
- xf86snes9x: $(OBJECTS) unix/xf86.o
-- $(CCC) $(INCLUDES) -o $@ $(OBJECTS) unix/xf86.o $(LDLIBS) -lXext -lX11 -lXxf86dga -lXxf86vm -lgz -lm
-+ $(CCC) $(INCLUDES) -o $@ $(OBJECTS) unix/xf86.o $(LDLIBS) -lXext -lX11 -lXxf86dga -lXxf86vm -lz -lm
- /bin/chmod u+s xf86snes9x
-
- ssnes9x: $(OBJECTS) unix/svga.o
diff --git a/emulators/snes9x/files/patch-ab b/emulators/snes9x/files/patch-ab
index f4bc11df104d..cb64626184b5 100644
--- a/emulators/snes9x/files/patch-ab
+++ b/emulators/snes9x/files/patch-ab
@@ -1,40 +1,11 @@
---- unix/unix.cpp.orig Mon Dec 21 15:09:16 1998
-+++ unix/unix.cpp Sun Jan 10 10:28:58 1999
-@@ -71,6 +71,10 @@
- #if defined(__sun) && defined(__GNUC__)
- typedef void (*SIG_PF)();
+--- port.h.orig Sat Mar 27 15:23:53 1999
++++ port.h Sat Mar 27 16:24:39 1999
+@@ -125,7 +125,7 @@
+ #define SLASH_CHAR '/'
#endif
-+#if defined (__FreeBSD__)
-+typedef void (*SIG_PF)();
-+#endif
-+
- #include "snes9x.h"
- #include "memmap.h"
-@@ -302,7 +306,7 @@
- Settings.SoundBufferSize = 0;
- Settings.SPCTo65c816Ratio = 2;
- Settings.DisableSoundEcho = FALSE;
-- Settings.APUEnabled = TRUE;
-+ Settings.APUEnabled = FALSE;
- Settings.H_Max = (100 * SNES_CYCLES_PER_SCANLINE) / 100;
- Settings.SkipFrames = AUTO_FRAMERATE;
- Settings.Shutdown = TRUE;
-@@ -983,7 +987,7 @@
- #if defined(__linux)
- sa.sa_handler = (SIG_PF) SoundTrigger;
- #else
-- sa.sa_handler = (SIG_PF) SoundTrigger;
-+ sa.sa_handler = (void*) SoundTrigger;
+-#ifdef __linux
++#if defined(__linux) || defined(__FreeBSD__)
+ typedef void (*SignalHandler)(int);
+ #define SIG_PF SignalHandler
#endif
-
- #if defined (SA_RESTART)
-@@ -1615,7 +1619,7 @@
- stretch = get_config_int("Graphics", "Scale", 0);
- _vsync = get_config_int("Graphics", "VSync", 0);
-
-- Settings.APUEnabled = get_config_int("Sound", "APUEnabled", TRUE);
-+ Settings.APUEnabled = get_config_int("Sound", "APUEnabled", FALSE);
- Settings.SoundPlaybackRate = get_config_int("Sound", "SoundPlaybackRate", 4);
- Settings.Stereo = get_config_int("Sound", "Stereo", TRUE);
- Settings.SoundBufferSize = get_config_int("Sound", "SoundBufferSize", 256);
diff --git a/emulators/snes9x/files/patch-ad b/emulators/snes9x/files/patch-ad
new file mode 100644
index 000000000000..310155cdf69a
--- /dev/null
+++ b/emulators/snes9x/files/patch-ad
@@ -0,0 +1,11 @@
+--- unix/unix.cpp.orig Sat Mar 27 15:20:06 1999
++++ unix/unix.cpp Sat Mar 27 15:20:14 1999
+@@ -57,7 +57,7 @@
+ #endif
+
+ #ifdef __linux
+-#include <sys/soundcard.h>
++#include <machine/soundcard.h>
+ #endif
+
+ #ifdef __sun