aboutsummaryrefslogtreecommitdiff
path: root/emulators/snespp/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-17 19:35:08 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-17 19:35:08 +0000
commitb980b3e3a26736fa807575012d7ecb2dd8618599 (patch)
tree353bdc537b8eb9b2393a4bd151ad7e40d5680609 /emulators/snespp/Makefile
parentfd3a00a156ebeaea48923a1878f597a261e22be2 (diff)
downloadports-b980b3e3a26736fa807575012d7ecb2dd8618599.tar.gz
ports-b980b3e3a26736fa807575012d7ecb2dd8618599.zip
snespp is a kernel module for Super NES/Famicon controllers interfaced via a
parallel port. It appears as a keyboard: buttons on the controllers send key strokes to the operating system. snespp works under both the system console and X windows, using the microseq interface to reduce overhead. WWW: http://www.cse.unsw.edu.au/~tbourke/software/snespp.html PR: ports/111721 Submitted by: Timothy Bourke <timbob at bigpond.com>
Notes
Notes: svn path=/head/; revision=190226
Diffstat (limited to 'emulators/snespp/Makefile')
-rw-r--r--emulators/snespp/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/emulators/snespp/Makefile b/emulators/snespp/Makefile
new file mode 100644
index 000000000000..9afab0539515
--- /dev/null
+++ b/emulators/snespp/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: snespp
+# Date created: 16 April 2007
+# Whom: Timothy Bourke <timbob@bigpond.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= snespp
+PORTVERSION= 1.0
+CATEGORIES= emulators
+MASTER_SITES= http://www.cse.unsw.edu.au/~tbourke/software/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= timbob@bigpond.com
+COMMENT= Kernel module for SNES controllers on a parallel port
+
+KMODDIR= /boot/modules
+
+NO_PACKAGE= this port should be recompiled for a particular FreeBSD kernel
+PLIST_SUB= KMODDIR="${KMODDIR}"
+
+MAN4= snespp.4
+MANCOMPRESSED= no
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600000
+IGNORE= versions of FreeBSD before 6.0 are not supported
+.endif
+
+do-install:
+ @${INSTALL_MAN} ${WRKSRC}/snespp.4 ${PREFIX}/man/man4
+ @${INSTALL_PROGRAM} ${WRKSRC}/snespp.ko ${KMODDIR}
+
+.include <bsd.port.post.mk>