aboutsummaryrefslogtreecommitdiff
path: root/emulators/stella
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-20 15:25:23 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-20 15:25:23 +0000
commite2f122bec64d6f5b616a16fac7f3ec2db548cfce (patch)
tree83cd09775567fafdd55d55c009eb1685883fc9ea /emulators/stella
parent9caac1043e2f7781cef39db4330a288005929812 (diff)
downloadports-e2f122bec64d6f5b616a16fac7f3ec2db548cfce.tar.gz
ports-e2f122bec64d6f5b616a16fac7f3ec2db548cfce.zip
Update to version 1.4
PR: ports/69293 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=114296
Diffstat (limited to 'emulators/stella')
-rw-r--r--emulators/stella/Makefile25
-rw-r--r--emulators/stella/distinfo4
-rw-r--r--emulators/stella/files/patch-ac84
-rw-r--r--emulators/stella/files/patch-src::emucore::Props.cxx38
-rw-r--r--emulators/stella/files/patch-src::emucore::Props.hxx37
-rw-r--r--emulators/stella/files/patch-src::emucore::PropsSet.cxx19
-rw-r--r--emulators/stella/files/patch-src::emucore::PropsSet.hxx20
-rw-r--r--emulators/stella/files/patch-src::emucore::TIASound.c30
-rw-r--r--emulators/stella/files/patch-src::emucore::m6502::src::M6502.cxx11
-rw-r--r--emulators/stella/files/patch-src::emucore::m6502::src::M6502.hxx11
-rw-r--r--emulators/stella/files/patch-src::ui::common::Settiongs.cxx11
-rw-r--r--emulators/stella/files/patch-src::ui::common::Settiongs.hxx11
-rw-r--r--emulators/stella/files/patch-src::ui::sound::SoundOSS.cxx15
-rw-r--r--emulators/stella/pkg-plist2
14 files changed, 29 insertions, 289 deletions
diff --git a/emulators/stella/Makefile b/emulators/stella/Makefile
index 0b593c733f91..fc1cbd6122a0 100644
--- a/emulators/stella/Makefile
+++ b/emulators/stella/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= stella
-PORTVERSION= 1.3
-PORTREVISION= 2
+PORTVERSION= 1.4
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,22 +20,22 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/src/build
-USE_XLIB= yes
+USE_GCC= 3.3
+USE_GNOME= pkgconfig
+USE_SDL= sdl
USE_GMAKE= yes
MAKEFILE= makefile
-PLIST_SUB= STELLA_BIN="${STELLA_BIN}"
+MAKE_ARGS= CXX="${CXX}" LD="${CXX}" OPTIMIZATIONS="${CXXFLAGS}" \
+ SYS_INCLUDES="${CPPFLAGS}" LDFLAGS="" LDLIBS="${LDFLAGS}"
+ALL_TARGET= linux-gl
-.if defined(WITHOUT_SDL)
-ALL_TARGET= freebsd-x
-STELLA_BIN= stella.x11
-.else
-USE_SDL= sdl
-ALL_TARGET= freebsd-sdl
-STELLA_BIN= stella.sdl
-.endif
+CPPFLAGS= `${SDL_CONFIG} --cflags` `pkg-config --cflags libpng12` \
+ -I${X11BASE}/include
+LDFLAGS= `${SDL_CONFIG} --libs` `pkg-config --libs libpng12` \
+ -L${X11BASE}/lib
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/build/${STELLA_BIN} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/build/stella ${PREFIX}/bin
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/src/emucore/stella.pro ${DATADIR}
.if !defined(NOPORTDOCS)
diff --git a/emulators/stella/distinfo b/emulators/stella/distinfo
index d004e8ae5d14..e0392347e5e0 100644
--- a/emulators/stella/distinfo
+++ b/emulators/stella/distinfo
@@ -1,2 +1,2 @@
-MD5 (stella-1.3-src.tar.gz) = b9318f82a180ff0a404fca78511b2772
-SIZE (stella-1.3-src.tar.gz) = 433201
+MD5 (stella-1.4-src.tar.gz) = dc2496a46eb823aa9994c77a7f62cf62
+SIZE (stella-1.4-src.tar.gz) = 670366
diff --git a/emulators/stella/files/patch-ac b/emulators/stella/files/patch-ac
deleted file mode 100644
index 13a3ea491c24..000000000000
--- a/emulators/stella/files/patch-ac
+++ /dev/null
@@ -1,84 +0,0 @@
---- src/build/makefile.orig Tue Feb 18 10:19:44 2003
-+++ src/build/makefile Tue Sep 16 21:48:28 2003
-@@ -23,7 +23,7 @@
- ## Comment a line out to disable that option, remove comment to enable it.
- ##============================================================================
-
--OPTIMIZATIONS = -O2 -Wall -Wno-unused
-+# OPTIMIZATIONS = -O2 -Wall -Wno-unused
- ### to get full optimization under gcc/x Intel based OS's..
- # OPTIMIZATIONS = -O3 -mcpu=pentiumpro -march=pentiumpro -Wall -Wno-unused \
- # -funroll-loops -fstrength-reduce -fomit-frame-pointer -ffast-math \
-@@ -61,7 +61,7 @@
- ### to include support for saving snapshots in png format
- ### (requires PNG library)
- ### Only X11 and SDL ports supported for now
--# SNAPSHOT_SUPPORT = 1
-+SNAPSHOT_SUPPORT = 1
-
- ### comment this out if your system doesn't
- ### have the gettimeofday function
-@@ -79,8 +79,8 @@
- ## No configurable options below this line ...
- ##============================================================================
-
--CXX = g++
--LD = g++
-+CXX ?= g++
-+LD = $(CXX)
-
- LDFLAGS =
- LDLIBS =
-@@ -92,8 +92,8 @@
-
- OBJS.SDL =
- OPTS.SDL =
--LIBS.SDL = `sdl-config --libs`
--CFLAGS.SDL = `sdl-config --cflags`
-+LIBS.SDL = `${SDL_CONFIG} --libs`
-+CFLAGS.SDL = `${SDL_CONFIG} --cflags`
-
- OPTS.DOS =
-
-@@ -103,7 +103,7 @@
-
- INCLUDES = -I. -I$(CORE) -I$(CORE)/m6502/src -I$(CORE)/m6502/src/bspf/src -I$(UI)/common
-
--CXXFLAGS = $(OPTIMIZATIONS) $(INCLUDES) $(SYS_INCLUDES)
-+CXXFLAGS += $(OPTIMIZATIONS) $(INCLUDES) $(SYS_INCLUDES)
-
- ## set the user-defined options
- ifdef BSPF_BOOL
-@@ -265,6 +265,32 @@
- LDLIBS+="$(LIBS.X11)" \
- OBJS="mainX11.o"
- OBJS+="$(OBJS.X11)"
-+
-+freebsd-x:
-+ $(MAKE) stella.x11 \
-+ INCLUDES="$(INCLUDES) -I$(UI)/x11 -I$(UI)/sound" \
-+ SYS_INCLUDES="-I$(X11BASE)/include -I$(LOCALBASE)/include/libpng" \
-+ OPTIONS="-DBSPF_UNIX=1" \
-+ OPTIONS+="$(OPTS.X11)" \
-+ LDFLAGS="-L$(X11BASE)/lib -L$(LOCALBASE)/lib" \
-+ LDFLAGS+="$(CFLAGS.X11)" \
-+ LDLIBS="-lX11 -lXext" \
-+ LDLIBS+="$(LIBS.X11)" \
-+ OBJS="mainX11.o" \
-+ OBJS+="$(OBJS.X11)"
-+
-+freebsd-sdl:
-+ $(MAKE) stella.sdl \
-+ INCLUDES="$(INCLUDES) -I$(UI)/sdl -I$(UI)/sound" \
-+ SYS_INCLUDES="-I$(X11BASE)/include -I$(LOCALBASE)/include/libpng" \
-+ OPTIONS="-DBSPF_UNIX=1" \
-+ OPTIONS+="$(OPTS.SDL)" \
-+ LDFLAGS="-L$(X11BASE)/lib -L$(LOCALBASE)/lib" \
-+ LDFLAGS+="$(CFLAGS.SDL)" \
-+ LDLIBS="-lX11 -lXext" \
-+ LDLIBS+="$(LIBS.SDL)" \
-+ OBJS="mainSDL.o RectList.o" \
-+ OBJS+="$(OBJS.SDL)"
-
- ###############################################################################
- ## List of "core" object files
diff --git a/emulators/stella/files/patch-src::emucore::Props.cxx b/emulators/stella/files/patch-src::emucore::Props.cxx
deleted file mode 100644
index 3cd76bdee02a..000000000000
--- a/emulators/stella/files/patch-src::emucore::Props.cxx
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/emucore/Props.cxx.orig Tue Feb 18 10:19:44 2003
-+++ src/emucore/Props.cxx Wed Sep 17 00:42:05 2003
-@@ -103,7 +103,7 @@
- }
-
- // - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
--void Properties::load(istream& in)
-+void Properties::load(std::istream& in)
- {
- // Empty my property array
- mySize = 0;
-@@ -146,7 +146,7 @@
- }
-
- // - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
--void Properties::save(ostream& out)
-+void Properties::save(std::ostream& out)
- {
- // Write out each of the key and value pairs
- for(uInt32 i = 0; i < mySize; ++i)
-@@ -164,7 +164,7 @@
- }
-
- // - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
--string Properties::readQuotedString(istream& in)
-+string Properties::readQuotedString(std::istream& in)
- {
- char c;
-
-@@ -205,7 +205,7 @@
- }
-
- // - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
--void Properties::writeQuotedString(ostream& out, const string& s)
-+void Properties::writeQuotedString(std::ostream& out, const string& s)
- {
- out.put('"');
- for(uInt32 i = 0; i < s.length(); ++i)
diff --git a/emulators/stella/files/patch-src::emucore::Props.hxx b/emulators/stella/files/patch-src::emucore::Props.hxx
deleted file mode 100644
index cd3eb971df64..000000000000
--- a/emulators/stella/files/patch-src::emucore::Props.hxx
+++ /dev/null
@@ -1,37 +0,0 @@
---- src/emucore/Props.hxx.orig Tue Feb 18 10:19:44 2003
-+++ src/emucore/Props.hxx Wed Sep 17 00:42:29 2003
-@@ -79,14 +79,14 @@
-
- @param in The input stream to use
- */
-- void load(istream& in);
-+ void load(std::istream& in);
-
- /**
- Save properties to the specified output stream
-
- @param out The output stream to use
- */
-- void save(ostream& out);
-+ void save(std::ostream& out);
-
- /**
- Merge the given properties into this properties object
-@@ -103,7 +103,7 @@
- @param in The input stream to use
- @return The string inside the quotes
- */
-- static string readQuotedString(istream& in);
-+ static string readQuotedString(std::istream& in);
-
- /**
- Write the specified string to the given output stream as a
-@@ -112,7 +112,7 @@
- @param out The output stream to use
- @param s The string to output
- */
-- static void writeQuotedString(ostream& out, const string& s);
-+ static void writeQuotedString(std::ostream& out, const string& s);
-
- public:
- /**
diff --git a/emulators/stella/files/patch-src::emucore::PropsSet.cxx b/emulators/stella/files/patch-src::emucore::PropsSet.cxx
deleted file mode 100644
index ae88bc1b2389..000000000000
--- a/emulators/stella/files/patch-src::emucore::PropsSet.cxx
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/emucore/PropsSet.cxx.orig Tue Feb 18 10:19:44 2003
-+++ src/emucore/PropsSet.cxx Wed Sep 17 00:47:25 2003
-@@ -203,14 +203,14 @@
- }
-
- // - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
--void PropertiesSet::save(ostream& out)
-+void PropertiesSet::save(std::ostream& out)
- {
- saveNode(out, myRoot);
- }
-
-
- // - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
--void PropertiesSet::saveNode(ostream& out, TreeNode *node)
-+void PropertiesSet::saveNode(std::ostream& out, TreeNode *node)
- {
- if(node)
- {
diff --git a/emulators/stella/files/patch-src::emucore::PropsSet.hxx b/emulators/stella/files/patch-src::emucore::PropsSet.hxx
deleted file mode 100644
index 541310e9f7de..000000000000
--- a/emulators/stella/files/patch-src::emucore::PropsSet.hxx
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/emucore/PropsSet.hxx.orig Tue Feb 18 10:19:44 2003
-+++ src/emucore/PropsSet.hxx Wed Sep 17 00:47:27 2003
-@@ -75,7 +75,7 @@
-
- @param out The output stream to use
- */
-- void save(ostream& out);
-+ void save(std::ostream& out);
-
- /**
- Get the number of properties in the collection.
-@@ -134,7 +134,7 @@
- @param out The output stream to use
- @param node The current subroot of the tree
- */
-- void saveNode(ostream& out, TreeNode *node);
-+ void saveNode(std::ostream& out, TreeNode *node);
-
- // The root of the BST
- TreeNode* myRoot;
diff --git a/emulators/stella/files/patch-src::emucore::TIASound.c b/emulators/stella/files/patch-src::emucore::TIASound.c
index 5d38df64e83a..25c28f8fa398 100644
--- a/emulators/stella/files/patch-src::emucore::TIASound.c
+++ b/emulators/stella/files/patch-src::emucore::TIASound.c
@@ -1,18 +1,16 @@
---- src/emucore/TIASound.c.orig Tue Feb 18 02:19:44 2003
-+++ src/emucore/TIASound.c Wed Sep 24 15:51:58 2003
-@@ -171,11 +171,13 @@
- {
- uint8 chan;
- int16 n;
--
-+
+--- src/emucore/TIASound.c.orig Mon Jun 14 04:22:45 2004
++++ src/emucore/TIASound.c Sun Jul 18 18:43:44 2004
+@@ -173,10 +173,12 @@
+ uint8 chan;
+ int16 n;
+
+ srandom(time(NULL));
+
- /* fill the 9bit polynomial with random bits */
- for (n=0; n<POLY9_SIZE; n++)
- {
-- Bit9[n] = rand() & 0x01; /* fill poly9 with random bits */
-+ Bit9[n] = random() & 0x01; /* fill poly9 with random bits */
- }
-
- /* calculate the sample 'divide by N' value based on the playback freq. */
+ /* fill the 9bit polynomial with random bits */
+ for (n=0; n<POLY9_SIZE; n++)
+ {
+- Bit9[n] = rand() & 0x01; /* fill poly9 with random bits */
++ Bit9[n] = random() & 0x01; /* fill poly9 with random bits */
+ }
+
+ /* calculate the sample 'divide by N' value based on the playback freq. */
diff --git a/emulators/stella/files/patch-src::emucore::m6502::src::M6502.cxx b/emulators/stella/files/patch-src::emucore::m6502::src::M6502.cxx
deleted file mode 100644
index 3a994e679b97..000000000000
--- a/emulators/stella/files/patch-src::emucore::m6502::src::M6502.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/emucore/m6502/src/M6502.cxx.orig Tue Feb 18 10:19:44 2003
-+++ src/emucore/m6502/src/M6502.cxx Wed Sep 17 00:45:41 2003
-@@ -128,7 +128,7 @@
- }
-
- // - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
--ostream& operator<<(ostream& out, const M6502::AddressingMode& mode)
-+std::ostream& operator<<(std::ostream& out, const M6502::AddressingMode& mode)
- {
- switch(mode)
- {
diff --git a/emulators/stella/files/patch-src::emucore::m6502::src::M6502.hxx b/emulators/stella/files/patch-src::emucore::m6502::src::M6502.hxx
deleted file mode 100644
index 85705ba0ab6a..000000000000
--- a/emulators/stella/files/patch-src::emucore::m6502::src::M6502.hxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/emucore/m6502/src/M6502.hxx.orig Tue Feb 18 10:19:44 2003
-+++ src/emucore/m6502/src/M6502.hxx Wed Sep 17 00:45:41 2003
-@@ -164,7 +164,7 @@
- @param out The stream to output the addressing mode to
- @param mode The addressing mode to output
- */
-- friend ostream& operator<<(ostream& out, const AddressingMode& mode);
-+ friend std::ostream& operator<<(std::ostream& out, const AddressingMode& mode);
-
- protected:
- /**
diff --git a/emulators/stella/files/patch-src::ui::common::Settiongs.cxx b/emulators/stella/files/patch-src::ui::common::Settiongs.cxx
deleted file mode 100644
index ec288d6e2e28..000000000000
--- a/emulators/stella/files/patch-src::ui::common::Settiongs.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ui/common/Settings.cxx.orig Tue Feb 18 10:19:45 2003
-+++ src/ui/common/Settings.cxx Wed Sep 17 00:40:23 2003
-@@ -247,7 +247,7 @@
- return true;
- }
-
--void Settings::handleRCFile(istream& in)
-+void Settings::handleRCFile(std::istream& in)
- {
- string line, key, value;
- uInt32 equalPos;
diff --git a/emulators/stella/files/patch-src::ui::common::Settiongs.hxx b/emulators/stella/files/patch-src::ui::common::Settiongs.hxx
deleted file mode 100644
index ec90ed2d8e49..000000000000
--- a/emulators/stella/files/patch-src::ui::common::Settiongs.hxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ui/common/Settings.hxx.orig Tue Feb 18 10:19:45 2003
-+++ src/ui/common/Settings.hxx Wed Sep 17 00:40:23 2003
-@@ -32,7 +32,7 @@
- ~Settings();
-
- bool handleCommandLineArgs(int ac, char* av[]);
-- void handleRCFile(istream& in);
-+ void handleRCFile(std::istream& in);
-
- public:
- // Indicates whether to use fullscreen
diff --git a/emulators/stella/files/patch-src::ui::sound::SoundOSS.cxx b/emulators/stella/files/patch-src::ui::sound::SoundOSS.cxx
deleted file mode 100644
index 3c042e19ba82..000000000000
--- a/emulators/stella/files/patch-src::ui::sound::SoundOSS.cxx
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/ui/sound/SoundOSS.cxx.orig Tue Feb 18 10:19:44 2003
-+++ src/ui/sound/SoundOSS.cxx Tue Sep 16 20:10:20 2003
-@@ -22,11 +22,7 @@
- #include <sys/ioctl.h>
- #include <sys/types.h>
-
--#ifdef __FreeBSD__
-- #include <machine/soundcard.h>
--#else
-- #include <sys/soundcard.h>
--#endif
-+#include <sys/soundcard.h>
-
- #define DSP_DEVICE "/dev/dsp"
- #define MIXER_DEVICE "/dev/mixer"
diff --git a/emulators/stella/pkg-plist b/emulators/stella/pkg-plist
index f878b6fe5c5e..c50b6ecab2fc 100644
--- a/emulators/stella/pkg-plist
+++ b/emulators/stella/pkg-plist
@@ -1,4 +1,4 @@
-bin/%%STELLA_BIN%%
+bin/stella
%%PORTDOCS%%%%DOCSDIR%%/graphics/chucky_cheese.png
%%PORTDOCS%%%%DOCSDIR%%/graphics/circuit.png
%%PORTDOCS%%%%DOCSDIR%%/graphics/console.png