aboutsummaryrefslogtreecommitdiff
path: root/emulators/tme
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-11-07 23:32:51 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-11-07 23:32:51 +0000
commitf50ef7392160f2720cf5b1817c29c76d12a353da (patch)
tree90c898435ea2e5669dcc01ce6dba6aa43f7c85a9 /emulators/tme
parent91ba83568d19b5e670c68b8729278e35f0e0a5ea (diff)
downloadports-f50ef7392160f2720cf5b1817c29c76d12a353da.tar.gz
ports-f50ef7392160f2720cf5b1817c29c76d12a353da.zip
- Update to version 0.8
- Install examples - Add LICENSE PR: ports/171997 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=307150
Diffstat (limited to 'emulators/tme')
-rw-r--r--emulators/tme/Makefile62
-rw-r--r--emulators/tme/distinfo4
-rw-r--r--emulators/tme/files/patch-configure29
-rw-r--r--emulators/tme/files/patch-host__bsd__bsd-bpf.c28
-rw-r--r--emulators/tme/files/patch-ic__ieee754__iee754-misc-auto.sh11
-rw-r--r--emulators/tme/files/patch-ic__sparc__sparc-execute.c11
-rw-r--r--emulators/tme/files/patch-libtme-module.c20
-rw-r--r--emulators/tme/files/patch-machine__sun__sun-bwtwo.c27
-rw-r--r--emulators/tme/pkg-plist269
9 files changed, 321 insertions, 140 deletions
diff --git a/emulators/tme/Makefile b/emulators/tme/Makefile
index f03e9b2ca2f7..e990ab6a08b2 100644
--- a/emulators/tme/Makefile
+++ b/emulators/tme/Makefile
@@ -1,28 +1,64 @@
-# New ports collection makefile for: tme
-# Date created: 2006-12-14
-# Whom: trasz <trasz@pin.if.uz.zgora.pl>
-#
+# Created by: trasz <trasz@pin.if.uz.zgora.pl>
# $FreeBSD$
-#
PORTNAME= tme
-PORTVERSION= 0.6
-PORTREVISION= 3
+PORTVERSION= 0.8
CATEGORIES= emulators
MASTER_SITES= http://people.csail.mit.edu/fredette/tme/
MAINTAINER= ports@FreeBSD.org
COMMENT= Emulator for Sun 2/120, 3/150, and SPARCstation 2 machines
-GNU_CONFIGURE= yes
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ cairo:${PORTSDIR}/graphics/cairo \
+ png15:${PORTSDIR}/graphics/png \
+ freetype:${PORTSDIR}/print/freetype2 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
+
+USE_GNOME= gdkpixbuf2 gtk20
+USE_PERL5= yes
USE_GMAKE= yes
-USE_XORG= x11
-USE_GNOME= gtk12
-CONFIGURE_ARGS+= --disable-shared
+USE_ICONV= yes
+USE_GETTEXT= yes
+USE_AUTOTOOLS= libtool libltdl
+CONFIGURE_ENV= ac_cv_have_isinff=no
+CONFIGURE_ARGS= --datadir=${WRKDIR}/tmproot --disable-warnings
+USE_PKGCONFIG= build
+USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext xfixes \
+ xi xinerama xrandr xrender
+USE_LDCONFIG= yes
MAKE_ENV= LANG=C
-MAKE_JOBS_UNSAFE= yes
+MAKE_JOBS_UNSAFE=yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${WRKSRC}/ic/ieee754/.libs
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.options.mk>
post-patch:
- ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/libtme/module.c
+ @${REINPLACE_CMD} -e '/misc_hosts/s|= no|= xno|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|\.\./ieee754|$$(top_builddir)/ic/ieee754|g' \
+ ${WRKSRC}/ic/m68k/Makefile.in
+ @${REINPLACE_CMD} -e 's|\.\./ieee754|$$(top_builddir)/ic/ieee754|g' \
+ ${WRKSRC}/ic/sparc/Makefile.in
+ @${REINPLACE_CMD} -e '/^#ifdef/s|\*/||' \
+ ${WRKSRC}/libtme/misc.c
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
+ ${WRKSRC}/libtme/module.c
+
+post-install:
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKDIR}/tmproot/examples/tme \
+ && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
+.endif
.include <bsd.port.mk>
diff --git a/emulators/tme/distinfo b/emulators/tme/distinfo
index 5cf4f7a510f2..cc5327587d4c 100644
--- a/emulators/tme/distinfo
+++ b/emulators/tme/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tme-0.6.tar.gz) = 97293c113cbcca0da533c26ec576dbad4ed6f8c702875b3b7949c6538a063f19
-SIZE (tme-0.6.tar.gz) = 1700273
+SHA256 (tme-0.8.tar.gz) = 7aa07fd60a574b2a248bbd22bfa68bcb39e6dddd4a678791b1a085e11d1badfd
+SIZE (tme-0.8.tar.gz) = 2100123
diff --git a/emulators/tme/files/patch-configure b/emulators/tme/files/patch-configure
deleted file mode 100644
index 2fb32d84ada6..000000000000
--- a/emulators/tme/files/patch-configure
+++ /dev/null
@@ -1,29 +0,0 @@
---- configure.orig Sun May 15 03:26:11 2005
-+++ configure Fri Feb 2 16:39:50 2007
-@@ -8890,7 +8890,7 @@
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
-- ac_cv_have_isinff=yes
-+ ac_cv_have_isinff=no
- else
- echo "$as_me: failed program was:" >&5
- sed 's/^/| /' conftest.$ac_ext >&5
-@@ -15113,7 +15113,7 @@
- ;;
-
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-+ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo elf`
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
-@@ -25853,7 +25853,7 @@
- enable_warnings=yes
- fi;
- if test "x$enable_warnings" = "xyes" -a "x$GCC" = "xyes"; then
-- CFLAGS="${CFLAGS-} -Wundef -Wall -Werror"
-+ CFLAGS="${CFLAGS-} -Wundef -Wall"
- CXXFLAGS="${CXXFLAGS-} -W"
- fi
-
diff --git a/emulators/tme/files/patch-host__bsd__bsd-bpf.c b/emulators/tme/files/patch-host__bsd__bsd-bpf.c
new file mode 100644
index 000000000000..cbf3e8e6bc14
--- /dev/null
+++ b/emulators/tme/files/patch-host__bsd__bsd-bpf.c
@@ -0,0 +1,28 @@
+--- host/bsd/bsd-if.c.orig 2003-10-16 02:48:23.000000000 +0000
++++ host/bsd/bsd-if.c 2012-07-07 12:24:22.000000000 +0000
+@@ -71,14 +72,15 @@
+
+ /* this macro helps us size a struct ifreq: */
+ #ifdef HAVE_SOCKADDR_SA_LEN
+-#define SIZEOF_IFREQ(ifr) (sizeof(ifr->ifr_name) + ifr->ifr_addr.sa_len)
++#define SIZEOF_IFREQ(ifr) \
++( sizeof(ifr->ifr_name) + (ifr->ifr_addr.sa_len > sizeof(ifr->ifr_ifru) ? ifr->ifr_addr.sa_len : sizeof(ifr->ifr_ifru)) )
+ #else /* !HAVE_SOCKADDR_SA_LEN */
+ #define SIZEOF_IFREQ(ifr) (sizeof(ifr->ifr_name) + sizeof(struct sockaddr))
+ #endif /* !HAVE_SOCKADDR_SA_LEN */
+
+ /* this finds a network interface: */
+ int
+ tme_bsd_if_find(const char *ifr_name_user, struct ifreq **_ifreq, tme_uint8_t **_if_addr, unsigned int *_if_addr_size)
+ {
+ int saved_errno;
+ int dummy_fd;
+@@ -175,7 +192,7 @@
+ if (ifr_user == NULL
+ && (ifr_name_user != NULL
+ ? !strncmp(ifr->ifr_name, ifr_name_user, sizeof(ifr->ifr_name))
+- : !(ifr->ifr_flags & IFF_LOOPBACK))) {
++ : !(saved_flags & IFF_LOOPBACK))) {
+ ifr_user = ifr;
+ }
+ }
diff --git a/emulators/tme/files/patch-ic__ieee754__iee754-misc-auto.sh b/emulators/tme/files/patch-ic__ieee754__iee754-misc-auto.sh
new file mode 100644
index 000000000000..f8807b65c848
--- /dev/null
+++ b/emulators/tme/files/patch-ic__ieee754__iee754-misc-auto.sh
@@ -0,0 +1,11 @@
+--- ic/ieee754/ieee754-misc-auto.sh.orig 2007-08-24 01:05:43.000000000 +0000
++++ ic/ieee754/ieee754-misc-auto.sh
+@@ -106,7 +106,7 @@ typedef float tme_ieee754_${precision}_b
+ #elif (TME_FLOAT_FORMAT_IEEE754_${capprecision}_BUILTIN == TME_FLOAT_FORMAT_DOUBLE)
+ typedef double tme_ieee754_${precision}_builtin_t;
+ #define tme_float_value_ieee754_${precision}_builtin tme_float_value_double
+-#elif (TME_FLOAT_FORMAT_IEEE754_${capprecision}_BUILTIN == TME_FLOAT_FORMAT_LONG_DOUBLE)
++#elif (defined(_TME_HAVE_LONG_DOUBLE) && (TME_FLOAT_FORMAT_IEEE754_${capprecision}_BUILTIN == TME_FLOAT_FORMAT_LONG_DOUBLE))
+ typedef long double tme_ieee754_${precision}_builtin_t;
+ #define tme_float_value_ieee754_${precision}_builtin tme_float_value_long_double
+ #endif
diff --git a/emulators/tme/files/patch-ic__sparc__sparc-execute.c b/emulators/tme/files/patch-ic__sparc__sparc-execute.c
new file mode 100644
index 000000000000..ba0eaee0e2e5
--- /dev/null
+++ b/emulators/tme/files/patch-ic__sparc__sparc-execute.c
@@ -0,0 +1,11 @@
+--- ic/sparc/sparc-execute.c 2010-02-21 06:58:15.000000000 +0900
++++ ic/sparc/sparc-execute.c 2010-04-14 22:55:50.000000000 +0900
+@@ -612,7 +612,7 @@
+ != pc_previous)) {
+ if (__tme_predict_true(((tme_sparc_ireg_t) (pc + sizeof(tme_uint32_t)))
+ == ic->tme_sparc_ireg(TME_SPARC_IREG_PC_NEXT))) {
+- tme_recode_thunk_off_t insns_thunk;
++ tme_recode_thunk_off_t insns_thunk = 0; /* XXX gcc -Wuninitialized */
+
+ /* if the current instruction TLB entry is not the invalid TLB
+ entry, and there is an instructions thunk for this PC: */
diff --git a/emulators/tme/files/patch-libtme-module.c b/emulators/tme/files/patch-libtme-module.c
index 43c168c8370e..4d2c85fd4c03 100644
--- a/emulators/tme/files/patch-libtme-module.c
+++ b/emulators/tme/files/patch-libtme-module.c
@@ -1,6 +1,20 @@
---- libtme/module.c.orig Wed Jan 26 13:59:24 2005
-+++ libtme/module.c Sun Dec 17 19:11:37 2006
-@@ -107,13 +107,14 @@
+--- libtme/module.c.orig 2010-06-06 04:04:42.000000000 +0900
++++ libtme/module.c 2011-03-20 06:00:02.000000000 +0900
+@@ -62,11 +62,13 @@
+ #endif /* !lt_ptr_t */
+ #endif /* !lt_ptr */
+
++#if 0
+ /* similarly, the installed libltdl may be so recent that its ltdl.h
+ renames lt_preloaded_symbols with a macro, to a name different from
+ what our libtool script makes. it's possible that the renaming
+ macro is meant to be undefined to handle this problem: */
+ #undef lt_preloaded_symbols
++#endif
+
+ /* types: */
+ struct tme_module {
+@@ -113,13 +115,14 @@
FILE *modules_index;
/* pass over the search path environment variables: */
diff --git a/emulators/tme/files/patch-machine__sun__sun-bwtwo.c b/emulators/tme/files/patch-machine__sun__sun-bwtwo.c
new file mode 100644
index 000000000000..0fc7aeef66f0
--- /dev/null
+++ b/emulators/tme/files/patch-machine__sun__sun-bwtwo.c
@@ -0,0 +1,27 @@
+--- machine/sun/sun-bwtwo.c.orig 2009-11-08 12:03:58.000000000 -0500
++++ machine/sun/sun-bwtwo.c 2011-10-06 20:52:30.000000000 -0400
+@@ -339,6 +339,7 @@
+ {
+ struct tme_sunbw2 *sunbw2;
+ int rc;
++ tme_uint16_t v;
+
+ /* start the sunbw2 structure: */
+ sunbw2 = tme_new0(struct tme_sunbw2, 1);
+@@ -365,12 +366,10 @@
+ case TME_SUNBW2_TYPE_OLD_ONBOARD:
+
+ /* set our initial CSR: */
+- sunbw2->tme_sunbw2_csr
+- = tme_htobe_u16(TME_SUNBW2_CSR_ENABLE_VIDEO
+- | (sunbw2->tme_sunbw2_sunfb.tme_sunfb_size == TME_SUNFB_SIZE_1024_1024
+- ? TME_SUNBW2_CSR_JUMPER_HIRES
+- : 0));
+-
++ v = TME_SUNBW2_CSR_ENABLE_VIDEO | (sunbw2->tme_sunbw2_sunfb.tme_sunfb_size
++ == TME_SUNFB_SIZE_1024_1024
++ ? TME_SUNBW2_CSR_JUMPER_HIRES : 0);
++ sunbw2->tme_sunbw2_csr = tme_htobe_u16(v);
+ break;
+ }
+
diff --git a/emulators/tme/pkg-plist b/emulators/tme/pkg-plist
index 61c60d35a40a..e8c19dd89175 100644
--- a/emulators/tme/pkg-plist
+++ b/emulators/tme/pkg-plist
@@ -1,125 +1,208 @@
-bin/tme-sun-idprom
bin/tme-sun-eeprom
+bin/tme-sun-idprom
bin/tmesh
+include/tme/bus/upa.h
+include/tme/common.h
+include/tme/completion.h
+include/tme/connection.h
+include/tme/element.h
include/tme/generic/bus-device.h
include/tme/generic/bus.h
-include/tme/generic/ic.h
-include/tme/generic/serial.h
+include/tme/generic/disk.h
include/tme/generic/ethernet.h
include/tme/generic/fb.h
-include/tme/generic/scsi.h
-include/tme/generic/disk.h
-include/tme/generic/tape.h
-include/tme/generic/mouse.h
include/tme/generic/float.h
+include/tme/generic/ic.h
include/tme/generic/keyboard.h
-@dirrm include/tme/generic
-include/tme/ic/m68k.h
+include/tme/generic/mouse.h
+include/tme/generic/scsi.h
+include/tme/generic/serial.h
+include/tme/generic/tape.h
+include/tme/hash.h
+include/tme/host/recode-mmap.h
+include/tme/host/recode-x86.h
include/tme/ic/am9513.h
-include/tme/ic/z8530.h
-include/tme/ic/mm58167.h
-include/tme/ic/isil7170.h
-include/tme/ic/i825x6.h
-include/tme/ic/sparc.h
-include/tme/ic/mk48txx.h
-include/tme/ic/nec765.h
include/tme/ic/bt458.h
-include/tme/ic/ieee754.h
+include/tme/ic/i825x6.h
include/tme/ic/ieee754-auto.h
include/tme/ic/ieee754-ops-auto.h
-@dirrm include/tme/ic
+include/tme/ic/ieee754.h
+include/tme/ic/isil7170.h
+include/tme/ic/m68k.h
+include/tme/ic/mk48txx.h
+include/tme/ic/mm58167.h
+include/tme/ic/nec765.h
+include/tme/ic/sparc.h
+include/tme/ic/z8530.h
+include/tme/log.h
include/tme/machine/sun.h
-@dirrm include/tme/machine
-include/tme/scsi/scsi-disk.h
-include/tme/scsi/scsi-tape.h
-include/tme/scsi/scsi-cdrom.h
-include/tme/scsi/scsi-msg.h
+include/tme/memory-auto.h
+include/tme/memory.h
+include/tme/misc.h
+include/tme/module.h
+include/tme/recode.h
+include/tme/runlength.h
include/tme/scsi/scsi-cdb.h
+include/tme/scsi/scsi-cdrom.h
include/tme/scsi/scsi-device.h
-@dirrm include/tme/scsi
-include/tme/memory.h
-include/tme/common.h
-include/tme/connection.h
-include/tme/element.h
+include/tme/scsi/scsi-disk.h
+include/tme/scsi/scsi-msg.h
+include/tme/scsi/scsi-tape.h
include/tme/threads.h
-include/tme/module.h
-include/tme/log.h
include/tme/tme.h
-include/tme/misc.h
-include/tme/hash.h
include/tme/tmesh.h
-include/tme/memory-auto.h
-@dirrm include/tme
-include/ltdl.h
+include/tme/token.h
+lib/libtme-generic.a
+lib/libtme-generic.la
+lib/libtme-generic.so
+lib/libtme-generic.so.0
+lib/libtme-ieee754.a
+lib/libtme-ieee754.la
+lib/libtme-ieee754.so
+lib/libtme-ieee754.so.0
+lib/libtme.a
+lib/libtme.la
+lib/libtme.so
+lib/libtme.so.0
+lib/libtmesh.a
+lib/libtmesh.la
+lib/libtmesh.so
+lib/libtmesh.so.0
+lib/tme/libtme-machine-sun.a
+lib/tme/libtme-machine-sun.la
+lib/tme/libtme-machine-sun.so
+lib/tme/libtme-machine-sun.so.0
lib/tme/tme-plugins.txt
-lib/tme/tme_generic.la
+lib/tme/tme_bus_multibus.a
+lib/tme/tme_bus_multibus.la
+lib/tme/tme_bus_multibus.so
+lib/tme/tme_bus_multibus.so.0
+lib/tme/tme_bus_sbus.a
+lib/tme/tme_bus_sbus.la
+lib/tme/tme_bus_sbus.so
+lib/tme/tme_bus_sbus.so.0
lib/tme/tme_generic.a
-lib/tme/tme_ic_m68k.la
-lib/tme/tme_ic_m68k.a
-lib/tme/tme_ic_sparc.la
-lib/tme/tme_ic_sparc.a
-lib/tme/tme_ic_am9513.la
+lib/tme/tme_generic.la
+lib/tme/tme_generic.so
+lib/tme/tme_generic.so.0
+lib/tme/tme_host_bsd.a
+lib/tme/tme_host_bsd.la
+lib/tme/tme_host_bsd.so
+lib/tme/tme_host_bsd.so.0
+lib/tme/tme_host_gtk.a
+lib/tme/tme_host_gtk.la
+lib/tme/tme_host_gtk.so
+lib/tme/tme_host_gtk.so.0
+lib/tme/tme_host_posix.a
+lib/tme/tme_host_posix.la
+lib/tme/tme_host_posix.so
+lib/tme/tme_host_posix.so.0
+lib/tme/tme_ic_ad184x.a
+lib/tme/tme_ic_ad184x.la
+lib/tme/tme_ic_ad184x.so
+lib/tme/tme_ic_ad184x.so.0
+lib/tme/tme_ic_am7930.a
+lib/tme/tme_ic_am7930.la
+lib/tme/tme_ic_am7930.so
+lib/tme/tme_ic_am7930.so.0
+lib/tme/tme_ic_am7990.a
+lib/tme/tme_ic_am7990.la
+lib/tme/tme_ic_am7990.so
+lib/tme/tme_ic_am7990.so.0
lib/tme/tme_ic_am9513.a
-lib/tme/tme_ic_mm58167.la
-lib/tme/tme_ic_mm58167.a
-lib/tme/tme_ic_z8530.la
-lib/tme/tme_ic_z8530.a
-lib/tme/tme_ic_i825x6.la
+lib/tme/tme_ic_am9513.la
+lib/tme/tme_ic_am9513.so
+lib/tme/tme_ic_am9513.so.0
lib/tme/tme_ic_i825x6.a
-lib/tme/tme_ic_isil7170.la
+lib/tme/tme_ic_i825x6.la
+lib/tme/tme_ic_i825x6.so
+lib/tme/tme_ic_i825x6.so.0
lib/tme/tme_ic_isil7170.a
-lib/tme/tme_ic_ncr5380.la
+lib/tme/tme_ic_isil7170.la
+lib/tme/tme_ic_isil7170.so
+lib/tme/tme_ic_isil7170.so.0
+lib/tme/tme_ic_lsi64854.a
+lib/tme/tme_ic_lsi64854.la
+lib/tme/tme_ic_lsi64854.so
+lib/tme/tme_ic_lsi64854.so.0
+lib/tme/tme_ic_m68k.a
+lib/tme/tme_ic_m68k.la
+lib/tme/tme_ic_m68k.so
+lib/tme/tme_ic_m68k.so.0
+lib/tme/tme_ic_mk48txx.a
+lib/tme/tme_ic_mk48txx.la
+lib/tme/tme_ic_mk48txx.so
+lib/tme/tme_ic_mk48txx.so.0
+lib/tme/tme_ic_mm58167.a
+lib/tme/tme_ic_mm58167.la
+lib/tme/tme_ic_mm58167.so
+lib/tme/tme_ic_mm58167.so.0
lib/tme/tme_ic_ncr5380.a
-lib/tme/tme_ic_am7930.la
-lib/tme/tme_ic_am7930.a
-lib/tme/tme_ic_am7990.la
-lib/tme/tme_ic_am7990.a
-lib/tme/tme_ic_ncr53c9x.la
+lib/tme/tme_ic_ncr5380.la
+lib/tme/tme_ic_ncr5380.so
+lib/tme/tme_ic_ncr5380.so.0
lib/tme/tme_ic_ncr53c9x.a
-lib/tme/tme_ic_mk48txx.la
-lib/tme/tme_ic_mk48txx.a
-lib/tme/tme_ic_lsi64854.la
-lib/tme/tme_ic_lsi64854.a
-lib/tme/tme_ic_nec765.la
+lib/tme/tme_ic_ncr53c9x.la
+lib/tme/tme_ic_ncr53c9x.so
+lib/tme/tme_ic_ncr53c9x.so.0
+lib/tme/tme_ic_ncr89c105.a
+lib/tme/tme_ic_ncr89c105.la
+lib/tme/tme_ic_ncr89c105.so
+lib/tme/tme_ic_ncr89c105.so.0
lib/tme/tme_ic_nec765.a
-lib/tme/libtme-machine-sun.la
-lib/tme/libtme-machine-sun.a
-lib/tme/tme_machine_sun2.la
+lib/tme/tme_ic_nec765.la
+lib/tme/tme_ic_nec765.so
+lib/tme/tme_ic_nec765.so.0
+lib/tme/tme_ic_sparc.a
+lib/tme/tme_ic_sparc.la
+lib/tme/tme_ic_sparc.so
+lib/tme/tme_ic_sparc.so.0
+lib/tme/tme_ic_stp2024.a
+lib/tme/tme_ic_stp2024.la
+lib/tme/tme_ic_stp2024.so
+lib/tme/tme_ic_stp2024.so.0
+lib/tme/tme_ic_stp22xx.a
+lib/tme/tme_ic_stp22xx.la
+lib/tme/tme_ic_stp22xx.so
+lib/tme/tme_ic_stp22xx.so.0
+lib/tme/tme_ic_z8530.a
+lib/tme/tme_ic_z8530.la
+lib/tme/tme_ic_z8530.so
+lib/tme/tme_ic_z8530.so.0
lib/tme/tme_machine_sun2.a
-lib/tme/tme_machine_sun3.la
+lib/tme/tme_machine_sun2.la
+lib/tme/tme_machine_sun2.so
+lib/tme/tme_machine_sun2.so.0
lib/tme/tme_machine_sun3.a
-lib/tme/tme_machine_sun4.la
+lib/tme/tme_machine_sun3.la
+lib/tme/tme_machine_sun3.so
+lib/tme/tme_machine_sun3.so.0
lib/tme/tme_machine_sun4.a
-lib/tme/tme_host_posix.la
-lib/tme/tme_host_posix.a
-lib/tme/tme_host_bsd.la
-lib/tme/tme_host_bsd.a
-lib/tme/tme_host_gtk.la
-lib/tme/tme_host_gtk.a
-lib/tme/tme_bus_multibus.la
-lib/tme/tme_bus_multibus.a
-lib/tme/tme_bus_sbus.la
-lib/tme/tme_bus_sbus.a
-lib/tme/tme_serial_kb.la
-lib/tme/tme_serial_kb.a
-lib/tme/tme_scsi.la
+lib/tme/tme_machine_sun4.la
+lib/tme/tme_machine_sun4.so
+lib/tme/tme_machine_sun4.so.0
lib/tme/tme_scsi.a
+lib/tme/tme_scsi.la
+lib/tme/tme_scsi.so
+lib/tme/tme_scsi.so.0
+lib/tme/tme_serial_kb.a
+lib/tme/tme_serial_kb.la
+lib/tme/tme_serial_kb.so
+lib/tme/tme_serial_kb.so.0
lib/tme/tmeconfig.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SUN-ULTRA-1
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SUN2-MULTIBUS
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SUN3-CARRERA
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/SUN4-75
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/my-sun-macros.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sun-keyboards.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sun3-carrera-eeprom.txt
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm lib/tme
-lib/libltdl.la
-lib/libltdl.a
-lib/libtme.la
-lib/libtme.a
-lib/libtme-generic.la
-lib/libtme-generic.a
-lib/libtme-ieee754.la
-lib/libtme-ieee754.a
-lib/libtmesh.la
-lib/libtmesh.a
-share/examples/tme/sun-keyboards.txt
-share/examples/tme/my-sun-macros.txt
-share/examples/tme/SUN2-MULTIBUS
-share/examples/tme/SUN3-CARRERA
-share/examples/tme/sun3-carrera-eeprom.txt
-share/examples/tme/SUN4-75
-@dirrm share/examples/tme
+@dirrm include/tme/scsi
+@dirrm include/tme/machine
+@dirrm include/tme/ic
+@dirrm include/tme/host
+@dirrm include/tme/generic
+@dirrm include/tme/bus
+@dirrm include/tme