aboutsummaryrefslogtreecommitdiff
path: root/emulators/tpm-emulator/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2010-11-07 12:08:52 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2010-11-07 12:08:52 +0000
commit1cf92127b214d45040e6429373dbe4caa266c68a (patch)
tree8ebda50beeb8a641516bc71fbcf900e9a31f86f7 /emulators/tpm-emulator/Makefile
parentc38e52a3c0b061b44ebb589d362563613f2edab8 (diff)
downloadports-1cf92127b214d45040e6429373dbe4caa266c68a.tar.gz
ports-1cf92127b214d45040e6429373dbe4caa266c68a.zip
Add tpm-emulator 0.7.1, is a Trusted Platform Module (TPM) emulator.
Notes
Notes: svn path=/head/; revision=264184
Diffstat (limited to 'emulators/tpm-emulator/Makefile')
-rw-r--r--emulators/tpm-emulator/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/emulators/tpm-emulator/Makefile b/emulators/tpm-emulator/Makefile
new file mode 100644
index 000000000000..8abcf954d625
--- /dev/null
+++ b/emulators/tpm-emulator/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: tpm-emulator
+# Date created: 18 Sep 2007
+# Whom: Sebastian Schuetz <sschuetz@fhm.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tpm-emulator
+PORTVERSION= 0.7.1
+CATEGORIES= emulators
+MASTER_SITES= BERLIOS/${PORTNAME}
+DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}
+
+MAINTAINER= nork@freebsd.org
+COMMENT= Trusted Platform Module (TPM) emulator
+
+LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
+
+USE_CMAKE= YES
+USE_LDCONFIG= YES
+MAKE_JOBS_SAFE= YES
+
+CONFLICTS= trousers-tddl*
+
+WANTLIB= c
+CMAKE_VERBOSE= YES
+CMAKE_SOURCE_PATH= ${WRKSRC}
+NO_CONFIGURE= YES
+BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
+INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
+CONFIGURE_WRKSRC= ${CMAKE_SOURCE_PATH}/build
+
+CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
+ -DCMAKE_EXE_LINKER_FLAGS="-L${LOCALBASE}/lib"
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/README
+
+WRKSRC= ${WRKDIR}/${PORTNAME:S/-/_/}-${PORTVERSION}
+
+post-patch:
+ @${MKDIR} ${WRKSRC}/build
+
+.include <bsd.port.mk>