aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose-additions
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-11-09 19:13:27 +0000
committerRene Ladan <rene@FreeBSD.org>2013-11-09 19:13:27 +0000
commitbfc52e710421bd92466b329f6fbb9be930eb4755 (patch)
tree7436338612f22a81def9ee6c2d2e3826c1504ea4 /emulators/virtualbox-ose-additions
parent16a624cb31062d141fd07c5dc3f7794ed7fe74cd (diff)
downloadports-bfc52e710421bd92466b329f6fbb9be930eb4755.tar.gz
ports-bfc52e710421bd92466b329f6fbb9be930eb4755.zip
Convert to USES=kmod, which removes duplicated code and ensures that all
required steps are followed. There are no user-visible changes. The exception is multimedia/ptx-kmod, which now installs the kernel module into /boot/modules instead of ${PREFIX}/libexec/${PORTNAME}, this was something USES=kmod cannot handle. PR: ports/183625 Submitted by: myself Approved by: portmgr (bdrewery) Exp-run by: bdrewery
Notes
Notes: svn path=/head/; revision=333329
Diffstat (limited to 'emulators/virtualbox-ose-additions')
-rw-r--r--emulators/virtualbox-ose-additions/Makefile14
-rw-r--r--emulators/virtualbox-ose-additions/pkg-plist2
2 files changed, 2 insertions, 14 deletions
diff --git a/emulators/virtualbox-ose-additions/Makefile b/emulators/virtualbox-ose-additions/Makefile
index 05601e573f0d..535b65b11f02 100644
--- a/emulators/virtualbox-ose-additions/Makefile
+++ b/emulators/virtualbox-ose-additions/Makefile
@@ -3,7 +3,7 @@
PORTNAME= virtualbox-ose
DISTVERSION= 4.2.18
-CATEGORIES= emulators kld
+CATEGORIES= emulators
MASTER_SITES= http://download.virtualbox.org/virtualbox/${DISTVERSION}/ \
http://tmp.chruetertee.ch/ \
http://disasterarea.chruetertee.ch/
@@ -23,7 +23,7 @@ BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
USE_RC_SUBR= vboxguest vboxservice
-USES= iconv
+USES= iconv kmod
ONLY_FOR_ARCHS= i386 amd64
FETCH_ARGS= -pRr
USE_BZIP2= yes
@@ -43,10 +43,6 @@ OPTIONS_DEFAULT= X11
NO_STAGE= yes
.include <bsd.port.options.mk>
-PLIST_SUB+= KMODDIR=${KMODDIR:C,^/,,}
-
-KMODDIR= /boot/modules
-SRC_BASE?= /usr/src
VIDEODIR= ${PREFIX}/lib/xorg/modules/drivers
INPUTDIR= ${PREFIX}/lib/xorg/modules/input
@@ -93,10 +89,6 @@ KMK_ARCH= freebsd.${ARCH}
XSERVER_ABI:= ${XSERVER_VER:S/.//:R}
-.if !exists(${SRC_BASE}/sys/kern/bus_if.m)
-IGNORE= requires kernel sources
-.endif
-
.include <bsd.port.pre.mk>
pre-everything::
@@ -134,7 +126,6 @@ do-build:
cd ${VBOX_BIN}/src && make ${MAKE_FLAGS}
do-install:
- ${MKDIR} ${KMODDIR}
${INSTALL_KLD} ${VBOX_BIN}/src/vboxguest/vboxguest.ko ${KMODDIR}
.if ${PORT_OPTIONS:MDEBUG}
${INSTALL_KLD} ${VBOX_BIN}/src/vboxguest/vboxguest.ko.symbols ${KMODDIR}
@@ -145,7 +136,6 @@ do-install:
${INSTALL_KLD} ${VBOX_BIN}/vboxvideo.ko.symbols ${KMODDIR}
.endif
.endif
- @/usr/sbin/kldxref ${KMODDIR}
${MKDIR} ${PREFIX}/etc/rc.d/
diff --git a/emulators/virtualbox-ose-additions/pkg-plist b/emulators/virtualbox-ose-additions/pkg-plist
index 2f447f58d9cd..d4a924feddaf 100644
--- a/emulators/virtualbox-ose-additions/pkg-plist
+++ b/emulators/virtualbox-ose-additions/pkg-plist
@@ -27,5 +27,3 @@ sbin/VBoxService
%%WITH_DEBUG%%%%KMODDIR%%/vboxguest.ko.symbols
%%X11%%%%KMODDIR%%/vboxvideo.ko
%%WITH_DEBUG%%%%X11%%%%KMODDIR%%/vboxvideo.ko
-@exec /usr/sbin/kldxref /%%KMODDIR%%
-@unexec /usr/sbin/kldxref /%%KMODDIR%%