aboutsummaryrefslogtreecommitdiff
path: root/emulators/vmware-tools2
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-21 07:21:27 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-21 07:21:27 +0000
commitc26e98a06144b1e6137d11f2cd619cf05f233c23 (patch)
treea2d8da796845f6c5e9584f3c79b3543642d9eb5d /emulators/vmware-tools2
parent14355fd88fd68afb986fcaefddfeb3fcae3f07b0 (diff)
downloadports-c26e98a06144b1e6137d11f2cd619cf05f233c23.tar.gz
ports-c26e98a06144b1e6137d11f2cd619cf05f233c23.zip
Add vmware-tools, VMware tools for FreeBSD guest OS (X Server only).
PR: ports/20612 Submitted by: Makoto MATSUSHITA <matusita@jp.FreeBSD.org> Modified by: knu
Notes
Notes: svn path=/head/; revision=31807
Diffstat (limited to 'emulators/vmware-tools2')
-rw-r--r--emulators/vmware-tools2/Makefile42
-rw-r--r--emulators/vmware-tools2/distinfo1
-rw-r--r--emulators/vmware-tools2/pkg-comment1
-rw-r--r--emulators/vmware-tools2/pkg-descr14
-rw-r--r--emulators/vmware-tools2/pkg-message5
-rw-r--r--emulators/vmware-tools2/pkg-plist2
6 files changed, 65 insertions, 0 deletions
diff --git a/emulators/vmware-tools2/Makefile b/emulators/vmware-tools2/Makefile
new file mode 100644
index 000000000000..e67f2d1f77ee
--- /dev/null
+++ b/emulators/vmware-tools2/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: VMware tools for FreeBSD
+# Date created: 10 Aug 2000
+# Whom: matusita@jp.FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= vmware-tools
+PORTVERSION= ${VMWARE_VER}.${BUILD_VER}
+CATEGORIES= emulators
+MASTER_SITES= ${AU_ONLY_SITES} \
+ http://www4.vmware.com/software/ \
+ http://vmware-svca.www.conxion.com/software/ \
+ http://vmware-chil.www.conxion.com/software/ \
+ http://vmware-heva.www.conxion.com/software/ \
+ http://vmware.wespe.de/software/ \
+ ftp://vmware.wespe.de/pub/software/
+DISTNAME= tools-for-freebsd-${BUILD_VER}
+
+MAINTAINER= matusita@jp.FreeBSD.org
+
+WRKSRC= ${WRKDIR}/vmware-freebsd-tools
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+NO_BUILD= yes
+
+RESTRICTED= "Not sure if we can redistribute this."
+
+.if defined(AU_RESIDENT) && (${AU_RESIDENT} == YES)
+AU_ONLY_SITES= ftp://mirror.aarnet.edu.au/pub/vmware/software/
+.endif
+
+VMWARE_VER= 2.0.2
+BUILD_VER= 307
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/XF86_VMware ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/XF86Config.dist ${PREFIX}/etc/XF86Config_VMware
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/emulators/vmware-tools2/distinfo b/emulators/vmware-tools2/distinfo
new file mode 100644
index 000000000000..57f4e3d4ab0e
--- /dev/null
+++ b/emulators/vmware-tools2/distinfo
@@ -0,0 +1 @@
+MD5 (tools-for-freebsd-307.tar.gz) = c9e4b04abe26f7158003fa183bcfa48f
diff --git a/emulators/vmware-tools2/pkg-comment b/emulators/vmware-tools2/pkg-comment
new file mode 100644
index 000000000000..a92f060af645
--- /dev/null
+++ b/emulators/vmware-tools2/pkg-comment
@@ -0,0 +1 @@
+VMware tools for FreeBSD guest OS (X Server only)
diff --git a/emulators/vmware-tools2/pkg-descr b/emulators/vmware-tools2/pkg-descr
new file mode 100644
index 000000000000..7939544ab055
--- /dev/null
+++ b/emulators/vmware-tools2/pkg-descr
@@ -0,0 +1,14 @@
+VMware tools support FreeBSD _Guest_ OS running on VMware. Beware,
+this port is _not_ for FreeBSD _Host_ OS.
+
+VMware tools for FreeBSD consist of vmware-toolbox which supports
+seamless operation between the Host and the Guest OS, dual-boot
+configulation files, and special X server for Guest OS. However,
+vmware-toolbox for FreeBSD lacks some features that vmware-toolbox for
+Linux has, and dual-boot configulation is broken because checkvm
+doesn't work.
+
+So this port installs X server ONLY. If you want vmware-toolbox,
+install emulators/linux-vmware-toolbox on your FreeBSD _Guest_ OS.
+
+WWW: http://www.vmware.com/download/downloadtools.html
diff --git a/emulators/vmware-tools2/pkg-message b/emulators/vmware-tools2/pkg-message
new file mode 100644
index 000000000000..57a109cb8812
--- /dev/null
+++ b/emulators/vmware-tools2/pkg-message
@@ -0,0 +1,5 @@
+XFree86 configulation file is in ${PREFIX}/etc/XF86Config_VMware.
+Copy this file to /etc/XF86Config before starting X.
+
+This package does not contain vmware-toolbox. You need to install
+emulators/linux-vmware-toolbox if you want it.
diff --git a/emulators/vmware-tools2/pkg-plist b/emulators/vmware-tools2/pkg-plist
new file mode 100644
index 000000000000..fd515f110692
--- /dev/null
+++ b/emulators/vmware-tools2/pkg-plist
@@ -0,0 +1,2 @@
+bin/XF86_VMware
+etc/XF86Config_VMware