aboutsummaryrefslogtreecommitdiff
path: root/emulators/vxtools
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2000-07-28 20:23:42 +0000
committerSADA Kenji <sada@FreeBSD.org>2000-07-28 20:23:42 +0000
commita29c40f0d98e922a21eab3925eab11f882fa49b4 (patch)
tree415bb103644a0d8b233c36e25d0f420dcaa1b49d /emulators/vxtools
parent2c67e7f4f581c74b12b0c78ff9cf3af7ed7a4757 (diff)
downloadports-a29c40f0d98e922a21eab3925eab11f882fa49b4.tar.gz
ports-a29c40f0d98e922a21eab3925eab11f882fa49b4.zip
New port vxtools - Command-line utilites for reading Veritas Filesystem (VxFS).
PR: ports/17436 Submitted by: Martin Hinner <mhi@linux.gyarab.cz>
Notes
Notes: svn path=/head/; revision=31088
Diffstat (limited to 'emulators/vxtools')
-rw-r--r--emulators/vxtools/Makefile35
-rw-r--r--emulators/vxtools/distinfo1
-rw-r--r--emulators/vxtools/pkg-comment1
-rw-r--r--emulators/vxtools/pkg-descr5
-rw-r--r--emulators/vxtools/pkg-plist8
5 files changed, 50 insertions, 0 deletions
diff --git a/emulators/vxtools/Makefile b/emulators/vxtools/Makefile
new file mode 100644
index 000000000000..7c49d3f88036
--- /dev/null
+++ b/emulators/vxtools/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: vxtools
+# Date created: 10 December 1999
+# Whom: Martin Hinner
+#
+# $FreeBSD$
+#
+
+PORTNAME= vxtools
+PORTVERSION= 0.2
+CATEGORIES= emulators
+MASTER_SITES= ftp://ftp.penguin.cz/pub/users/mhi/vxfs/
+
+MAINTAINER= mhi@penguin.cz
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN1= vxmount.1 vxumount.1
+MAN8= prtvtoc.8
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/vxls ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/vxmount ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/vxumount ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/vxcat ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/vxidump ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/vxcd ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/vxpwd ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/prtvtoc ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/prtvtoc.8 ${PREFIX}/man/man8
+ @ ${INSTALL_MAN} ${WRKSRC}/vxmount.1 ${PREFIX}/man/man1
+ @ ${INSTALL_MAN} ${WRKSRC}/vxumount.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/emulators/vxtools/distinfo b/emulators/vxtools/distinfo
new file mode 100644
index 000000000000..213062e0ba5d
--- /dev/null
+++ b/emulators/vxtools/distinfo
@@ -0,0 +1 @@
+MD5 (vxtools-0.2.tar.bz2) = aa3e019c7759f6bbbf4eae071cfec27e
diff --git a/emulators/vxtools/pkg-comment b/emulators/vxtools/pkg-comment
new file mode 100644
index 000000000000..cfd9a1577b56
--- /dev/null
+++ b/emulators/vxtools/pkg-comment
@@ -0,0 +1 @@
+Command-line utilites for reading Veritas Filesystem (VxFS)
diff --git a/emulators/vxtools/pkg-descr b/emulators/vxtools/pkg-descr
new file mode 100644
index 000000000000..ae8c962ee2f6
--- /dev/null
+++ b/emulators/vxtools/pkg-descr
@@ -0,0 +1,5 @@
+This package allows you to read files from Veritas Journaled Filesystem.
+Current version seems to support versions 2 and 4 (and 3, but this version
+was never released, AFAIK). I don't plan a write version, because I don't
+know journal log structure and I have *no* time to play with it. But I plan
+a Linux kernel implementation.
diff --git a/emulators/vxtools/pkg-plist b/emulators/vxtools/pkg-plist
new file mode 100644
index 000000000000..670adbecb2bc
--- /dev/null
+++ b/emulators/vxtools/pkg-plist
@@ -0,0 +1,8 @@
+bin/prtvtoc
+bin/vxmount
+bin/vxumount
+bin/vxls
+bin/vxcd
+bin/vxpwd
+bin/vxidump
+bin/vxcat