aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine-devel
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2010-09-11 17:42:25 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2010-09-11 17:42:25 +0000
commit950310ee65be8afb1288f2dd2002b090327b2cad (patch)
tree8087a75046eed052a7d2254cd6a39b2820f54c91 /emulators/wine-devel
parentd06e3605052776395a4ab34e5d363236d934c754 (diff)
downloadports-950310ee65be8afb1288f2dd2002b090327b2cad.tar.gz
ports-950310ee65be8afb1288f2dd2002b090327b2cad.zip
Add a new option OPENAL, off by default, that controls the use of OpenAL.
Among others, this makes Starcraft 2 work nicely. Submitted by: tijl
Notes
Notes: svn path=/head/; revision=260987
Diffstat (limited to 'emulators/wine-devel')
-rw-r--r--emulators/wine-devel/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 8644a1759e14..3db5d557f7c4 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -29,7 +29,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${DATADIR} --verbose --disable-tests \
--with-glu --with-opengl --with-xrandr \
--without-capi --without-gphoto --without-gsm \
- --without-mpg123 --without-openal --without-sane \
+ --without-mpg123 --without-sane \
--without-xcomposite --without-xinerama
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
@@ -54,6 +54,7 @@ OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" Off \
HAL "Use HAL (Hardware Abstraction Layer)" Off \
LDAP "Use LDAP" Off \
LIBXSLT "Use libxslt (only used by msxml3.dll)" Off \
+ OPENAL "Use OpenAL (3D audio library)" Off \
WINEMAKER "Fully support winemaker (requires Perl)" Off
.include <bsd.port.pre.mk>
@@ -93,6 +94,13 @@ LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
CONFIGURE_ARGS+= --without-xslt
.endif
+.ifdef WITH_OPENAL
+CONFIGURE_ARGS+= --with-openal
+USE_OPENAL= yes
+.else
+CONFIGURE_ARGS+= --without-openal
+.endif
+
.ifdef WITH_WINEMAKER
RUN_DEPENDS+= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
.endif