aboutsummaryrefslogtreecommitdiff
path: root/emulators/xbraitenberg/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-28 08:53:10 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-28 08:53:10 +0000
commit8883f7a4eb96a1c9df5e9c6b04ed005859754124 (patch)
tree446c342e7961f61d99571940126a050750c226e3 /emulators/xbraitenberg/Makefile
parentee233f9bb49874492887dc4daff08d0a515c91a1 (diff)
downloadports-8883f7a4eb96a1c9df5e9c6b04ed005859754124.tar.gz
ports-8883f7a4eb96a1c9df5e9c6b04ed005859754124.zip
- Add xbraitenberg-0.8,
A Braintenberg vehicle simulator with pseudo-physics
Notes
Notes: svn path=/head/; revision=105484
Diffstat (limited to 'emulators/xbraitenberg/Makefile')
-rw-r--r--emulators/xbraitenberg/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/emulators/xbraitenberg/Makefile b/emulators/xbraitenberg/Makefile
new file mode 100644
index 000000000000..00d4cd806124
--- /dev/null
+++ b/emulators/xbraitenberg/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: xbraitenberg
+# Date created: 28 Mar 2004
+# Whom: krion
+#
+# $FreeBSD$
+#
+
+PORTNAME= xbraitenberg
+PORTVERSION= 0.8
+CATEGORIES= emulators
+MASTER_SITES= http://www.lcdf.org/~eddietwo/xbraitenberg/
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= A Braitenberg vehicle simulator with pseudo-physics
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LIBS="-L${X11BASE}/lib"
+
+PLIST_FILES= bin/xbraitenberg
+
+.include <bsd.port.mk>