aboutsummaryrefslogtreecommitdiff
path: root/emulators/xmame
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-11-22 12:42:16 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-11-22 12:42:16 +0000
commit7a1c1cc62242ec74c0a94287686a04266482de58 (patch)
treecbcb57f35beeef9b1f5843907ddfff14df81ee9a /emulators/xmame
parent7bf34f2fb0e2af844c2a8598891be42bfcbdd97a (diff)
downloadports-7a1c1cc62242ec74c0a94287686a04266482de58.tar.gz
ports-7a1c1cc62242ec74c0a94287686a04266482de58.zip
Update port to version 0.56.1.
PR: 31596 Submitted by: Stijn Hoop <stijn@win.tue.nl>
Notes
Notes: svn path=/head/; revision=50369
Diffstat (limited to 'emulators/xmame')
-rw-r--r--emulators/xmame/Makefile30
-rw-r--r--emulators/xmame/distinfo2
-rw-r--r--emulators/xmame/files/patch-ac21
-rw-r--r--emulators/xmame/files/patch-ad13
4 files changed, 49 insertions, 17 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index d8d32f46be67..33fdf8e71155 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -6,26 +6,29 @@
#
PORTNAME?= xmame
-PORTVERSION?= 0.55.2
+PORTVERSION?= 0.56.1
CATEGORIES= emulators
MASTER_SITES= http://x.mame.net/download/ \
- ftp://ftp.kaupp.cx/pub/xmame/ \
http://www.mame.net/zips/ \
http://cheat.retrogames.com/ \
http://www.sys2064.com/files/mame/
DISTNAME= xmame-${XMAMEVERSION:S/p/pre/}
DIST_SUBDIR= xmame
-XMAMEVERSION?= ${PORTVERSION}
-USE_BZIP2= yes
MAINTAINER?= stijn@win.tue.nl
-USE_XPM= yes
-USE_X_PREFIX= yes
+USE_BZIP2= yes
USE_GMAKE= yes
MAN6= x${MAMEMESS}.6
+XMAMEVERSION?= ${PORTVERSION}
+
+.if !defined(WITH_SVGALIB) || ${WITH_SVGALIB} != "yes"
+USE_XPM= yes
+USE_X_PREFIX= yes
+.endif
+
# Are we building MAME, MESS or PinMAME? (also set by slave ports)
MAMEMESS?= mame
@@ -162,6 +165,9 @@ pre-everything::
# acceleration
# WITH_SDL Uses the SDL library to be able to play fullscreen
# without root rights
+# WITH_SVGALIB Uses the svgalib library to allow playing without X. This
+# has not been extensively tested; patches welcome to make
+# this actually work.
# WITH_X11 The standard display target, should work without
# dependancies other than X
#
@@ -175,6 +181,12 @@ PLIST_SUB+= OPENGL=""
ALL_DOCS+= ${GLDOCS}
.else
PLIST_SUB+= OPENGL="@comment "
+.if defined(WITH_SVGALIB) && ${WITH_SVGALIB} == "yes"
+LIB_DEPENDS= vga.1:${PORTSDIR}/graphics/svgalib
+CFLAGS+= -I${LOCALBASE}/include
+MAKE_ENV+= LOCALBASE=${LOCALBASE}
+DISPLAY_METHOD= svgalib
+.else
.if !defined(WITH_SDL) || ${WITH_SDL} != "no"
LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl12
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
@@ -191,6 +203,8 @@ pre-everything::
DISPLAY_METHOD= x11
.endif
.endif
+.endif
+PKGNAMESUFFIX=-${DISPLAY_METHOD:L}
# USB joysticks - only enabled on -STABLE because of conflicting USB
# prototypes in -STABLE & -CURRENT.
@@ -222,12 +236,14 @@ post-patch:
${WRKSRC}/src/unix/video-drivers/glexport.c
${PERL} -pi -e 's@malloc.h@stdlib.h@' \
${WRKSRC}/src/unix/video-drivers/gljpg.c
+ ${PERL} -pi -e 's@asm/io.h@machine/cpufunc.h@' \
+ ${WRKSRC}/src/unix/video-drivers/twkuser.c
# The large number of sed regexes here is intended to make this port a whole
# lot easier to maintain - please don't convert them into a patch.
do-configure:
${SED} -e "s@= gcc@?= ${CC}@g" \
- -e "s@= -O2 -Wall@?= ${CFLAGS}@g" \
+ -e "s@^CFLAGS.*@CFLAGS ?= ${CFLAGS}@g" \
-e "s@= cp@?= ${INSTALL} ${COPY}@g" \
-e "s@lib/x\$$(TARGET)@share/x\$$(TARGET)@g" \
-e "s@/usr/X11R6@${X11BASE}@g" \
diff --git a/emulators/xmame/distinfo b/emulators/xmame/distinfo
index 3bed43225d8b..1a1c0116dfec 100644
--- a/emulators/xmame/distinfo
+++ b/emulators/xmame/distinfo
@@ -1,4 +1,4 @@
-MD5 (xmame/xmame-0.55.2.tar.bz2) = 23ebdb97a56690678b881f883089675a
+MD5 (xmame/xmame-0.56.1.tar.bz2) = 220c071b2852b883b98cb8f637df17c4
MD5 (xmame/xmame-0.37b15.2.tar.bz2) = 9c05a92aac0e29811e7b276c631153ed
MD5 (xmame/xmame-0.37b14.2.tar.bz2) = 34bfba3d1412a8f8e1abd4d738de3f27
MD5 (xmame/cheat.zip) = aa2c0a7af3e18db041e6b9e6bae60f11
diff --git a/emulators/xmame/files/patch-ac b/emulators/xmame/files/patch-ac
index 47ee03e48f7f..f93a6f1b2eed 100644
--- a/emulators/xmame/files/patch-ac
+++ b/emulators/xmame/files/patch-ac
@@ -1,21 +1,24 @@
---- src/unix/unix.mak.orig Mon Apr 9 03:54:42 2001
-+++ src/unix/unix.mak Tue Apr 10 10:52:06 2001
-@@ -46,18 +46,18 @@
+--- src/unix/unix.mak.orig Thu Nov 15 07:15:47 2001
++++ src/unix/unix.mak Thu Nov 22 11:11:35 2001
+@@ -45,20 +45,20 @@
+
+ # svga and ggi also use $(X11LIB) since that's where zlib often is
LIBS.x11 = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext
- LIBS.svgalib = $(X11LIB) -lvga -lvgagl
+-LIBS.svgalib = $(X11LIB) -lvga -lvgagl
++LIBS.svgalib = -L$(LOCALBASE)/lib -lvga -lvgagl
LIBS.ggi = $(X11LIB) -lggi
-LIBS.xgl = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext $(GLLIBS) -ljpeg
-+LIBS.xgl = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext $(GLLIBS) -L/usr/local/lib -ljpeg
++LIBS.xgl = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext $(GLLIBS) -L$(LOCALBASE)/lib -ljpeg
LIBS.xfx = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext -lglide2x
LIBS.svgafx = $(X11LIB) -lvga -lvgagl -lglide2x
LIBS.openstep = -framework AppKit
--LIBS.SDL = -ldl -lSDL -lpthread -D_REENTRANT
+-LIBS.SDL = `sdl-config --libs`
+LIBS.SDL = `$(SDL_CONFIG) --libs`
LIBS.photon2 = -L/usr/lib -lph -lphrender
CFLAGS.x11 = $(X11INC) $(JOY_X11_CFLAGS)
-CFLAGS.xgl = $(X11INC) $(JOY_X11_CFLAGS) $(GLCFLAGS)
-+CFLAGS.xgl = -DGLU_VERSION_1_2 $(X11INC) $(JOY_X11_CFLAGS) $(GLCFLAGS) -I/usr/local/include $(PTHREAD_CFLAGS)
++CFLAGS.xgl = -DGLU_VERSION_1_2 $(X11INC) $(JOY_X11_CFLAGS) $(GLCFLAGS) -I$(LOCALBASE)/include $(PTHREAD_CFLAGS)
CFLAGS.xfx = $(X11INC) $(JOY_X11_CFLAGS) -I/usr/include/glide
CFLAGS.svgafx = -I/usr/include/glide
-CFLAGS.SDL = -D_REENTRANT
@@ -23,7 +26,7 @@
CFLAGS.photon2 =
INST.x11 = doinstall
-@@ -322,7 +322,7 @@
+@@ -340,7 +340,7 @@
doc/x$(TARGET)rc.dist: all src/unix/xmamerc-keybinding-notes.txt
./x$(TARGET).$(DISPLAY_METHOD) -noloadconfig -showconfig | \
@@ -32,7 +35,7 @@
cat src/unix/xmamerc-keybinding-notes.txt >> doc/x$(TARGET)rc.dist
doc/gamelist.$(TARGET): all
-@@ -331,7 +331,8 @@
+@@ -349,7 +349,8 @@
doc/x$(TARGET).6: all src/unix/xmame.6-1 src/unix/xmame.6-3
cat src/unix/xmame.6-1 > doc/x$(TARGET).6
diff --git a/emulators/xmame/files/patch-ad b/emulators/xmame/files/patch-ad
new file mode 100644
index 000000000000..b0462f7c8942
--- /dev/null
+++ b/emulators/xmame/files/patch-ad
@@ -0,0 +1,13 @@
+--- src/unix/video-drivers/svgainput.c.orig Tue Oct 16 11:06:30 2001
++++ src/unix/video-drivers/svgainput.c Tue Oct 16 11:05:37 2001
+@@ -12,6 +12,10 @@
+ #include "devices.h"
+ #include "keyboard.h"
+
++#ifdef __FreeBSD__
++#define SIGUNUSED SIGUSR2
++#endif
++
+ static int console_fd = -1;
+ static int mouse_fd = -1;
+ static int leds = 0;