aboutsummaryrefslogtreecommitdiff
path: root/emulators/xsystem35
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-02-10 17:19:12 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-02-10 17:19:12 +0000
commit3b7f939de0375f2284750b260203002e01f8b632 (patch)
tree35b21c10e001dd9537f877bf136ccc612289cad5 /emulators/xsystem35
parentf5b8404eadb659b2d146656a209fa5d16f11779c (diff)
downloadports-3b7f939de0375f2284750b260203002e01f8b632.tar.gz
ports-3b7f939de0375f2284750b260203002e01f8b632.zip
Set WM_CLASS to manage under tiling WMs
Approved by: mentors (implicit)
Notes
Notes: svn path=/head/; revision=378787
Diffstat (limited to 'emulators/xsystem35')
-rw-r--r--emulators/xsystem35/Makefile2
-rw-r--r--emulators/xsystem35/files/patch-wmclass15
2 files changed, 16 insertions, 1 deletions
diff --git a/emulators/xsystem35/Makefile b/emulators/xsystem35/Makefile
index 198681b778ae..ed66285e67e7 100644
--- a/emulators/xsystem35/Makefile
+++ b/emulators/xsystem35/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xsystem35
DISTVERSION= 1.7.3-pre5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators games
MASTER_SITES= DEBIAN
DISTNAME= ${PORTNAME}_${DISTVERSION}.orig
diff --git a/emulators/xsystem35/files/patch-wmclass b/emulators/xsystem35/files/patch-wmclass
new file mode 100644
index 000000000000..4c95eb33ccac
--- /dev/null
+++ b/emulators/xsystem35/files/patch-wmclass
@@ -0,0 +1,15 @@
+Origin: https://gist.github.com/smly/5787574
+
+--- src/xcore_video.c.orig 2003-06-29 15:28:12 UTC
++++ src/xcore_video.c
+@@ -307,6 +307,10 @@ static void init_window(void) {
+ 0, WIN_DEPTH,
+ InputOutput, x11_visual, attrib_mask, &at);
+ }
++ XClassHint wm_class;
++ wm_class.res_name = "XSystem35";
++ wm_class.res_class = "XSystem35";
++ XSetClassHint( x11_display, x11_window, &wm_class );
+
+ /* determin dib depth candidate */
+ dib_depth_candidate = (depth == 16 && vinfo.red_mask == 0x7c00) ? 15: WIN_DEPTH;