aboutsummaryrefslogtreecommitdiff
path: root/emulators/xsystem35
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2004-08-14 20:34:30 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2004-08-14 20:34:30 +0000
commitd4d258e0527273b437b8d121db5d12002bf2b23d (patch)
tree0dbb684b23041779c66d8fe87b0411a3226f6b18 /emulators/xsystem35
parent1bbdec872cf6e397612364bc898c18e13fb2888c (diff)
downloadports-d4d258e0527273b437b8d121db5d12002bf2b23d.tar.gz
ports-d4d258e0527273b437b8d121db5d12002bf2b23d.zip
o update to 1.7.2.
o catch up comment/descr. o make freetype support non-optional. o drop broken SDL support.
Notes
Notes: svn path=/head/; revision=116214
Diffstat (limited to 'emulators/xsystem35')
-rw-r--r--emulators/xsystem35/Makefile82
-rw-r--r--emulators/xsystem35/distinfo4
-rw-r--r--emulators/xsystem35/files/patch-configure.in4
-rw-r--r--emulators/xsystem35/files/patch-soundcard.h26
-rw-r--r--emulators/xsystem35/files/patch-src_font_freetype2.c12
-rw-r--r--emulators/xsystem35/files/patch-src_tempname.c11
-rw-r--r--emulators/xsystem35/pkg-descr7
-rw-r--r--emulators/xsystem35/pkg-plist107
8 files changed, 128 insertions, 125 deletions
diff --git a/emulators/xsystem35/Makefile b/emulators/xsystem35/Makefile
index 82760de9734f..f8e2e4709768 100644
--- a/emulators/xsystem35/Makefile
+++ b/emulators/xsystem35/Makefile
@@ -6,45 +6,31 @@
#
PORTNAME= xsystem35
-PORTVERSION= 1.4.2
-PORTREVISION= 3
+PORTVERSION= 1.7.2
CATEGORIES= emulators
-MASTER_SITES= http://www.aist-nara.ac.jp/~masaki-c/private/unitbase/xsys35/down/
+MASTER_SITES= http://8ne.sakura.ne.jp:20008/chika/unitbase/xsys35/down/
MAINTAINER= sf@FreeBSD.org
-COMMENT= AliceSoft System 3.5 on X Window System
+COMMENT= AliceSoft System 3.5/3.6/3.8/3.9 on X Window System
-USE_REINPLACE= yes
-USE_AUTOCONF_VER= 213
+LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis
+
+USE_AUTOCONF_VER= 259
+USE_LIBTOOL_VER= 15
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gtk12
WANT_GNOME= yes
+USE_REINPLACE= yes
PKGMESSAGE= ${WRKSRC}/MESSAGE
-DOC_FILES= BUGS ChangeLog ChangeLog.1 FAQ GAMES.TXT GRFMT.TXT \
- INSTALL MISCGAME.TXT \
- README README.color README.joystick README.music \
- TECH.TXT THANKS TODO
-
-EXAMPLES= README.TXT \
- 456atlach.inf 456ningen.inf 456zero.inf \
- ambi.inf atlach_new.inf dalk.inf darcrows.inf diabo.inf \
- drstop.inf hushaby.inf kakurezuki.inf katsumi.inf \
- kichiku.inf mamatoto.inf mamori.inf miko.inf mugen.inf \
- oudou.inf panyo.inf panyo_new.inf pascha.inf persiom.inf \
- progood.inf rance1.inf rance2.inf rance3.inf rance4.inf \
- seeinao.inf toushin.inf toushin2.inf
-
PATCHES= pastel.diff
.include <bsd.port.pre.mk>
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
-
CONFIGURE_ARGS= --without-included-gettext \
+ --program-prefix="" \
--with-cachesize=20 \
--enable-midi=seq,extp,raw \
--enable-cdrom=bsd,mp3
@@ -58,20 +44,14 @@ CONFIGURE_ARGS+= --enable-audio=oss,esd --with-default-output=esd
CONFIGURE_ARGS+= --enable-audio=oss --with-default-output=oss
.endif
-.if defined(WITH_SDL)
-LIB_DEPENDS+= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-CONFIGURE_ARGS+= --enable-sdl
-CONFIGURE_ENV+= SDL_CONFIG="${SDL_CONFIG}"
-.else
-CONFIGURE_ARGS+= --disable-sdl
-.endif
-
-.if defined(WITH_FREETYPE)
-CONFIGURE_ARGS+= --enable-ttf
-.else
-CONFIGURE_ARGS+= --disable-ttf
-.endif
-
+#.if defined(WITH_SDL)
+#USE_SDL= sdl
+#CONFIGURE_ARGS+= --enable-sdl
+#CONFIGURE_ENV+= "CPPFLAGS=`$(SDL_CONFIG) --cflags`" \
+# "LIBS=`$(SDL_CONFIG) --libs`"
+#.else
+CONFIGURE_ARGS+= --disable-sdl
+#.endif
.if ${ARCH} == "i386"
.if defined(WITHOUT_MMX)
CONFIGURE_ARGS+= --disable-mmx
@@ -82,12 +62,9 @@ BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.endif
pre-everything::
-.if !defined(WITH_SDL)
- @${ECHO_MSG} '===> Define WITH_SDL to enable SDL support'
-.endif
-.if !defined(WITH_FREETYPE)
- @${ECHO_MSG} '===> Define WITH_FREETYPE to enable FreeType support'
-.endif
+#.if !defined(WITH_SDL)
+# @${ECHO_MSG} '===> Define WITH_SDL to enable SDL support'
+#.endif
.if ${ARCH} == "i386"
.if !defined(WITHOUT_MMX)
@${ECHO_MSG} '===> Define WITHOUT_MMX to disable MMX routines'
@@ -104,26 +81,21 @@ post-patch:
done
pre-configure:
- @${TOUCH} ${WRKSRC}/aclocal.m4 \
- ${WRKSRC}/Makefile.in \
- ${WRKSRC}/src/Makefile.in
+ (cd ${WRKSRC}/libltdl; ${AUTOCONF})
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/xsystem35 ${PREFIX}/bin
+post-install:
${INSTALL_SCRIPT} ${WRKSRC}/contrib/instgame ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/share/locale/ja/LC_MESSAGES
- ${INSTALL_DATA} ${WRKSRC}/po/ja.mo ${PREFIX}/share/locale/ja/LC_MESSAGES/xsystem35.mo
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/ja/xsystem35
(cd ${WRKSRC}/doc;\
- ${INSTALL_MAN} ${DOC_FILES} ${PREFIX}/share/doc/ja/xsystem35)
+ ${INSTALL_MAN} * ${PREFIX}/share/doc/ja/xsystem35)
.endif
- @${MKDIR} ${PREFIX}/share/examples/xsystem35
- ${INSTALL_DATA} ${WRKSRC}/src/xsys35rc.sample ${PREFIX}/share/examples/xsystem35
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/src/xsys35rc.sample ${EXAMPLESDIR}
@(cd ${WRKSRC}/contrib; \
- ${INSTALL_DATA} ${EXAMPLES} ${PREFIX}/share/examples/xsystem35)
+ ${INSTALL_DATA} *.* ${EXAMPLESDIR})
@(cd ${WRKSRC}/patch; \
- ${INSTALL_DATA} ${PATCHES} ${PREFIX}/share/examples/xsystem35)
+ ${INSTALL_DATA} ${PATCHES} ${EXAMPLESDIR})
@${SED} -e s,PREFIX,${PREFIX}, ${PKGDIR}/pkg-message > ${WRKSRC}/MESSAGE
@${CAT} ${WRKSRC}/MESSAGE
diff --git a/emulators/xsystem35/distinfo b/emulators/xsystem35/distinfo
index d5ec66fa1294..7698737b0cb1 100644
--- a/emulators/xsystem35/distinfo
+++ b/emulators/xsystem35/distinfo
@@ -1,2 +1,2 @@
-MD5 (xsystem35-1.4.2.tar.gz) = d775ddb4ae2c355ee416efbfb4bbc7f3
-SIZE (xsystem35-1.4.2.tar.gz) = 458807
+MD5 (xsystem35-1.7.2.tar.gz) = 95225db33c620a66111740f7e75a14ea
+SIZE (xsystem35-1.7.2.tar.gz) = 990167
diff --git a/emulators/xsystem35/files/patch-configure.in b/emulators/xsystem35/files/patch-configure.in
index bb98e8b44cf9..38f5a9ec38d4 100644
--- a/emulators/xsystem35/files/patch-configure.in
+++ b/emulators/xsystem35/files/patch-configure.in
@@ -1,5 +1,5 @@
---- configure.in.orig Tue Nov 27 04:26:47 2001
-+++ configure.in Sun Dec 23 07:26:26 2001
+--- configure.ac.orig Tue Nov 27 04:26:47 2001
++++ configure.ac Sun Dec 23 07:26:26 2001
@@ -316,7 +316,7 @@
*-*-linux*)
;;
diff --git a/emulators/xsystem35/files/patch-soundcard.h b/emulators/xsystem35/files/patch-soundcard.h
index d9307277a79d..ed6ec3fb217e 100644
--- a/emulators/xsystem35/files/patch-soundcard.h
+++ b/emulators/xsystem35/files/patch-soundcard.h
@@ -1,16 +1,3 @@
---- src/audio_oss.c.orig Tue Apr 3 06:00:44 2001
-+++ src/audio_oss.c Sat Sep 7 10:57:08 2002
-@@ -33,9 +33,7 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <sys/ioctl.h>
--#if defined(__FreeBSD__)
--#include <machine/soundcard.h>
--#elif defined(__OpenBSD__) || defined(__NetBSD__)
-+#if defined(__OpenBSD__) || defined(__NetBSD__)
- #include <soundcard.h>
- #else
- #include <sys/soundcard.h>
--- src/midi.rawmidi.c.orig Sat Mar 31 04:16:38 2001
+++ src/midi.rawmidi.c Sat Sep 7 10:57:13 2002
@@ -39,9 +39,7 @@
@@ -24,16 +11,3 @@
#include <soundcard.h>
#else
#include <sys/soundcard.h>
---- src/mixer_oss.c.orig Thu Mar 22 20:10:13 2001
-+++ src/mixer_oss.c Sat Sep 7 10:57:26 2002
-@@ -33,9 +33,7 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <sys/ioctl.h>
--#if defined(__FreeBSD__)
--#include <machine/soundcard.h>
--#elif defined(__OpenBSD__) || defined(__NetBSD__)
-+#if defined(__OpenBSD__) || defined(__NetBSD__)
- #include <soundcard.h>
- #else
- #include <sys/soundcard.h>
diff --git a/emulators/xsystem35/files/patch-src_font_freetype2.c b/emulators/xsystem35/files/patch-src_font_freetype2.c
new file mode 100644
index 000000000000..c2a84ac76885
--- /dev/null
+++ b/emulators/xsystem35/files/patch-src_font_freetype2.c
@@ -0,0 +1,12 @@
+--- src/font_freetype2.c.orig Mon Jul 21 04:30:16 2003
++++ src/font_freetype2.c Sat Aug 14 05:11:39 2004
+@@ -26,7 +26,8 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <glib.h>
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+
+ #include "portab.h"
+ #include "system.h"
diff --git a/emulators/xsystem35/files/patch-src_tempname.c b/emulators/xsystem35/files/patch-src_tempname.c
new file mode 100644
index 000000000000..ad7ab18f1c0b
--- /dev/null
+++ b/emulators/xsystem35/files/patch-src_tempname.c
@@ -0,0 +1,11 @@
+--- src/tempname.c.orig Mon Nov 10 00:06:13 2003
++++ src/tempname.c Sun Aug 15 02:36:09 2004
+@@ -112,7 +112,7 @@
+ uintmax_t is only 32 bits lose about 3.725 bits of randomness,
+ which is better than not having mkstemp at all. */
+ #if !defined UINT64_MAX && !defined uint64_t
+-# define uint64_t uintmax_t
++# define uint64_t u_int64_t
+ #endif
+
+ /* These are the characters used in temporary filenames. */
diff --git a/emulators/xsystem35/pkg-descr b/emulators/xsystem35/pkg-descr
index 512656d24166..1904280d4705 100644
--- a/emulators/xsystem35/pkg-descr
+++ b/emulators/xsystem35/pkg-descr
@@ -1,6 +1,3 @@
-Xsystem35 is AliceSoft System 3.5 implementation on X Window System
+Xsystem35 is AliceSoft System 3.5/3.6/3.8/3.9 implementation on X Window System
-WWW: http://www.aist-nara.ac.jp/~masaki-c/private/unitbase/xsys35/index.html
-
-- FUJISHIMA Satsuki
-k5@cheerful.com
+WWW: http://8ne.sakura.ne.jp:20008/chika/unitbase/xsys35/
diff --git a/emulators/xsystem35/pkg-plist b/emulators/xsystem35/pkg-plist
index bfd2a6dd9db7..e75d9b6b7f2d 100644
--- a/emulators/xsystem35/pkg-plist
+++ b/emulators/xsystem35/pkg-plist
@@ -1,6 +1,29 @@
bin/instgame
bin/xsystem35
-share/locale/ja/LC_MESSAGES/xsystem35.mo
+lib/xsystem35/AliceLogo.so
+lib/xsystem35/Confirm.so
+lib/xsystem35/Gpx.so
+lib/xsystem35/MSGSKIP.so
+lib/xsystem35/Math.so
+lib/xsystem35/MsgSkip.so
+lib/xsystem35/NIGHTDLL.so
+lib/xsystem35/NightDemonDemo.so
+lib/xsystem35/RandMT.so
+lib/xsystem35/SACT.so
+lib/xsystem35/ShArray.so
+lib/xsystem35/ShCalc.so
+lib/xsystem35/ShGraph.so
+lib/xsystem35/ShPort.so
+lib/xsystem35/ShSound.so
+lib/xsystem35/ShString.so
+lib/xsystem35/dDemo.so
+lib/xsystem35/eDemo.so
+lib/xsystem35/eeDemo.so
+lib/xsystem35/nDEMO.so
+lib/xsystem35/nDEMOE.so
+lib/xsystem35/oDEMO.so
+lib/xsystem35/oujimisc.so
+lib/xsystem35/tDemo.so
%%PORTDOCS%%share/doc/ja/xsystem35/BUGS
%%PORTDOCS%%share/doc/ja/xsystem35/ChangeLog
%%PORTDOCS%%share/doc/ja/xsystem35/ChangeLog.1
@@ -16,38 +39,52 @@ share/locale/ja/LC_MESSAGES/xsystem35.mo
%%PORTDOCS%%share/doc/ja/xsystem35/TECH.TXT
%%PORTDOCS%%share/doc/ja/xsystem35/THANKS
%%PORTDOCS%%share/doc/ja/xsystem35/TODO
-share/examples/xsystem35/README.TXT
-share/examples/xsystem35/456atlach.inf
-share/examples/xsystem35/456ningen.inf
-share/examples/xsystem35/456zero.inf
-share/examples/xsystem35/ambi.inf
-share/examples/xsystem35/atlach_new.inf
-share/examples/xsystem35/dalk.inf
-share/examples/xsystem35/darcrows.inf
-share/examples/xsystem35/diabo.inf
-share/examples/xsystem35/drstop.inf
-share/examples/xsystem35/hushaby.inf
-share/examples/xsystem35/kakurezuki.inf
-share/examples/xsystem35/katsumi.inf
-share/examples/xsystem35/kichiku.inf
-share/examples/xsystem35/mamatoto.inf
-share/examples/xsystem35/mamori.inf
-share/examples/xsystem35/miko.inf
-share/examples/xsystem35/mugen.inf
-share/examples/xsystem35/oudou.inf
-share/examples/xsystem35/panyo.inf
-share/examples/xsystem35/panyo_new.inf
-share/examples/xsystem35/pascha.inf
-share/examples/xsystem35/persiom.inf
-share/examples/xsystem35/progood.inf
-share/examples/xsystem35/rance1.inf
-share/examples/xsystem35/rance2.inf
-share/examples/xsystem35/rance3.inf
-share/examples/xsystem35/rance4.inf
-share/examples/xsystem35/seeinao.inf
-share/examples/xsystem35/toushin.inf
-share/examples/xsystem35/toushin2.inf
-share/examples/xsystem35/xsys35rc.sample
-share/examples/xsystem35/pastel.diff
+%%EXAMPLESDIR%%/20cDPS.inf
+%%EXAMPLESDIR%%/20cKaeru.inf
+%%EXAMPLESDIR%%/456atlach.inf
+%%EXAMPLESDIR%%/456ningen.inf
+%%EXAMPLESDIR%%/456zero.inf
+%%EXAMPLESDIR%%/README.TXT
+%%EXAMPLESDIR%%/ambi.inf
+%%EXAMPLESDIR%%/atlach_new.inf
+%%EXAMPLESDIR%%/chairs.inf
+%%EXAMPLESDIR%%/daiakuji.inf
+%%EXAMPLESDIR%%/dalk.inf
+%%EXAMPLESDIR%%/darcrows.inf
+%%EXAMPLESDIR%%/diabo.inf
+%%EXAMPLESDIR%%/diabo_new.inf
+%%EXAMPLESDIR%%/drstop.inf
+%%EXAMPLESDIR%%/esuka.inf
+%%EXAMPLESDIR%%/hushaby.inf
+%%EXAMPLESDIR%%/kakurezuki.inf
+%%EXAMPLESDIR%%/katsumi.inf
+%%EXAMPLESDIR%%/kichiku.inf
+%%EXAMPLESDIR%%/mamatoto.inf
+%%EXAMPLESDIR%%/mamori.inf
+%%EXAMPLESDIR%%/miko.inf
+%%EXAMPLESDIR%%/mugen.inf
+%%EXAMPLESDIR%%/nd.inf
+%%EXAMPLESDIR%%/onlyyou_r.inf
+%%EXAMPLESDIR%%/oudou.inf
+%%EXAMPLESDIR%%/panyo.inf
+%%EXAMPLESDIR%%/panyo_new.inf
+%%EXAMPLESDIR%%/pascha.inf
+%%EXAMPLESDIR%%/pastel.diff
+%%EXAMPLESDIR%%/persiom.inf
+%%EXAMPLESDIR%%/progood.inf
+%%EXAMPLESDIR%%/rance1.inf
+%%EXAMPLESDIR%%/rance2.inf
+%%EXAMPLESDIR%%/rance3.inf
+%%EXAMPLESDIR%%/rance4.inf
+%%EXAMPLESDIR%%/rance5d.inf
+%%EXAMPLESDIR%%/seeinao.inf
+%%EXAMPLESDIR%%/toushin.inf
+%%EXAMPLESDIR%%/toushin2.inf
+%%EXAMPLESDIR%%/tsuma.inf
+%%EXAMPLESDIR%%/tsuma2.inf
+%%EXAMPLESDIR%%/xsys35rc.sample
+%%EXAMPLESDIR%%/zero_new.inf
+share/locale/ja/LC_MESSAGES/xsystem35.mo
+@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm share/doc/ja/xsystem35
-@dirrm share/examples/xsystem35
+@dirrm lib/xsystem35