aboutsummaryrefslogtreecommitdiff
path: root/emulators/yape
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-19 14:39:00 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-19 14:39:00 +0000
commit165f72d80a70691b9654ac00cead0004cebecfa5 (patch)
treede34f1f51183456c3218ed83debaed36cf7f1d25 /emulators/yape
parent5bc323a0c3cc336509878b0485fcaac8f46d76e6 (diff)
downloadports-165f72d80a70691b9654ac00cead0004cebecfa5.tar.gz
ports-165f72d80a70691b9654ac00cead0004cebecfa5.zip
add yape 0.32.3
Yet Another Commodore +4 Emulator PR: 45004 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu>
Notes
Notes: svn path=/head/; revision=70493
Diffstat (limited to 'emulators/yape')
-rw-r--r--emulators/yape/Makefile36
-rw-r--r--emulators/yape/distinfo1
-rw-r--r--emulators/yape/files/patch-archdep.cpp29
-rw-r--r--emulators/yape/files/patch-interface.cpp11
-rw-r--r--emulators/yape/files/patch-main.h11
-rw-r--r--emulators/yape/files/patch-sound.h11
-rw-r--r--emulators/yape/pkg-comment1
-rw-r--r--emulators/yape/pkg-descr15
-rw-r--r--emulators/yape/pkg-plist3
9 files changed, 118 insertions, 0 deletions
diff --git a/emulators/yape/Makefile b/emulators/yape/Makefile
new file mode 100644
index 000000000000..108270213176
--- /dev/null
+++ b/emulators/yape/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: yape
+# Date created: 31.10.2002
+# Whom: Janos.Mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= yape
+PORTVERSION= 0.32.3
+CATEGORIES= emulators
+MASTER_SITES= http://www.keepitretro.com/plus4/download/
+DISTNAME= yapeSDL-${PORTVERSION}
+
+MAINTAINER= janos.mohacsi@bsd.hu
+
+LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12
+
+NO_WRKSUBDIR= yes
+USE_REINPLACE= yes
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+USE_GMAKE= yes
+ALL_TARGET= yape
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|sdl-config|${SDL_CONFIG}|" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/yape ${PREFIX}/bin
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.Linux ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/emulators/yape/distinfo b/emulators/yape/distinfo
new file mode 100644
index 000000000000..908459497ad1
--- /dev/null
+++ b/emulators/yape/distinfo
@@ -0,0 +1 @@
+MD5 (yapeSDL-0.32.3.tar.gz) = 454c538dc29c78d3bd0c8523d04da137
diff --git a/emulators/yape/files/patch-archdep.cpp b/emulators/yape/files/patch-archdep.cpp
new file mode 100644
index 000000000000..dd22b3ad3a9a
--- /dev/null
+++ b/emulators/yape/files/patch-archdep.cpp
@@ -0,0 +1,29 @@
+--- archdep.cpp.orig Thu Oct 31 23:47:54 2002
++++ archdep.cpp Thu Oct 31 23:48:53 2002
+@@ -108,7 +108,7 @@
+
+ strcpy( homedir , getenv( "HOME" ));
+ //strcpy( filter, filefilter);
+- strcat( homedir, "/yape" );
++ strcat( homedir, "/.yape" );
+ chdir ( homedir );
+ dirp = opendir( homedir );
+ //fprintf( stderr, "reading from %s\n", homedir);
+@@ -136,7 +136,7 @@
+ int ad_makedirs(char *path)
+ {
+ strcpy(temp,path);
+- strcat(temp, "/yape");
++ strcat(temp, "/.yape");
+ mkdir(temp, 0777);
+
+ return 1;
+@@ -146,7 +146,7 @@
+ {
+
+ strcpy( temp, tmpchr);
+- strcat( temp, "/yape/yape.conf");
++ strcat( temp, "/.yape/yape.conf");
+
+ return temp;
+ }
diff --git a/emulators/yape/files/patch-interface.cpp b/emulators/yape/files/patch-interface.cpp
new file mode 100644
index 000000000000..3e2e1501dae7
--- /dev/null
+++ b/emulators/yape/files/patch-interface.cpp
@@ -0,0 +1,11 @@
+--- interface.cpp.orig Thu Oct 31 23:43:08 2002
++++ interface.cpp Thu Oct 31 23:43:35 2002
+@@ -10,7 +10,7 @@
+ (c) 2000, 2001 Attila Grósz
+ */
+
+-#include "SDL/SDL.h"
++#include "SDL.h"
+ #include "tedmem.h"
+ #include "interface.h"
+ #include "archdep.h"
diff --git a/emulators/yape/files/patch-main.h b/emulators/yape/files/patch-main.h
new file mode 100644
index 000000000000..f75fcff2aaef
--- /dev/null
+++ b/emulators/yape/files/patch-main.h
@@ -0,0 +1,11 @@
+--- main.h.orig Thu Oct 31 23:44:51 2002
++++ main.h Thu Oct 31 23:45:12 2002
+@@ -17,7 +17,7 @@
+ #include <string.h>
+ #include <ctype.h>
+ #include <math.h>
+-#include "SDL/SDL.h"
++#include "SDL.h"
+
+ #include "keyboard.h"
+ #include "cpu.h"
diff --git a/emulators/yape/files/patch-sound.h b/emulators/yape/files/patch-sound.h
new file mode 100644
index 000000000000..1b33377f7f49
--- /dev/null
+++ b/emulators/yape/files/patch-sound.h
@@ -0,0 +1,11 @@
+--- sound.h.orig Thu Oct 31 23:44:15 2002
++++ sound.h Thu Oct 31 23:44:25 2002
+@@ -1,7 +1,7 @@
+ #ifndef _SOUND_H
+ #define _SOUND_H
+
+-#include "SDL/SDL.h"
++#include "SDL.h"
+
+
+ class MEM;
diff --git a/emulators/yape/pkg-comment b/emulators/yape/pkg-comment
new file mode 100644
index 000000000000..dbbbb6b523f3
--- /dev/null
+++ b/emulators/yape/pkg-comment
@@ -0,0 +1 @@
+Yet Another Commodore +4 Emulator
diff --git a/emulators/yape/pkg-descr b/emulators/yape/pkg-descr
new file mode 100644
index 000000000000..b3de21bc0b21
--- /dev/null
+++ b/emulators/yape/pkg-descr
@@ -0,0 +1,15 @@
+Yet Another Commodore +4 Emulator
+
+Yape features:
+
+ - full, cycle exact MOS 7501 CPU emulation
+ - almost full TED 7360 chip emulation
+ - full ROM banking
+ - almost full tape emulation
+ - joystick emulation via cursor keys
+ - color palette based on original Commodore specs
+ - PRG and TAP file format support
+ - fake disk LOAD/SAVE to the file system
+
+WWW: http://plus4.keepitretro.com
+Janos Mohacsi
diff --git a/emulators/yape/pkg-plist b/emulators/yape/pkg-plist
new file mode 100644
index 000000000000..3e822cd0b468
--- /dev/null
+++ b/emulators/yape/pkg-plist
@@ -0,0 +1,3 @@
+bin/yape
+%%PORTDOCS%%share/doc/yape/README.Linux
+%%PORTDOCS%%@dirrm share/doc/yape