aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 00:50:28 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 00:50:28 +0000
commit3e2fd4b788942461b3fbd53d7edac9a1abc3488e (patch)
tree50f793f00a7cb711970c62063687af6cd8625387 /emulators
parentec7c5b0142aeb3539337db2d501d7b5ecf5e7284 (diff)
downloadports-3e2fd4b788942461b3fbd53d7edac9a1abc3488e.tar.gz
ports-3e2fd4b788942461b3fbd53d7edac9a1abc3488e.zip
Remove always-false/true conditions based on OSVERSION 500000
Notes
Notes: svn path=/head/; revision=200771
Diffstat (limited to 'emulators')
-rw-r--r--emulators/gcube/Makefile8
-rw-r--r--emulators/gngeo/Makefile4
-rw-r--r--emulators/hercules/Makefile4
-rw-r--r--emulators/linux-vmware-toolbox4/Makefile8
-rw-r--r--emulators/linux-vmware-toolbox5/Makefile4
-rw-r--r--emulators/linux-vmware-toolbox6/Makefile4
-rw-r--r--emulators/mupen64-base/Makefile4
-rw-r--r--emulators/pearpc/Makefile4
-rw-r--r--emulators/snes9express/Makefile8
-rw-r--r--emulators/uae/Makefile8
-rw-r--r--emulators/vice/Makefile5
-rw-r--r--emulators/vmware-tools3/Makefile8
12 files changed, 5 insertions, 64 deletions
diff --git a/emulators/gcube/Makefile b/emulators/gcube/Makefile
index b325e448b677..f154583b5d69 100644
--- a/emulators/gcube/Makefile
+++ b/emulators/gcube/Makefile
@@ -54,10 +54,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES= ${FILESDIR}/cpu.c-patch
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/gngeo/Makefile b/emulators/gngeo/Makefile
index b4ceb9309a34..2852e9819a0c 100644
--- a/emulators/gngeo/Makefile
+++ b/emulators/gngeo/Makefile
@@ -39,10 +39,6 @@ MAN1= gngeo.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src__emu.h
-.endif
-
.if !defined(WITHOUT_I386ASM) || !defined(WITHOUT_RAZE) || \
!defined(WITHOUT_STAR)
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
diff --git a/emulators/hercules/Makefile b/emulators/hercules/Makefile
index 099ce064e3b7..6e28203dfa37 100644
--- a/emulators/hercules/Makefile
+++ b/emulators/hercules/Makefile
@@ -42,10 +42,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= does not compile on FreeBSD 4.x
-.endif
-
.if defined(WITH_DEBUG)
CFLAGS+= -g
.endif
diff --git a/emulators/linux-vmware-toolbox4/Makefile b/emulators/linux-vmware-toolbox4/Makefile
index 51d74980c208..9f26764b6339 100644
--- a/emulators/linux-vmware-toolbox4/Makefile
+++ b/emulators/linux-vmware-toolbox4/Makefile
@@ -36,13 +36,7 @@ NO_LATEST_LINK= yes
VMWARE_VER= 4.5.2
BUILD_VER= 8848
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-MOUNT_DEV?= /dev/acd0c
-.else
MOUNT_DEV?= /dev/acd0
-.endif
MOUNT_PT?= /mnt
MOUNT= /sbin/mount
UMOUNT= /sbin/umount
@@ -91,4 +85,4 @@ do-install:
${BRANDELF} -t Linux ${WRKSRC}/bin/vmware-toolbox
${INSTALL_PROGRAM} ${WRKSRC}/bin/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/linux-vmware-toolbox5/Makefile b/emulators/linux-vmware-toolbox5/Makefile
index 77d0cb092888..47b46ce3cc07 100644
--- a/emulators/linux-vmware-toolbox5/Makefile
+++ b/emulators/linux-vmware-toolbox5/Makefile
@@ -39,11 +39,7 @@ BUILD_VER= 19175
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-MOUNT_DEV?= /dev/acd0c
-.else
MOUNT_DEV?= /dev/acd0
-.endif
MOUNT_PT?= /mnt
MOUNT= /sbin/mount
UMOUNT= /sbin/umount
diff --git a/emulators/linux-vmware-toolbox6/Makefile b/emulators/linux-vmware-toolbox6/Makefile
index 2b98726c0204..bc6df4f84ae4 100644
--- a/emulators/linux-vmware-toolbox6/Makefile
+++ b/emulators/linux-vmware-toolbox6/Makefile
@@ -39,11 +39,7 @@ BUILD_VER= 55017
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-MOUNT_DEV?= /dev/acd0c
-.else
MOUNT_DEV?= /dev/acd0
-.endif
MOUNT_PT?= /mnt
MOUNT= /sbin/mount
UMOUNT= /sbin/umount
diff --git a/emulators/mupen64-base/Makefile b/emulators/mupen64-base/Makefile
index ac990ef2b331..f7cff58cde04 100644
--- a/emulators/mupen64-base/Makefile
+++ b/emulators/mupen64-base/Makefile
@@ -67,8 +67,4 @@ CFLAGS+= -DX86 -mcpu=athlon
MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-.if ${OSVERSION} < 500000
-LDFLAGS+= -L/usr/lib -lcipher
-.endif
-
.include <bsd.port.post.mk>
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index 11d5954e8652..d27deb36e44c 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -97,10 +97,6 @@ pre-configure:
post-configure:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/src/Makefile
-.if ${OSVERSION} < 500000
- @${CP} ${FILESDIR}/wcrtomb.c ${FILESDIR}/mbrtowc.c \
- ${WRKSRC}/
-.endif
post-install:
@${MKDIR} ${DATADIR}
diff --git a/emulators/snes9express/Makefile b/emulators/snes9express/Makefile
index 0f91d824db9d..a877b5f22546 100644
--- a/emulators/snes9express/Makefile
+++ b/emulators/snes9express/Makefile
@@ -23,12 +23,6 @@ USE_XLIB= yes
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
-
post-configure:
@${REINPLACE_CMD} -e 's|lstat$$U.o||' ${WRKSRC}/Makefile
@@ -44,4 +38,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/uae/Makefile b/emulators/uae/Makefile
index 948736d4cd72..fbc5af67c964 100644
--- a/emulators/uae/Makefile
+++ b/emulators/uae/Makefile
@@ -59,10 +59,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/amiga/devs/AHI/uae.audio ${DATADIR}/amiga/devs/AHI/
${INSTALL_DATA} ${WRKSRC}/amiga/devs/AudioModes/UAE ${DATADIR}/amiga/devs/AudioModes/
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Doesn't build on FreeBSD < 5.x"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 997d2c5c3307..c498989956de 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -88,11 +88,6 @@ CONFIGURE_ARGS+= --with-esd
CONFIGURE_ARGS+= --without-esd
.endif
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-# ../src/resid/libresid.a(wave.o)(.rodata+0x0): relocation truncated to fit: GPREL32 *UND*
-BROKEN= "GPREL relocation truncated"
-.endif
-
post-extract:
@${RM} -f ${WRKSRC}/doc/vice.info*
diff --git a/emulators/vmware-tools3/Makefile b/emulators/vmware-tools3/Makefile
index 4061e3b1a02a..dc0ddf592142 100644
--- a/emulators/vmware-tools3/Makefile
+++ b/emulators/vmware-tools3/Makefile
@@ -36,13 +36,7 @@ NO_PACKAGE= ${RESTRICTED}
VMWARE_VER= 3.2.1
BUILD_VER= 2237
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-MOUNT_DEV?= /dev/acd0c
-.else
MOUNT_DEV?= /dev/acd0
-.endif
MOUNT_PT?= /mnt
MOUNT= /sbin/mount
UMOUNT= /sbin/umount
@@ -83,4 +77,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/vmware-toolbox ${PREFIX}/bin
-${LOCALBASE}/sbin/vmware-guestd --cmd toolinstall.end
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>