aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2005-04-12 03:26:56 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2005-04-12 03:26:56 +0000
commitc3d8037aeba75366ed06e02fbc981e15b46e7d0a (patch)
tree6074bae79118b7d7d4d3d3a8ac0a4dcd65f18f8b /emulators
parentb286f01b6c3af5d674e10da33f8eda0c2011007b (diff)
downloadports-c3d8037aeba75366ed06e02fbc981e15b46e7d0a.tar.gz
ports-c3d8037aeba75366ed06e02fbc981e15b46e7d0a.zip
At Kris's request, back out the MACHINE_ARCH spelling correction until
after 5.4-RELEASE.
Notes
Notes: svn path=/head/; revision=133116
Diffstat (limited to 'emulators')
-rw-r--r--emulators/atari800/Makefile2
-rw-r--r--emulators/bochs/Makefile2
-rw-r--r--emulators/generator/Makefile2
-rw-r--r--emulators/hatari/Makefile2
-rw-r--r--emulators/kmamerun/Makefile2
-rw-r--r--emulators/linux_base-suse-9.1/Makefile8
-rw-r--r--emulators/pearpc/Makefile2
-rw-r--r--emulators/snes9x/Makefile2
-rw-r--r--emulators/twin/Makefile2
-rw-r--r--emulators/xbraitenberg/Makefile2
-rw-r--r--emulators/zsnes/Makefile2
11 files changed, 14 insertions, 14 deletions
diff --git a/emulators/atari800/Makefile b/emulators/atari800/Makefile
index a6c5ebc4433f..6a47a2e4c637 100644
--- a/emulators/atari800/Makefile
+++ b/emulators/atari800/Makefile
@@ -26,7 +26,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= atari800.1
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 33218a950af2..c76123efe061 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -24,7 +24,7 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-split-hd \
--enable-all-optimizations \
--with-x11 \
diff --git a/emulators/generator/Makefile b/emulators/generator/Makefile
index 1265f8023088..4476c4f23f3a 100644
--- a/emulators/generator/Makefile
+++ b/emulators/generator/Makefile
@@ -22,7 +22,7 @@ USE_SDL= sdl
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-gtk
diff --git a/emulators/hatari/Makefile b/emulators/hatari/Makefile
index 7acab72474a5..cfa31d4ec237 100644
--- a/emulators/hatari/Makefile
+++ b/emulators/hatari/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An Atari ST emulator
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_SDL= yes
diff --git a/emulators/kmamerun/Makefile b/emulators/kmamerun/Makefile
index 36b34b50521f..1c6084e286c1 100644
--- a/emulators/kmamerun/Makefile
+++ b/emulators/kmamerun/Makefile
@@ -19,6 +19,6 @@ RUN_DEPENDS= xmame:${PORTSDIR}/emulators/xmame
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
CONFIGURE_TARGET=
-CONFIGURE_ARGS+=--build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/emulators/linux_base-suse-9.1/Makefile b/emulators/linux_base-suse-9.1/Makefile
index 386141aec64a..a6ae7f8a1742 100644
--- a/emulators/linux_base-suse-9.1/Makefile
+++ b/emulators/linux_base-suse-9.1/Makefile
@@ -39,7 +39,6 @@ DISTFILES= suse-release-9.1-0.i586.rpm \
libgcc-3.3.3-41.i586.rpm \
termcap-2.0.8-876.i586.rpm \
freetype2-2.1.7-53.i586.rpm
-EXTRACT_ONLY=
MAINTAINER= trevor@FreeBSD.org
COMMENT= Basic packages for Linux mode from SUSE 9.1/i386
@@ -52,7 +51,7 @@ CONFLICTS= linux_base-6* linux_base-7* linux_base-debian* \
NO_LATEST_LINK= yes
RESTRICTED= "binaries under GNU GPL without accompanying source"
ONLY_FOR_ARCHS= i386
-DIST_SUBDIR= rpm/${ARCH}/suse
+DIST_SUBDIR= rpm/${MACHINE_ARCH}/suse
PREFIX= ${LINUXBASE}
NO_BUILD= yes
NO_FILTER_SHLIBS= yes
@@ -82,7 +81,7 @@ FALLBACK_ELF_MIB= kern.fallback_elf_brand
LINUX_ELF= 3
PREVIOUS_ELF!= /sbin/sysctl -n ${FALLBACK_ELF_MIB}
-pre-install:
+do-extract:
#
# Handle the loading of the linux loadable kernel module if required.
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@@ -113,7 +112,7 @@ pre-install:
# mtab in etc, albeit an empty one. This is needed in a couple of
# cases. Most notably staroffice6.
#
- ${INSTALL_DATA} ${FILESDIR}/yp.conf ${WRKSRC}/etc
+ ${INSTALL} ${COPY} -m 644 ${FILESDIR}/yp.conf ${WRKSRC}/etc
${TOUCH} ${WRKSRC}/etc/mtab ${WRKSRC}/etc/host.conf
#
# Finish
@@ -126,6 +125,7 @@ pre-install:
done
@${LN} -sf /var/tmp ${WRKSRC}/usr/tmp
+pre-install:
${RM} -f ${PLIST}
cd ${WRKSRC} && ${FIND} -s . -type f -o -type l | \
${CUT} -c3-999 >> ${PLIST} \
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index d893ddb03b8b..4e85deb336f9 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -17,7 +17,7 @@ COMMENT= PowerPC emulator
USE_XLIB= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PKGMESSAGE= ${WRKDIR}/pkg-message
MAN1= ppc.1
diff --git a/emulators/snes9x/Makefile b/emulators/snes9x/Makefile
index 81be44a46e8a..c9ac5f7b7bdb 100644
--- a/emulators/snes9x/Makefile
+++ b/emulators/snes9x/Makefile
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
USE_X_PREFIX= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAKE_ARGS= INCLUDES="-I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDLIBS="-L${X11BASE}/lib ${PTHREAD_LIBS}" \
OPTIMISE="${CXXFLAGS}"
diff --git a/emulators/twin/Makefile b/emulators/twin/Makefile
index 112eae21dad5..e8a042738ba1 100644
--- a/emulators/twin/Makefile
+++ b/emulators/twin/Makefile
@@ -25,7 +25,7 @@ USE_XLIB= yes
USE_REINPLACE= yes
USE_AUTOCONF_VER= 213
GNU_CONFIGURE= yes
-.if ${ARCH} == "alpha"
+.if ${MACHINE_ARCH} == "alpha"
CONFIGURE_ARGS+=--disable-intp
.endif
USE_GMAKE= yes
diff --git a/emulators/xbraitenberg/Makefile b/emulators/xbraitenberg/Makefile
index 6c5942238441..06dd79ca6176 100644
--- a/emulators/xbraitenberg/Makefile
+++ b/emulators/xbraitenberg/Makefile
@@ -15,7 +15,7 @@ COMMENT= A Braitenberg vehicle simulator with pseudo-physics
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LIBS="-L${X11BASE}/lib"
diff --git a/emulators/zsnes/Makefile b/emulators/zsnes/Makefile
index 6ff04da6cf49..e5355f4fb097 100644
--- a/emulators/zsnes/Makefile
+++ b/emulators/zsnes/Makefile
@@ -31,7 +31,7 @@ USE_GL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yyes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
ALL_TARGET= ALL