aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2005-11-10 15:29:12 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2005-11-10 15:29:12 +0000
commit5530378497930172e4e23d9112b6784cc7b5c426 (patch)
tree26b8250da1e8ff81404f44fdf315fd24aac1e6bd /emulators
parent8cbd6f66060cf0f9cd2062fc68f7fb7f64889125 (diff)
downloadports-5530378497930172e4e23d9112b6784cc7b5c426.tar.gz
ports-5530378497930172e4e23d9112b6784cc7b5c426.zip
Update to Wine 0.9.1.
Set CFLAGS incrementally, and note that we are in beta now. [1] PR: 88492 [1] Submitted by: Andrew Pantyukhin <infofarmer@gmail.com> [1]
Notes
Notes: svn path=/head/; revision=147842
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile6
-rw-r--r--emulators/wine-devel/distinfo4
-rw-r--r--emulators/wine-devel/pkg-descr2
-rw-r--r--emulators/wine-devel/pkg-plist4
-rw-r--r--emulators/wine/Makefile6
-rw-r--r--emulators/wine/distinfo4
-rw-r--r--emulators/wine/pkg-descr2
-rw-r--r--emulators/wine/pkg-plist4
8 files changed, 16 insertions, 16 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 951cf0e334bf..08bcb5815815 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-PORTVERSION= 0.9
+PORTVERSION= 0.9.1
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
@@ -27,11 +27,11 @@ MAN1= widl.1 wine.1 winebuild.1 winedbg.1 winedump.1 winegcc.1 \
winemaker.1 wineserver.1 wmc.1 wrc.1
ONLY_FOR_ARCHS= i386
USE_BISON= yes
+USE_BZIP2= yes
USE_GMAKE= yes
USE_GL= yes
USE_MESA= yes # wine/dlls/glut32/ depends on the presence of libglut.
USE_XPM= yes
-USE_BZIP2= yes
.include <bsd.port.pre.mk>
@@ -42,7 +42,7 @@ IGNORE= fails to work on versions of FreeBSD before 5.3 (due to problems with t
.if defined(DEBUG)
STRIP=
.else
-CFLAGS= -O2
+CFLAGS+= -O2
pre-extract:
@${ECHO} "DEBUG has not been set, building without debug info."
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index ec6587f919a3..accb998f5acf 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (wine-0.9.tar.bz2) = 20858ca2bcfc6ae765007c40e5cdd550
-SIZE (wine-0.9.tar.bz2) = 10036834
+MD5 (wine-0.9.1.tar.bz2) = c6453803be17088789ebce61aeefc0d1
+SIZE (wine-0.9.1.tar.bz2) = 10165557
diff --git a/emulators/wine-devel/pkg-descr b/emulators/wine-devel/pkg-descr
index 279db96df9a1..55ca19427ccb 100644
--- a/emulators/wine-devel/pkg-descr
+++ b/emulators/wine-devel/pkg-descr
@@ -1,7 +1,7 @@
Wine is a Microsoft Windows compatibility layer running under Unix-like
systems on i386 (and compatible) CPUs.
-It is still alpha quality, but is definitely making progress. Most
+It is still beta quality, but is definitely making progress. Most
applications already work, more or less, including several games.
WWW: http://www.winehq.com/
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index 6fe17d0fc213..ce76c728dd07 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -456,6 +456,7 @@ lib/wine/dpnet.dll.so
lib/wine/dsound.dll.so
lib/wine/dswave.dll.so
lib/wine/dxdiagn.dll.so
+lib/wine/eject.exe.so
lib/wine/expand.exe.so
lib/wine/gdi.exe.so
lib/wine/gdi32.dll.so
@@ -682,7 +683,7 @@ lib/wine/shell32.dll.so
lib/wine/shfolder.dll.so
lib/wine/shlwapi.dll.so
lib/wine/snmpapi.dll.so
-lib/wine/sound.dll.so
+lib/wine/sound.drv.so
lib/wine/start.exe.so
lib/wine/stdole2.tlb.so
lib/wine/stdole32.tlb.so
@@ -742,7 +743,6 @@ lib/wine/winepath.exe.so
lib/wine/wineps.drv.so
lib/wine/wineps16.drv.so
lib/wine/winetest.exe.so
-lib/wine/winetty.drv.so
lib/wine/winevdm.exe.so
lib/wine/winex11.drv.so
lib/wine/wing.dll.so
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 951cf0e334bf..08bcb5815815 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-PORTVERSION= 0.9
+PORTVERSION= 0.9.1
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
@@ -27,11 +27,11 @@ MAN1= widl.1 wine.1 winebuild.1 winedbg.1 winedump.1 winegcc.1 \
winemaker.1 wineserver.1 wmc.1 wrc.1
ONLY_FOR_ARCHS= i386
USE_BISON= yes
+USE_BZIP2= yes
USE_GMAKE= yes
USE_GL= yes
USE_MESA= yes # wine/dlls/glut32/ depends on the presence of libglut.
USE_XPM= yes
-USE_BZIP2= yes
.include <bsd.port.pre.mk>
@@ -42,7 +42,7 @@ IGNORE= fails to work on versions of FreeBSD before 5.3 (due to problems with t
.if defined(DEBUG)
STRIP=
.else
-CFLAGS= -O2
+CFLAGS+= -O2
pre-extract:
@${ECHO} "DEBUG has not been set, building without debug info."
diff --git a/emulators/wine/distinfo b/emulators/wine/distinfo
index ec6587f919a3..accb998f5acf 100644
--- a/emulators/wine/distinfo
+++ b/emulators/wine/distinfo
@@ -1,2 +1,2 @@
-MD5 (wine-0.9.tar.bz2) = 20858ca2bcfc6ae765007c40e5cdd550
-SIZE (wine-0.9.tar.bz2) = 10036834
+MD5 (wine-0.9.1.tar.bz2) = c6453803be17088789ebce61aeefc0d1
+SIZE (wine-0.9.1.tar.bz2) = 10165557
diff --git a/emulators/wine/pkg-descr b/emulators/wine/pkg-descr
index 279db96df9a1..55ca19427ccb 100644
--- a/emulators/wine/pkg-descr
+++ b/emulators/wine/pkg-descr
@@ -1,7 +1,7 @@
Wine is a Microsoft Windows compatibility layer running under Unix-like
systems on i386 (and compatible) CPUs.
-It is still alpha quality, but is definitely making progress. Most
+It is still beta quality, but is definitely making progress. Most
applications already work, more or less, including several games.
WWW: http://www.winehq.com/
diff --git a/emulators/wine/pkg-plist b/emulators/wine/pkg-plist
index 6fe17d0fc213..ce76c728dd07 100644
--- a/emulators/wine/pkg-plist
+++ b/emulators/wine/pkg-plist
@@ -456,6 +456,7 @@ lib/wine/dpnet.dll.so
lib/wine/dsound.dll.so
lib/wine/dswave.dll.so
lib/wine/dxdiagn.dll.so
+lib/wine/eject.exe.so
lib/wine/expand.exe.so
lib/wine/gdi.exe.so
lib/wine/gdi32.dll.so
@@ -682,7 +683,7 @@ lib/wine/shell32.dll.so
lib/wine/shfolder.dll.so
lib/wine/shlwapi.dll.so
lib/wine/snmpapi.dll.so
-lib/wine/sound.dll.so
+lib/wine/sound.drv.so
lib/wine/start.exe.so
lib/wine/stdole2.tlb.so
lib/wine/stdole32.tlb.so
@@ -742,7 +743,6 @@ lib/wine/winepath.exe.so
lib/wine/wineps.drv.so
lib/wine/wineps16.drv.so
lib/wine/winetest.exe.so
-lib/wine/winetty.drv.so
lib/wine/winevdm.exe.so
lib/wine/winex11.drv.so
lib/wine/wing.dll.so