aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-08-17 14:20:40 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-08-17 14:20:40 +0000
commit21a283f3bec444388d1448f993783ec673a06502 (patch)
tree16be3a9188cf2781563095e15839c170074dd7a7 /emulators
parentcda45bfa8a05d49eb690397ab1b7facd622490a7 (diff)
downloadports-21a283f3bec444388d1448f993783ec673a06502.tar.gz
ports-21a283f3bec444388d1448f993783ec673a06502.zip
Remove UNIQUENAME and LATEST_LINK.
UNIQUENAME was never unique, it was only used by USE_LDCONFIG and now, we won't have conflicts there. Use PKGBASE instead of LATEST_LINK in PKGLATESTFILE, the *only* consumer is pkg-devel, and it works just fine without LATEST_LINK as pkg-devel has the correct PKGNAME anyway. Now that UNIQUENAME is gone, OPTIONSFILE is too. (it's been called OPTIONS_FILE now.) Reviewed by: antoine, bapt Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D3336
Notes
Notes: svn path=/head/; revision=394508
Diffstat (limited to 'emulators')
-rw-r--r--emulators/generator-cbiere/Makefile4
-rw-r--r--emulators/i386-wine-devel/Makefile.inc2
-rw-r--r--emulators/i386-wine/Makefile.inc2
-rw-r--r--emulators/linux_base-c6/Makefile1
-rw-r--r--emulators/linux_base-f10/Makefile1
-rw-r--r--emulators/mupen64plus-core/Makefile1
-rw-r--r--emulators/virtualbox-ose-additions/Makefile1
-rw-r--r--emulators/virtualbox-ose-kmod/Makefile1
8 files changed, 4 insertions, 9 deletions
diff --git a/emulators/generator-cbiere/Makefile b/emulators/generator-cbiere/Makefile
index e7240cef0c0b..1e8f3c02de7d 100644
--- a/emulators/generator-cbiere/Makefile
+++ b/emulators/generator-cbiere/Makefile
@@ -19,14 +19,14 @@ USES= gmake jpeg tar:bzip2
USE_GNOME= gtk12
USE_SDL= sdl
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-transform-name=s/${PORTNAME}/${UNIQUENAME}/ \
+CONFIGURE_ARGS= --program-transform-name=s/${PORTNAME}/${PORTNAME}/ \
--with-gtk
MAKE_JOBS_UNSAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES= bin/${UNIQUENAME}-gtk
+PLIST_FILES= bin/${PORTNAME}-gtk
OPTIONS_DEFINE= OPTIMIZED_CFLAGS SDL
OPTIONS_DEFINE_i386= RAZE
diff --git a/emulators/i386-wine-devel/Makefile.inc b/emulators/i386-wine-devel/Makefile.inc
index 8da6f49a53c4..53f9eabf30bc 100644
--- a/emulators/i386-wine-devel/Makefile.inc
+++ b/emulators/i386-wine-devel/Makefile.inc
@@ -28,7 +28,7 @@ CONFLICTS_INSTALL?= wine-[0-9]* wine-staging-[0-9]* wine-devel-[0-9]* \
EXTRACT_AFTER_ARGS= -C / --exclude +COMPACT_MANIFEST --exclude +MANIFEST \
--exclude +MTREE_DIRS --exclude share/licenses/'*' \
- --exclude libdata/ldconfig32/${UNIQUENAME} \
+ --exclude libdata/ldconfig32/${PKGNAMEPREFIX}${PORTNAME} \
-s '|/usr/local|${STAGEDIR}${PREFIX}|gs'
NO_BUILD= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/emulators/i386-wine/Makefile.inc b/emulators/i386-wine/Makefile.inc
index 82aa02cb180e..6e429a901b38 100644
--- a/emulators/i386-wine/Makefile.inc
+++ b/emulators/i386-wine/Makefile.inc
@@ -28,7 +28,7 @@ CONFLICTS_INSTALL?= wine-[0-9]* wine-staging-[0-9]* wine-devel-[0-9]* \
EXTRACT_AFTER_ARGS= -C / --exclude +COMPACT_MANIFEST --exclude +MANIFEST \
--exclude +MTREE_DIRS --exclude share/licenses/'*' \
- --exclude libdata/ldconfig32/${UNIQUENAME} \
+ --exclude libdata/ldconfig32/${PKGNAMEPREFIX}-${PORTNAME} \
-s '|/usr/local|${STAGEDIR}${PREFIX}|gs'
NO_BUILD= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/emulators/linux_base-c6/Makefile b/emulators/linux_base-c6/Makefile
index 498ae3189493..d48d0a48179d 100644
--- a/emulators/linux_base-c6/Makefile
+++ b/emulators/linux_base-c6/Makefile
@@ -175,7 +175,6 @@ FALLBACK_ELF_MIB= kern.fallback_elf_brand
.if (${ARCH} == "amd64")
. if defined(OVERRIDE_LINUX_BASE_PORT) && ${OVERRIDE_LINUX_BASE_PORT} != "c6_64"
-LATEST_LINK:= ${PKGBASE:C/linux/linux32/}
ARCH= i386
. endif
.endif
diff --git a/emulators/linux_base-f10/Makefile b/emulators/linux_base-f10/Makefile
index 8915809c6cec..22454de93b55 100644
--- a/emulators/linux_base-f10/Makefile
+++ b/emulators/linux_base-f10/Makefile
@@ -146,7 +146,6 @@ FALLBACK_ELF_MIB= kern.fallback_elf_brand
.endif
.if (${ARCH} == "amd64")
-LATEST_LINK:= ${PKGBASE:C/linux/linux32/}
ARCH= i386
.endif
diff --git a/emulators/mupen64plus-core/Makefile b/emulators/mupen64plus-core/Makefile
index 5414931e8568..5b6682bc2316 100644
--- a/emulators/mupen64plus-core/Makefile
+++ b/emulators/mupen64plus-core/Makefile
@@ -24,7 +24,6 @@ ONLY_FOR_ARCHS= i386 amd64
OPTFLAGS= #
MAKE_ENV+= OPTFLAGS="${OPTFLAGS}"
-OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
.include "${.CURDIR}/../mupen64plus-core/Makefile.common"
.include <bsd.port.mk>
diff --git a/emulators/virtualbox-ose-additions/Makefile b/emulators/virtualbox-ose-additions/Makefile
index 6992d2e36306..e982b6a41ece 100644
--- a/emulators/virtualbox-ose-additions/Makefile
+++ b/emulators/virtualbox-ose-additions/Makefile
@@ -22,7 +22,6 @@ BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
CPE_VENDOR= oracle
CPE_PRODUCT= vm_virtualbox
-UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
PATCHDIR= ${.CURDIR}/../${PORTNAME}/files
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
USE_RC_SUBR= vboxguest vboxservice
diff --git a/emulators/virtualbox-ose-kmod/Makefile b/emulators/virtualbox-ose-kmod/Makefile
index 789dcad63bd2..ae30d444bd16 100644
--- a/emulators/virtualbox-ose-kmod/Makefile
+++ b/emulators/virtualbox-ose-kmod/Makefile
@@ -22,7 +22,6 @@ CPE_VENDOR= oracle
CPE_PRODUCT= vm_virtualbox
USES= cpe kmod tar:bzip2
-UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
PATCHDIR= ${.CURDIR}/../${PORTNAME}/files
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
USE_RC_SUBR= vboxnet