aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-06-23 16:28:59 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-06-23 16:28:59 +0000
commit7892bbf2dc4584574a338cfb4afa8a9dfae2229e (patch)
treecd8d53186fc490e31618d6cd36a3ff7154e2da5c /emulators
parentdfca6a087069790ce3d3f0753bc9603949b82f3b (diff)
downloadports-7892bbf2dc4584574a338cfb4afa8a9dfae2229e.tar.gz
ports-7892bbf2dc4584574a338cfb4afa8a9dfae2229e.zip
Update to 3.2.0
Based on PR: ports/63663 Submitted by: Miguel Mendez Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=112069
Diffstat (limited to 'emulators')
-rw-r--r--emulators/sim/Makefile22
-rw-r--r--emulators/sim/distinfo4
-rw-r--r--emulators/sim/files/patch-makefile18
-rw-r--r--emulators/sim/pkg-plist25
-rw-r--r--emulators/simh/Makefile22
-rw-r--r--emulators/simh/distinfo4
-rw-r--r--emulators/simh/files/patch-makefile18
-rw-r--r--emulators/simh/pkg-plist25
8 files changed, 44 insertions, 94 deletions
diff --git a/emulators/sim/Makefile b/emulators/sim/Makefile
index 3c43f5c6a6d6..5a277fcfbf53 100644
--- a/emulators/sim/Makefile
+++ b/emulators/sim/Makefile
@@ -6,13 +6,10 @@
#
PORTNAME= sim
-PORTVERSION= 3.0.2
-PORTREVISION= 1
+PORTVERSION= 3.2.0
CATEGORIES= emulators
-MASTER_SITES= http://simh.trailing-edge.com/sources/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR=jedgar
-DISTNAME= ${PORTNAME}hv30-2
+MASTER_SITES= http://simh.trailing-edge.com/sources/
+DISTNAME= ${PORTNAME}hv32-0
MAINTAINER= jedgar@FreeBSD.org
COMMENT= PDP-8, PDP-11, PDP-1, other 18b PDP, Nova, and IBM 1401 simulators
@@ -29,11 +26,14 @@ BIN_FILES= pdp1 pdp4 pdp7 pdp8 pdp9 \
pdp15 pdp11 pdp10 vax nova \
eclipse h316 hp2100 i1401 \
i1620 s3 altair altairz80 \
- gri ibm1130 id16 id32 sds
+ gri ibm1130 id16 id32 sds lgp
-PORTDOCS= 0readme_30.txt simh_doc.txt simh_swre.txt \
+PORTDOCS= 0readme_32.txt simh_doc.txt simh_swre.txt \
0readme_ethernet.txt simh_faq.txt
+PLIST_FILES= ${BIN_FILES:S/^/bin\//g} share/sim/ka655.bin share/sim/ka655x.bin
+PLIST_DIRS= share/sim
+
pre-patch:
@${MKDIR} ${WRKSRC}/BIN
@for i in ${WRKSRC}/makefile `${FIND} ${WRKSRC} -name "*.[hc]"`; do \
@@ -47,12 +47,12 @@ do-install:
.endfor
@${MKDIR} ${PREFIX}/share/sim
- ${INSTALL_DATA} ${WRKDIR}/VAX/ka655.bin ${PREFIX}/share/sim
+ ${INSTALL_DATA} ${WRKDIR}/VAX/ka655*.bin ${PREFIX}/share/sim
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/sim
+ @${MKDIR} ${DOCSDIR}
@for i in ${PORTDOCS}; do\
- ${INSTALL_DATA} ${WRKDIR}/$$i ${PREFIX}/share/doc/sim; \
+ ${INSTALL_DATA} ${WRKDIR}/$$i ${DOCSDIR}; \
done
.endif
diff --git a/emulators/sim/distinfo b/emulators/sim/distinfo
index 5669f82745ac..60302168ecdf 100644
--- a/emulators/sim/distinfo
+++ b/emulators/sim/distinfo
@@ -1,2 +1,2 @@
-MD5 (simhv30-2.zip) = 3747e8b28b284ba06edc0c7ea549abe4
-SIZE (simhv30-2.zip) = 1757964
+MD5 (simhv32-0.zip) = 431a1b7915e9aa9253eab83a366590bf
+SIZE (simhv32-0.zip) = 1914305
diff --git a/emulators/sim/files/patch-makefile b/emulators/sim/files/patch-makefile
index 1e61f59270b4..faa54a9b6722 100644
--- a/emulators/sim/files/patch-makefile
+++ b/emulators/sim/files/patch-makefile
@@ -1,11 +1,11 @@
---- makefile.orig Tue Oct 28 18:02:43 2003
-+++ makefile Tue Oct 28 18:03:09 2003
-@@ -5,7 +5,7 @@
- #
- ifeq ($(WIN32),)
- #Unix Environments
--CC = gcc -O2 -lm -I .
-+CC = gcc ${CFLAGS} -lm -I .
- #CC = gcc -O2 -g -lm -I .
+--- makefile.orig Wed Jun 23 18:01:06 2004
++++ makefile Wed Jun 23 18:01:50 2004
+@@ -10,7 +10,7 @@
+ else
+ OS_CCDEFS = -D_GNU_SOURCE
+ endif
+-CC = gcc -std=c99 -O2 -g -lm $(OS_CCDEFS) -I .
++CC += ${CFLAGS} -lm $(OS_CCDEFS) -I .
ifeq ($(USE_NETWORK),)
else
+ NETWORK_OPT = -DUSE_NETWORK -lpcap -isystem /usr/local/include -L /usr/local/lib
diff --git a/emulators/sim/pkg-plist b/emulators/sim/pkg-plist
deleted file mode 100644
index e4117b4eb3a1..000000000000
--- a/emulators/sim/pkg-plist
+++ /dev/null
@@ -1,25 +0,0 @@
-bin/pdp1
-bin/pdp4
-bin/pdp7
-bin/pdp8
-bin/pdp9
-bin/pdp15
-bin/pdp11
-bin/pdp10
-bin/vax
-bin/nova
-bin/eclipse
-bin/h316
-bin/hp2100
-bin/i1401
-bin/i1620
-bin/s3
-bin/altair
-bin/altairz80
-bin/gri
-bin/ibm1130
-bin/id16
-bin/id32
-bin/sds
-share/sim/ka655.bin
-@dirrm share/sim
diff --git a/emulators/simh/Makefile b/emulators/simh/Makefile
index 3c43f5c6a6d6..5a277fcfbf53 100644
--- a/emulators/simh/Makefile
+++ b/emulators/simh/Makefile
@@ -6,13 +6,10 @@
#
PORTNAME= sim
-PORTVERSION= 3.0.2
-PORTREVISION= 1
+PORTVERSION= 3.2.0
CATEGORIES= emulators
-MASTER_SITES= http://simh.trailing-edge.com/sources/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR=jedgar
-DISTNAME= ${PORTNAME}hv30-2
+MASTER_SITES= http://simh.trailing-edge.com/sources/
+DISTNAME= ${PORTNAME}hv32-0
MAINTAINER= jedgar@FreeBSD.org
COMMENT= PDP-8, PDP-11, PDP-1, other 18b PDP, Nova, and IBM 1401 simulators
@@ -29,11 +26,14 @@ BIN_FILES= pdp1 pdp4 pdp7 pdp8 pdp9 \
pdp15 pdp11 pdp10 vax nova \
eclipse h316 hp2100 i1401 \
i1620 s3 altair altairz80 \
- gri ibm1130 id16 id32 sds
+ gri ibm1130 id16 id32 sds lgp
-PORTDOCS= 0readme_30.txt simh_doc.txt simh_swre.txt \
+PORTDOCS= 0readme_32.txt simh_doc.txt simh_swre.txt \
0readme_ethernet.txt simh_faq.txt
+PLIST_FILES= ${BIN_FILES:S/^/bin\//g} share/sim/ka655.bin share/sim/ka655x.bin
+PLIST_DIRS= share/sim
+
pre-patch:
@${MKDIR} ${WRKSRC}/BIN
@for i in ${WRKSRC}/makefile `${FIND} ${WRKSRC} -name "*.[hc]"`; do \
@@ -47,12 +47,12 @@ do-install:
.endfor
@${MKDIR} ${PREFIX}/share/sim
- ${INSTALL_DATA} ${WRKDIR}/VAX/ka655.bin ${PREFIX}/share/sim
+ ${INSTALL_DATA} ${WRKDIR}/VAX/ka655*.bin ${PREFIX}/share/sim
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/sim
+ @${MKDIR} ${DOCSDIR}
@for i in ${PORTDOCS}; do\
- ${INSTALL_DATA} ${WRKDIR}/$$i ${PREFIX}/share/doc/sim; \
+ ${INSTALL_DATA} ${WRKDIR}/$$i ${DOCSDIR}; \
done
.endif
diff --git a/emulators/simh/distinfo b/emulators/simh/distinfo
index 5669f82745ac..60302168ecdf 100644
--- a/emulators/simh/distinfo
+++ b/emulators/simh/distinfo
@@ -1,2 +1,2 @@
-MD5 (simhv30-2.zip) = 3747e8b28b284ba06edc0c7ea549abe4
-SIZE (simhv30-2.zip) = 1757964
+MD5 (simhv32-0.zip) = 431a1b7915e9aa9253eab83a366590bf
+SIZE (simhv32-0.zip) = 1914305
diff --git a/emulators/simh/files/patch-makefile b/emulators/simh/files/patch-makefile
index 1e61f59270b4..faa54a9b6722 100644
--- a/emulators/simh/files/patch-makefile
+++ b/emulators/simh/files/patch-makefile
@@ -1,11 +1,11 @@
---- makefile.orig Tue Oct 28 18:02:43 2003
-+++ makefile Tue Oct 28 18:03:09 2003
-@@ -5,7 +5,7 @@
- #
- ifeq ($(WIN32),)
- #Unix Environments
--CC = gcc -O2 -lm -I .
-+CC = gcc ${CFLAGS} -lm -I .
- #CC = gcc -O2 -g -lm -I .
+--- makefile.orig Wed Jun 23 18:01:06 2004
++++ makefile Wed Jun 23 18:01:50 2004
+@@ -10,7 +10,7 @@
+ else
+ OS_CCDEFS = -D_GNU_SOURCE
+ endif
+-CC = gcc -std=c99 -O2 -g -lm $(OS_CCDEFS) -I .
++CC += ${CFLAGS} -lm $(OS_CCDEFS) -I .
ifeq ($(USE_NETWORK),)
else
+ NETWORK_OPT = -DUSE_NETWORK -lpcap -isystem /usr/local/include -L /usr/local/lib
diff --git a/emulators/simh/pkg-plist b/emulators/simh/pkg-plist
deleted file mode 100644
index e4117b4eb3a1..000000000000
--- a/emulators/simh/pkg-plist
+++ /dev/null
@@ -1,25 +0,0 @@
-bin/pdp1
-bin/pdp4
-bin/pdp7
-bin/pdp8
-bin/pdp9
-bin/pdp15
-bin/pdp11
-bin/pdp10
-bin/vax
-bin/nova
-bin/eclipse
-bin/h316
-bin/hp2100
-bin/i1401
-bin/i1620
-bin/s3
-bin/altair
-bin/altairz80
-bin/gri
-bin/ibm1130
-bin/id16
-bin/id32
-bin/sds
-share/sim/ka655.bin
-@dirrm share/sim