aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2013-08-17 16:27:24 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2013-08-17 16:27:24 +0000
commit41e60477bdfd199f4fa53ac14af9a86349cff50b (patch)
treec1657d06d35b5f160b90b16620933ca757495766 /emulators
parentb60960981b1bb72f389b3e4f7f448117d4d07528 (diff)
downloadports-41e60477bdfd199f4fa53ac14af9a86349cff50b.tar.gz
ports-41e60477bdfd199f4fa53ac14af9a86349cff50b.zip
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.
Right now this is a noop in the former case and a noop in the latter case unless lang/gcc44 has been installed explicitly. This puts a bit more emphasis on standardizing on a canonical version "current" GCC and makes it easier to update that canonical version by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port. That is, USE_GCC=yes means "use a decent/modern version of GCC" without having to worry about details. Approved by: portmgr (bdrewery)
Notes
Notes: svn path=/head/; revision=324851
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dolphin-emu-devel/Makefile2
-rw-r--r--emulators/fceux/Makefile2
-rw-r--r--emulators/higan/Makefile2
-rw-r--r--emulators/mame/Makefile2
-rw-r--r--emulators/mess/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/emulators/dolphin-emu-devel/Makefile b/emulators/dolphin-emu-devel/Makefile
index d6ab2bc8639c..797a79a0c834 100644
--- a/emulators/dolphin-emu-devel/Makefile
+++ b/emulators/dolphin-emu-devel/Makefile
@@ -34,7 +34,7 @@ DOS2UNIX_REGEX= .*\.(h|c|cpp)
# XXX Has only been tested with clang and gcc
.if ${CC} != "clang" && ${CXX} != "clang++"
-USE_GCC= 4.6+
+USE_GCC= yes
.endif
USES= cmake pkgconfig iconv
diff --git a/emulators/fceux/Makefile b/emulators/fceux/Makefile
index f14880281487..11ffd069fe8b 100644
--- a/emulators/fceux/Makefile
+++ b/emulators/fceux/Makefile
@@ -110,7 +110,7 @@ CC= /usr/bin/clang
CXX= /usr/bin/clang++
CPP= /usr/bin/clang-cpp
.else
-USE_GCC= 4.6+
+USE_GCC= yes
.endif
.endif
diff --git a/emulators/higan/Makefile b/emulators/higan/Makefile
index 841ba612e659..e65e0d52d907 100644
--- a/emulators/higan/Makefile
+++ b/emulators/higan/Makefile
@@ -14,7 +14,7 @@ COMMENT= Nintendo multi-system emulator
USES= pkgconfig
USE_XZ= yes
USE_GMAKE= yes
-USE_GCC= 4.6+
+USE_GCC= yes
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 5a07b4ca7eeb..f412e1c9fcd8 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -91,7 +91,7 @@ CC= /usr/bin/clang
CPP= /usr/bin/clang-cpp
CXX= /usr/bin/clang++
.else
-USE_GCC= 4.6+
+USE_GCC= yes
.endif
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index aafd4613ad95..cce664bc9e02 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -91,7 +91,7 @@ CC= /usr/bin/clang
CPP= /usr/bin/clang-cpp
CXX= /usr/bin/clang++
.else
-USE_GCC= 4.6+
+USE_GCC= yes
.endif
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"