aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-29 16:54:35 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-29 16:54:35 +0000
commit56585684091248573cddfb0687d87728a143d691 (patch)
tree85390e0ede9952ad31127ab8d2246c67c889c9ac /emulators
parent5d27780bc12c161e3776aea0cac3f2e356a6bb37 (diff)
downloadports-56585684091248573cddfb0687d87728a143d691.tar.gz
ports-56585684091248573cddfb0687d87728a143d691.zip
- Add PROFILING_DESC (should be part of r323888)
- Unbreak the build on amd64 (and make it generally type safe) - Remove gtkmm-2.4 from LIB_DEPENDS, glademm-2.4 implies it
Notes
Notes: svn path=/head/; revision=323894
Diffstat (limited to 'emulators')
-rw-r--r--emulators/vba/Makefile4
-rw-r--r--emulators/vba/files/patch-src-System.h42
-rw-r--r--emulators/vba/files/patch-src-prof_gmon.h11
3 files changed, 54 insertions, 3 deletions
diff --git a/emulators/vba/Makefile b/emulators/vba/Makefile
index b98531627271..2ad27d3b51ef 100644
--- a/emulators/vba/Makefile
+++ b/emulators/vba/Makefile
@@ -33,6 +33,7 @@ PORTDOCS= AUTHORS NEWS README ChangeLog
OPTIONS_DEFINE= GTK2 PROFILING DOCS
OPTIONS_SUB= yes
+PROFILING_DESC= Enable profiling
GTK2_CONFIGURE_ON= --enable-gtk=2.4
PROFILING_CONFIGURE_ENABLE= profiling
@@ -40,8 +41,7 @@ PROFILING_CONFIGURE_ENABLE= profiling
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MGTK2}
-LIB_DEPENDS+= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
- glademm-2.4:${PORTSDIR}/devel/libglademm24
+LIB_DEPENDS+= glademm-2.4:${PORTSDIR}/devel/libglademm24
PROG_FILES+= ${WRKSRC}/src/gtk/gvba
GTK2_DATA_FILES= ${WRKSRC}/src/gtk/vba.glade
.endif
diff --git a/emulators/vba/files/patch-src-System.h b/emulators/vba/files/patch-src-System.h
new file mode 100644
index 000000000000..6ab8711b64fc
--- /dev/null
+++ b/emulators/vba/files/patch-src-System.h
@@ -0,0 +1,42 @@
+--- src/System.h.orig 2004-05-13 22:02:43.000000000 +0800
++++ src/System.h 2013-07-30 00:13:30.000000000 +0800
+@@ -20,30 +20,31 @@
+ #ifndef VBA_SYSTEM_H
+ #define VBA_SYSTEM_H
+
++#include <inttypes.h>
+ #include "unzip.h"
+
+ #ifndef NULL
+ #define NULL 0
+ #endif
+
+-typedef unsigned char u8;
+-typedef unsigned short u16;
+-typedef unsigned int u32;
++typedef uint8_t u8;
++typedef uint16_t u16;
++typedef uint32_t u32;
+
+ #ifdef _MSC_VER
+ typedef unsigned __int64 u64;
+ #else
+-typedef unsigned long long u64;
++typedef uint64_t u64;
+ #endif
+
+-typedef signed char s8;
+-typedef signed short s16;
+-typedef signed int s32;
++typedef int8_t s8;
++typedef int16_t s16;
++typedef int32_t s32;
+
+ #ifdef _MSC_VER
+ typedef signed __int64 s64;
+ #else
+-typedef signed long long s64;
++typedef int64_t s64;
+ #endif
+
+ struct EmulatedSystem {
diff --git a/emulators/vba/files/patch-src-prof_gmon.h b/emulators/vba/files/patch-src-prof_gmon.h
index b44f14a1fe4e..fb193f9307b1 100644
--- a/emulators/vba/files/patch-src-prof_gmon.h
+++ b/emulators/vba/files/patch-src-prof_gmon.h
@@ -1,6 +1,15 @@
--- src/prof/gmon.h.orig 2007-10-04 01:06:18.000000000 +0200
+++ src/prof/gmon.h 2007-10-04 01:06:48.000000000 +0200
-@@ -119,7 +119,7 @@
+@@ -29,6 +29,8 @@
+ #ifndef gmon_h
+ #define gmon_h
+
++#include <inttypes.h>
++
+ /* Size of the 4.4BSD gmon header */
+ #define GMON_HDRSIZE_BSD44_32 (4 + 4 + 4 + 4 + 4 + (3 * 4))
+ #define GMON_HDRSIZE_BSD44_64 (8 + 8 + 4 + 4 + 4 + (3 * 4))
+@@ -119,7 +121,7 @@
struct tostruct
{