aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2013-08-12 06:20:27 +0000
committerDavid Naylor <dbn@FreeBSD.org>2013-08-12 06:20:27 +0000
commit826b080b4097c132b2c105be952daa1be8831525 (patch)
tree6f8e388ea691dcb222b7bfb9687dc7b15457fce3 /emulators
parent162c633191e3e0b64791636dec0d2c7c06b1cc5e (diff)
downloadports-826b080b4097c132b2c105be952daa1be8831525.tar.gz
ports-826b080b4097c132b2c105be952daa1be8831525.zip
Add back i386-wine/Makefile (wouldn't commit otherwise).
Subversion and pre-commit hooks are not cooperating in the changes required for i386-wine(-devel). For the historians: This file is a copy of i386-wine-devel/Makefile as at version 321106.
Notes
Notes: svn path=/head/; revision=324614
Diffstat (limited to 'emulators')
-rw-r--r--emulators/i386-wine/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/emulators/i386-wine/Makefile b/emulators/i386-wine/Makefile
new file mode 100644
index 000000000000..3e65cfa1622b
--- /dev/null
+++ b/emulators/i386-wine/Makefile
@@ -0,0 +1,16 @@
+# Created by: David Naylor (dbn@FreeBSD.org)
+# $FreeBSD$
+
+# Special bootstrapper to allow:
+# - i386 specific port to be slave to ${PORTSDIR}/emulators/wine
+# - amd64 specific port to be normal port (based on binary package)
+
+.if !defined(ARCH)
+ARCH!= uname -p
+.endif
+
+.if ${ARCH} == i386
+.include "${.CURDIR}/Makefile.i386"
+.else
+.include "${.CURDIR}/Makefile.inc"
+.endif