aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-12-19 18:49:21 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-12-19 18:49:21 +0000
commit5f44340e12fbc3f6f7e2e98bcae9a5af8d9afce6 (patch)
tree96db4787b9e678bc3a58724b19bf73ed15835c69 /emulators
parentf1ad17fac9ee6afc70230112aac4a01f979f39b4 (diff)
downloadports-5f44340e12fbc3f6f7e2e98bcae9a5af8d9afce6.tar.gz
ports-5f44340e12fbc3f6f7e2e98bcae9a5af8d9afce6.zip
+ Our AMD64 Linux compat is 32-bit i386 emulation, so adjust accordingly.
+ We don't have Sparc64 Linux emulation, so don't try here.
Notes
Notes: svn path=/head/; revision=124507
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-gentoo-stage1/Makefile26
-rw-r--r--emulators/linux_base-gentoo-stage1/distinfo.amd643
-rw-r--r--emulators/linux_base-gentoo-stage1/distinfo.sparc643
-rw-r--r--emulators/linux_dist-gentoo-stage1/Makefile26
-rw-r--r--emulators/linux_dist-gentoo-stage1/distinfo.amd643
-rw-r--r--emulators/linux_dist-gentoo-stage1/distinfo.sparc643
6 files changed, 22 insertions, 42 deletions
diff --git a/emulators/linux_base-gentoo-stage1/Makefile b/emulators/linux_base-gentoo-stage1/Makefile
index 333fe07aad87..dc4fe1019039 100644
--- a/emulators/linux_base-gentoo-stage1/Makefile
+++ b/emulators/linux_base-gentoo-stage1/Makefile
@@ -19,30 +19,26 @@ RESTRICTED= "binaries licensed under GNU GPL without accompanying source"
EXPIRATION_DATE=2005-02-18
DEPRECATED= ${BROKEN}
-ONLY_FOR_ARCHS= alpha amd64 ia64 i386 sparc64
+ONLY_FOR_ARCHS= alpha amd64 ia64 i386
USE_BZIP2= y
.include <bsd.port.pre.mk>
-PORTARCH=${MACHINE_ARCH:S/64//}
-.if (${PORTARCH} == "alpha")
+.if (${ARCH} == "amd64")
+LATEST_LINK= ${PORTNAME:C/linux_base/linux32_base/}
+MACHINE_ARCH= i386
+.endif
+
+.if (${MACHINE_ARCH} == "alpha")
MASTER_SITE_SUBDIR= experimental/alpha/stages
DISTNAME= stage1-alpha-20030721
-.elif (${PORTARCH} == "amd")
-BROKEN= "Linux emulation is not available on x86-64"
-IGNORE= ${BROKEN}
-MASTER_SITE_SUBDIR= experimental/amd64/stages
-DISTNAME= stage1-amd64-20040124
-.elif (${PORTARCH} == "ia")
-MASTER_SITE_SUBDIR= experimental/ia64
-DISTNAME= stage1-ia64-20030912
-.elif (${PORTARCH} == "i386")
+.elif (${MACHINE_ARCH} == "i386")
+MASTER_SITE_SUBDIR= releases/x86/${PORTVERSION}/stages/x86
+DISTNAME= stage1-x86-20030910
+.elif (${MACHINE_ARCH} == "ia64")
MASTER_SITE_SUBDIR= releases/x86/${PORTVERSION}/stages/x86
DISTNAME= stage1-x86-20030910
-.elif (${PORTARCH} == "sparc")
-MASTER_SITE_SUBDIR= experimental/sparc/stages/sparc64
-DISTNAME= stage1-sparc64-20031011
.endif
DIST_SUBDIR= gentoo-linux
diff --git a/emulators/linux_base-gentoo-stage1/distinfo.amd64 b/emulators/linux_base-gentoo-stage1/distinfo.amd64
deleted file mode 100644
index 480aea71edb6..000000000000
--- a/emulators/linux_base-gentoo-stage1/distinfo.amd64
+++ /dev/null
@@ -1,3 +0,0 @@
-$FreeBSD$
-MD5 (gentoo-linux/stage1-amd64-20040124.tar.bz2) = 3aef5b340629b49e360c5a362568ef92
-SIZE (gentoo-linux/gentoo-linux/stage1-amd64-20040124.tar.bz2) = 10896348
diff --git a/emulators/linux_base-gentoo-stage1/distinfo.sparc64 b/emulators/linux_base-gentoo-stage1/distinfo.sparc64
deleted file mode 100644
index b99b235572fa..000000000000
--- a/emulators/linux_base-gentoo-stage1/distinfo.sparc64
+++ /dev/null
@@ -1,3 +0,0 @@
-$FreeBSD$
-MD5 (gentoo-linux/stage1-sparc64-20031011.tar.bz2) = d6fbba1df90890ba4295a95e2cda3db4
-SIZE (gentoo-linux/stage1-sparc64-20031011.tar.bz2) = 19136385
diff --git a/emulators/linux_dist-gentoo-stage1/Makefile b/emulators/linux_dist-gentoo-stage1/Makefile
index 333fe07aad87..dc4fe1019039 100644
--- a/emulators/linux_dist-gentoo-stage1/Makefile
+++ b/emulators/linux_dist-gentoo-stage1/Makefile
@@ -19,30 +19,26 @@ RESTRICTED= "binaries licensed under GNU GPL without accompanying source"
EXPIRATION_DATE=2005-02-18
DEPRECATED= ${BROKEN}
-ONLY_FOR_ARCHS= alpha amd64 ia64 i386 sparc64
+ONLY_FOR_ARCHS= alpha amd64 ia64 i386
USE_BZIP2= y
.include <bsd.port.pre.mk>
-PORTARCH=${MACHINE_ARCH:S/64//}
-.if (${PORTARCH} == "alpha")
+.if (${ARCH} == "amd64")
+LATEST_LINK= ${PORTNAME:C/linux_base/linux32_base/}
+MACHINE_ARCH= i386
+.endif
+
+.if (${MACHINE_ARCH} == "alpha")
MASTER_SITE_SUBDIR= experimental/alpha/stages
DISTNAME= stage1-alpha-20030721
-.elif (${PORTARCH} == "amd")
-BROKEN= "Linux emulation is not available on x86-64"
-IGNORE= ${BROKEN}
-MASTER_SITE_SUBDIR= experimental/amd64/stages
-DISTNAME= stage1-amd64-20040124
-.elif (${PORTARCH} == "ia")
-MASTER_SITE_SUBDIR= experimental/ia64
-DISTNAME= stage1-ia64-20030912
-.elif (${PORTARCH} == "i386")
+.elif (${MACHINE_ARCH} == "i386")
+MASTER_SITE_SUBDIR= releases/x86/${PORTVERSION}/stages/x86
+DISTNAME= stage1-x86-20030910
+.elif (${MACHINE_ARCH} == "ia64")
MASTER_SITE_SUBDIR= releases/x86/${PORTVERSION}/stages/x86
DISTNAME= stage1-x86-20030910
-.elif (${PORTARCH} == "sparc")
-MASTER_SITE_SUBDIR= experimental/sparc/stages/sparc64
-DISTNAME= stage1-sparc64-20031011
.endif
DIST_SUBDIR= gentoo-linux
diff --git a/emulators/linux_dist-gentoo-stage1/distinfo.amd64 b/emulators/linux_dist-gentoo-stage1/distinfo.amd64
deleted file mode 100644
index 480aea71edb6..000000000000
--- a/emulators/linux_dist-gentoo-stage1/distinfo.amd64
+++ /dev/null
@@ -1,3 +0,0 @@
-$FreeBSD$
-MD5 (gentoo-linux/stage1-amd64-20040124.tar.bz2) = 3aef5b340629b49e360c5a362568ef92
-SIZE (gentoo-linux/gentoo-linux/stage1-amd64-20040124.tar.bz2) = 10896348
diff --git a/emulators/linux_dist-gentoo-stage1/distinfo.sparc64 b/emulators/linux_dist-gentoo-stage1/distinfo.sparc64
deleted file mode 100644
index b99b235572fa..000000000000
--- a/emulators/linux_dist-gentoo-stage1/distinfo.sparc64
+++ /dev/null
@@ -1,3 +0,0 @@
-$FreeBSD$
-MD5 (gentoo-linux/stage1-sparc64-20031011.tar.bz2) = d6fbba1df90890ba4295a95e2cda3db4
-SIZE (gentoo-linux/stage1-sparc64-20031011.tar.bz2) = 19136385