aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-12-28 06:09:02 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-12-28 06:09:02 +0000
commit65446a732ca8d086fe2532c5d348cf295ccf452c (patch)
tree7d1cb3950192aa32a3f4922a7eddf5b8ae8a11e1 /emulators
parent8fb0841852de5edcdb4f264dc76d7bf4bdbe1569 (diff)
downloadports-65446a732ca8d086fe2532c5d348cf295ccf452c.tar.gz
ports-65446a732ca8d086fe2532c5d348cf295ccf452c.zip
Quiet installation errors due to lack of /dev/null w/in LINUXBASE.
Notes
Notes: svn path=/head/; revision=125323
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/emulators/linux_base/Makefile b/emulators/linux_base/Makefile
index ff6484ab155d..b8d6f9267c7e 100644
--- a/emulators/linux_base/Makefile
+++ b/emulators/linux_base/Makefile
@@ -137,6 +137,12 @@ pre-install:
.endif
do-install:
+# Make sure we have a /dev/null in the chrooted environment.
+ @${MKDIR} ${LINUXBASE}/dev
+ @${RM} -f ${LINUXBASE}/dev/null
+ @mknod ${LINUXBASE}/dev/null c 2 2
+ @${CHMOD} 666 ${LINUXBASE}/dev/null
+#
@${MKDIR} ${LINUXBASE}/${DBPATH}
@${MKDIR} ${LINUXBASE}/var/tmp ${LINUXBASE}/lib
@cd ${LINUXBASE}/lib && ${LN} -sf libtermcap.so.2.0.8 libtermcap.so.2