aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 19:55:44 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 19:55:44 +0000
commit7ac002aef0cc5bd8e1e2b0d597a4a76ea902202b (patch)
tree70e7dd67334ad11c35a420a43a66c5fd2cbe7d27 /emulators
parent78ae62f1d4661fc7930a4b4cfa0e1eb0132a59b0 (diff)
downloadports-7ac002aef0cc5bd8e1e2b0d597a4a76ea902202b.tar.gz
ports-7ac002aef0cc5bd8e1e2b0d597a4a76ea902202b.zip
- Convert to USES=libtool
- Add missing dependency on libfreetype and USE_XORG xxf86vm - Remove remnants of broken SDL support - Replace patch with post-patch command
Notes
Notes: svn path=/head/; revision=366263
Diffstat (limited to 'emulators')
-rw-r--r--emulators/xsystem35/Makefile36
-rw-r--r--emulators/xsystem35/files/patch-configure.in10
-rw-r--r--emulators/xsystem35/pkg-plist48
3 files changed, 13 insertions, 81 deletions
diff --git a/emulators/xsystem35/Makefile b/emulators/xsystem35/Makefile
index 85bb19223646..1fa1c71ae19f 100644
--- a/emulators/xsystem35/Makefile
+++ b/emulators/xsystem35/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xsystem35
PORTVERSION= 1.7.2
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= emulators
MASTER_SITES= http://8ne.sakura.ne.jp:20008/chika/unitbase/xsys35/down/
@@ -13,20 +13,24 @@ COMMENT= AliceSoft System 3.5/3.6/3.8/3.9 on X Window System
LICENSE= GPLv2 # (or later)
LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
libjpeg.so:${PORTSDIR}/graphics/jpeg
OPTIONS_DEFINE= ESOUND DOCS EXAMPLES
-USES= gettext gmake
+USES= gettext gmake libtool
+USE_AUTOTOOLS= autoconf:env
USE_GNOME= gtk12
-USE_AUTOTOOLS= autoconf libtool
+USE_XORG= xxf86vm
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-gettext \
--with-cachesize=20 \
+ --disable-static \
--enable-midi=seq,extp,raw \
--enable-cdrom=bsd,mp3
-
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
+MAKE_JOBS_UNSAFE= yes
SUB_FILES= pkg-message
@@ -41,31 +45,17 @@ CONFIGURE_ARGS+= --enable-audio=oss,esd --with-default-output=esd
CONFIGURE_ARGS+= --enable-audio=oss --with-default-output=oss
.endif
-#.if ${PORT_OPTIONS:MSDL}
-#USE_SDL= sdl
-#CONFIGURE_ARGS+= --enable-sdl
-#CPPFLAGS+= $$(${SDL_CONFIG} --cflags)
-#LDFLAGS+= $$(${SDL_CONFIG} --libs)
-#.else
-CONFIGURE_ARGS+= --disable-sdl
-#.endif
-
-.if ${MACHINE_CPU:Mmmx} && !defined(PACKAGE_BUILDING)
+.if defined(MACHINE_CPU) && ${MACHINE_CPU:Mmmx}
CONFIGURE_ARGS+= --enable-mmx
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.else
CONFIGURE_ARGS+= --disable-mmx
.endif
-post-extract:
- @${CP} ${WRKSRC}/INSTALL ${WRKSRC}/doc/INSTALL
-
post-patch:
- ${FIND} ${WRKSRC}/src -type f |\
- ${XARGS} ${GREP} -l '<SDL/SDL' /dev/null |\
- ${XARGS} ${REINPLACE_CMD} -e 's,<SDL/,<,'
- @${REINPLACE_CMD} -e \
- 's|__COUNTER__|__COUNTER_H__|' ${WRKSRC}/src/counter.h
+ @${CP} ${WRKSRC}/INSTALL ${WRKSRC}/doc/INSTALL
+ @${REINPLACE_CMD} '/-lxpg4/d' ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's|__COUNTER__|__COUNTER_H__|' ${WRKSRC}/src/counter.h
pre-configure:
(cd ${WRKSRC}/libltdl; ${AUTOCONF})
diff --git a/emulators/xsystem35/files/patch-configure.in b/emulators/xsystem35/files/patch-configure.in
deleted file mode 100644
index 98350fe3a160..000000000000
--- a/emulators/xsystem35/files/patch-configure.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.ac.orig Sun Dec 21 16:18:05 2003
-+++ configure.ac Mon Nov 15 10:22:54 2004
-@@ -463,7 +463,6 @@
- *-*-linux*)
- ;;
- *-*-freebsd*)
-- EXTRALIBS="$EXTRALIBS -lxpg4"
- ;;
- *-irix*)
- chk_rgb=yes
diff --git a/emulators/xsystem35/pkg-plist b/emulators/xsystem35/pkg-plist
index bd98ccb19a7f..29fcb199480e 100644
--- a/emulators/xsystem35/pkg-plist
+++ b/emulators/xsystem35/pkg-plist
@@ -1,76 +1,28 @@
bin/instgame
bin/xsystem35
-lib/xsystem35/AliceLogo.a
-lib/xsystem35/AliceLogo.la
lib/xsystem35/AliceLogo.so
-lib/xsystem35/Confirm.a
-lib/xsystem35/Confirm.la
lib/xsystem35/Confirm.so
-lib/xsystem35/Gpx.a
-lib/xsystem35/Gpx.la
lib/xsystem35/Gpx.so
-lib/xsystem35/MSGSKIP.a
-lib/xsystem35/MSGSKIP.la
lib/xsystem35/MSGSKIP.so
-lib/xsystem35/Math.a
-lib/xsystem35/Math.la
lib/xsystem35/Math.so
-lib/xsystem35/MsgSkip.a
-lib/xsystem35/MsgSkip.la
lib/xsystem35/MsgSkip.so
-lib/xsystem35/NIGHTDLL.a
-lib/xsystem35/NIGHTDLL.la
lib/xsystem35/NIGHTDLL.so
-lib/xsystem35/NightDemonDemo.a
-lib/xsystem35/NightDemonDemo.la
lib/xsystem35/NightDemonDemo.so
-lib/xsystem35/RandMT.a
-lib/xsystem35/RandMT.la
lib/xsystem35/RandMT.so
-lib/xsystem35/SACT.a
-lib/xsystem35/SACT.la
lib/xsystem35/SACT.so
-lib/xsystem35/ShArray.a
-lib/xsystem35/ShArray.la
lib/xsystem35/ShArray.so
-lib/xsystem35/ShCalc.a
-lib/xsystem35/ShCalc.la
lib/xsystem35/ShCalc.so
-lib/xsystem35/ShGraph.a
-lib/xsystem35/ShGraph.la
lib/xsystem35/ShGraph.so
-lib/xsystem35/ShPort.a
-lib/xsystem35/ShPort.la
lib/xsystem35/ShPort.so
-lib/xsystem35/ShSound.a
-lib/xsystem35/ShSound.la
lib/xsystem35/ShSound.so
-lib/xsystem35/ShString.a
-lib/xsystem35/ShString.la
lib/xsystem35/ShString.so
-lib/xsystem35/dDemo.a
-lib/xsystem35/dDemo.la
lib/xsystem35/dDemo.so
-lib/xsystem35/eDemo.a
-lib/xsystem35/eDemo.la
lib/xsystem35/eDemo.so
-lib/xsystem35/eeDemo.a
-lib/xsystem35/eeDemo.la
lib/xsystem35/eeDemo.so
-lib/xsystem35/nDEMO.a
-lib/xsystem35/nDEMO.la
lib/xsystem35/nDEMO.so
-lib/xsystem35/nDEMOE.a
-lib/xsystem35/nDEMOE.la
lib/xsystem35/nDEMOE.so
-lib/xsystem35/oDEMO.a
-lib/xsystem35/oDEMO.la
lib/xsystem35/oDEMO.so
-lib/xsystem35/oujimisc.a
-lib/xsystem35/oujimisc.la
lib/xsystem35/oujimisc.so
-lib/xsystem35/tDemo.a
-lib/xsystem35/tDemo.la
lib/xsystem35/tDemo.so
%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog