aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2014-08-29 19:20:58 +0000
committerJuergen Lock <nox@FreeBSD.org>2014-08-29 19:20:58 +0000
commit83097b938834d534ef24111ae0839f2140c5ac58 (patch)
tree6bf18ff8204c57dac3fbe444452900570ae016c6 /emulators
parentaa80ecdafcc2026c87ba35089625813145a86108 (diff)
downloadports-83097b938834d534ef24111ae0839f2140c5ac58.tar.gz
ports-83097b938834d534ef24111ae0839f2140c5ac58.zip
- bsd-user: Increase MAX_ARG_PAGES to 64.
Notes
Notes: svn path=/head/; revision=366553
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile3
-rw-r--r--emulators/qemu-devel/files/extra-patch-max-arg-pages28
2 files changed, 30 insertions, 1 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 8f58491ab925..d9d89bce2404 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qemu
PORTVERSION= 2.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://wiki.qemu.org/download/:release \
LOCAL/nox:snapshot
@@ -78,6 +78,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bsd-user-trapsig
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-21927cffcc7bcacbb953155f778200846df9f60e
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-bsd-user-freebsd-os-sys.c
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-sysctl-hw-physmem
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-max-arg-pages
.endif
CONFIGURE_ARGS+= --extra-ldflags=-L${LOCALBASE}/lib
diff --git a/emulators/qemu-devel/files/extra-patch-max-arg-pages b/emulators/qemu-devel/files/extra-patch-max-arg-pages
new file mode 100644
index 000000000000..ca447f0d6090
--- /dev/null
+++ b/emulators/qemu-devel/files/extra-patch-max-arg-pages
@@ -0,0 +1,28 @@
+From 200e09e4bf497b43cace6b2b2b85b943f5d59dc1 Mon Sep 17 00:00:00 2001
+From: Sean Bruno <sbruno@freebsd.org>
+Date: Fri, 29 Aug 2014 14:56:00 +0000
+Subject: [PATCH] Increase MAX_ARG_PAGES to 64 (256k total arg).
+
+I've found that building packages, like binutils, exceeded 128k easily
+---
+ bsd-user/qemu.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/bsd-user/qemu.h b/bsd-user/qemu.h
+index 09af1b4..0731c64 100644
+--- a/bsd-user/qemu.h
++++ b/bsd-user/qemu.h
+@@ -121,10 +121,10 @@ extern unsigned long mmap_min_addr;
+ /* ??? See if we can avoid exposing so much of the loader internals. */
+ /*
+ * MAX_ARG_PAGES defines the number of pages allocated for arguments
+- * and envelope for the new program. 32 should suffice, this gives
+- * a maximum env+arg of 128kB w/4KB pages!
++ * and envelope for the new program. 64 should suffice, this gives
++ * a maximum env+arg of 256kB w/4KB pages!
+ */
+-#define MAX_ARG_PAGES 32
++#define MAX_ARG_PAGES 64
+
+ /*
+ * This structure is used to hold the arguments that are