aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2014-09-18 09:06:59 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2014-09-18 09:06:59 +0000
commitbead6e2747e1bb86e499e37861aa892b3b3668ce (patch)
tree96d9089d51ca8600e1005f4394c70bb3c2475e9a /emulators
parent83fa084228fd4e452b14fe44c612eaf512c3d73c (diff)
downloadports-bead6e2747e1bb86e499e37861aa892b3b3668ce.tar.gz
ports-bead6e2747e1bb86e499e37861aa892b3b3668ce.zip
- Add CPE information to virtualbox ports
Notes
Notes: svn path=/head/; revision=368433
Diffstat (limited to 'emulators')
-rw-r--r--emulators/virtualbox-ose-additions/Makefile5
-rw-r--r--emulators/virtualbox-ose-kmod/Makefile5
-rw-r--r--emulators/virtualbox-ose/Makefile5
3 files changed, 12 insertions, 3 deletions
diff --git a/emulators/virtualbox-ose-additions/Makefile b/emulators/virtualbox-ose-additions/Makefile
index 2c9f2df8b8a0..5eef26e3005c 100644
--- a/emulators/virtualbox-ose-additions/Makefile
+++ b/emulators/virtualbox-ose-additions/Makefile
@@ -19,11 +19,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
kmk:${PORTSDIR}/devel/kBuild
+CPE_VENDOR= oracle
+CPE_PRODUCT= vm_virtualbox
+
UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
PATCHDIR= ${.CURDIR}/../${PORTNAME}/files
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
USE_RC_SUBR= vboxguest vboxservice
-USES= compiler:features iconv kmod tar:bzip2
+USES= compiler:features cpe iconv kmod tar:bzip2
ONLY_FOR_ARCHS= i386 amd64
USE_PYTHON_BUILD= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/emulators/virtualbox-ose-kmod/Makefile b/emulators/virtualbox-ose-kmod/Makefile
index b74bff489153..9c215ac22c97 100644
--- a/emulators/virtualbox-ose-kmod/Makefile
+++ b/emulators/virtualbox-ose-kmod/Makefile
@@ -18,7 +18,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= kmk:${PORTSDIR}/devel/kBuild
-USES= kmod tar:bzip2
+CPE_VENDOR= oracle
+CPE_PRODUCT= vm_virtualbox
+
+USES= cpe kmod tar:bzip2
UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
PATCHDIR= ${.CURDIR}/../${PORTNAME}/files
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index b6c2a9428d74..0da912babba0 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -28,9 +28,12 @@ LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
RUN_DEPENDS= ${LOCALBASE}/etc/rc.d/vboxnet:${PORTSDIR}/emulators/virtualbox-ose-kmod \
cdrecord:${PORTSDIR}/sysutils/cdrtools
+CPE_VENDOR= oracle
+CPE_PRODUCT= vm_virtualbox
+
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
ONLY_FOR_ARCHS= i386 amd64
-USES= compiler iconv pkgconfig tar:bzip2
+USES= compiler cpe iconv pkgconfig tar:bzip2
USE_GNOME= libidl
USE_PYTHON_BUILD= yes