aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2013-10-04 17:19:41 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2013-10-04 17:19:41 +0000
commit37db92665387c7b0cea7be0b1ca682fa389ab1e2 (patch)
tree4bfa4bba78a24fa9817c98705662ca885ce8bb07 /emulators
parent32e23fd557590dc701727b6cd7502f7ada719f9f (diff)
downloadports-37db92665387c7b0cea7be0b1ca682fa389ab1e2.tar.gz
ports-37db92665387c7b0cea7be0b1ca682fa389ab1e2.zip
- Add new port: emulators/mupen64plus-video-glide64mk2
Notes
Notes: svn path=/head/; revision=329345
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64plus-video-glide64mk2/Makefile22
-rw-r--r--emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile41
-rw-r--r--emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-src-Glide64_Util.h13
-rw-r--r--emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-src-GlideHQ_TxDbg.cpp25
5 files changed, 102 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 1a3921009255..e2cdfbb29da8 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -114,6 +114,7 @@
SUBDIR += mupen64plus-ui-console
SUBDIR += mupen64plus-video-arachnoid
SUBDIR += mupen64plus-video-glide64
+ SUBDIR += mupen64plus-video-glide64mk64
SUBDIR += mupen64plus-video-rice
SUBDIR += mupen64plus-video-z64
SUBDIR += nonpareil
diff --git a/emulators/mupen64plus-video-glide64mk2/Makefile b/emulators/mupen64plus-video-glide64mk2/Makefile
new file mode 100644
index 000000000000..7abe0b9c2067
--- /dev/null
+++ b/emulators/mupen64plus-video-glide64mk2/Makefile
@@ -0,0 +1,22 @@
+# Created by: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+# $FreeBSD$
+
+PKGNAMESUFFIX= -video-glide64mk2
+
+COMMENT= Glide64mk2 video plugin for Mupen64Plus
+
+LIB_DEPENDS= mupen64plus.2:${PORTSDIR}/emulators/mupen64plus-core
+
+USE_GL= gl
+USE_SDL= yes
+
+MASTERDIR= ${.CURDIR}/../mupen64plus-core
+
+OPTIONS_DEFINE= #
+
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/${PORTNAME}
+LDFLAGS+= -L${LOCALBASE}/lib
+
+NO_STAGE= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile b/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile
new file mode 100644
index 000000000000..b0022b62df36
--- /dev/null
+++ b/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-projects-unix_Makefile
@@ -0,0 +1,41 @@
+--- source/mupen64plus-video-glide64mk2/projects/unix/Makefile 2013-07-03 19:28:17.000000000 -0500
++++ source/mupen64plus-video-glide64mk2/projects/unix/Makefile 2013-10-04 04:17:19.000000000 -0500
+@@ -125,7 +125,7 @@
+ OPTFLAGS ?= -O3 -flto
+ WARNFLAGS ?= -Wall
+ CFLAGS += $(OPTFLAGS) $(WARNFLAGS) -ffast-math -fno-strict-aliasing -fvisibility=hidden -I../../src -I../../src/Glitch64/inc -DGCC
+-CXXFLAGS += -fvisibility-inlines-hidden -std=gnu++0x
++CXXFLAGS += -fvisibility-inlines-hidden
+ LDFLAGS += $(SHARED)
+ BOOST_SUFFIX ?=
+
+@@ -186,6 +186,7 @@
+ endif
+ ifeq ($(OS), FREEBSD)
+ LDLIBS += -lc
++ CPPFLAGS += -DNO_FILTER_THREAD
+ endif
+
+ ifeq ($(origin PKG_CONFIG), undefined)
+@@ -199,6 +200,10 @@
+ ZLIB_LDLIBS += -lz
+ endif
+
++ifeq ($(OS), FREEBSD) # use system zlib on FreeBSD
++ ZLIB_LDLIBS += -lz
++endif
++
+ ifeq ($(origin ZLIB_CFLAGS) $(origin ZLIB_LDLIBS), undefined undefined)
+ ifeq ($(shell $(PKG_CONFIG) --modversion zlib 2>/dev/null),)
+ $(error No zlib development libraries found!)
+@@ -292,8 +297,8 @@
+ endif
+
+ # set base program pointers and flags
+-CC = $(CROSS_COMPILE)gcc
+-CXX = $(CROSS_COMPILE)g++
++CC ?= $(CROSS_COMPILE)gcc
++CXX ?= $(CROSS_COMPILE)g++
+ RM ?= rm -f
+ INSTALL ?= install
+ MKDIR ?= mkdir -p
diff --git a/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-src-Glide64_Util.h b/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-src-Glide64_Util.h
new file mode 100644
index 000000000000..b66eb60085b8
--- /dev/null
+++ b/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-src-Glide64_Util.h
@@ -0,0 +1,13 @@
+--- source/mupen64plus-video-glide64mk2/src/Glide64/Util.h 2013-10-04 04:04:30.000000000 -0500
++++ source/mupen64plus-video-glide64mk2/src/Glide64/Util.h 2013-10-04 04:04:41.000000000 -0500
+@@ -90,9 +90,7 @@
+ lx = lc; \
+ }
+
+-#if defined(__GNUC__)
+- #define bswap32(x) __builtin_bswap32(x)
+-#elif defined(_MSC_VER) && (defined(_M_IX86) || defined(_M_X64))
++#if defined(_MSC_VER) && (defined(_M_IX86) || defined(_M_X64))
+ #include <stdlib.h>
+ #define bswap32(x) _byteswap_ulong(x)
+ #else
diff --git a/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-src-GlideHQ_TxDbg.cpp b/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-src-GlideHQ_TxDbg.cpp
new file mode 100644
index 000000000000..37344ef05b77
--- /dev/null
+++ b/emulators/mupen64plus-video-glide64mk2/files/patch-source-mupen64plus-video-glide64mk2-src-GlideHQ_TxDbg.cpp
@@ -0,0 +1,25 @@
+--- source/mupen64plus-video-glide64mk2/src/GlideHQ/TxDbg.cpp 2013-10-04 03:11:58.000000000 -0500
++++ source/mupen64plus-video-glide64mk2/src/GlideHQ/TxDbg.cpp 2013-10-04 03:16:46.000000000 -0500
+@@ -53,7 +53,7 @@
+ void
+ TxDbg::output(const int level, const wchar_t *format, ...)
+ {
+-#ifdef _GLIBCXX_HAVE_BROKEN_VSWPRINTF
++#if defined _GLIBCXX_HAVE_BROKEN_VSWPRINTF || defined (__FreeBSD__)
+ wchar_t newformat[4095];
+ #else
+ std::wstring newformat;
+@@ -65,8 +65,12 @@
+ return;
+
+ va_start(args, format);
+-#ifdef _GLIBCXX_HAVE_BROKEN_VSWPRINTF
++#if defined _GLIBCXX_HAVE_BROKEN_VSWPRINTF || defined (__FreeBSD__)
++#if defined(__FreeBSD__)
++ swprintf(newformat, sizeof(newformat)/sizeof(*newformat), L"%d:\t", level);
++#else
+ swprintf(newformat, L"%d:\t", level);
++#endif
+ wcscat(newformat, format);
+ vfwprintf(_dbgfile, newformat, args);
+ #else