aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2013-10-05 02:02:34 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2013-10-05 02:02:34 +0000
commitbf8a6433505073a09976328f2c75502dd7b5f742 (patch)
treee10152acdf7cd3ddf7862d0f4c66873684be5e31 /emulators
parent80097c60027e2880e8d58512b0a3d12fb46013b0 (diff)
downloadports-bf8a6433505073a09976328f2c75502dd7b5f742.tar.gz
ports-bf8a6433505073a09976328f2c75502dd7b5f742.zip
- Update to 0.3
Notes
Notes: svn path=/head/; revision=329405
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wxmupen64plus/Makefile21
-rw-r--r--emulators/wxmupen64plus/distinfo4
-rw-r--r--emulators/wxmupen64plus/files/patch-wscript66
-rw-r--r--emulators/wxmupen64plus/files/patch-wxvidext.cpp11
-rw-r--r--emulators/wxmupen64plus/files/patch-wxvidext.h11
-rw-r--r--emulators/wxmupen64plus/pkg-descr2
6 files changed, 79 insertions, 36 deletions
diff --git a/emulators/wxmupen64plus/Makefile b/emulators/wxmupen64plus/Makefile
index 4b325da6099a..83a9c941397a 100644
--- a/emulators/wxmupen64plus/Makefile
+++ b/emulators/wxmupen64plus/Makefile
@@ -2,16 +2,17 @@
# $FreeBSD$
PORTNAME= wxmupen64plus
-PORTVERSION= 0.2
-PORTREVISION= 2
+PORTVERSION= 0.3
CATEGORIES= emulators
-MASTER_SITES= http://cdn.bitbucket.org/auria/wxmupen64plus/downloads/
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+ ${MASTER_SITE_LOCAL:S,$,acm/${PORTNAME}/,} \
+ http://cdn.bitbucket.org/auria/wxmupen64plus/downloads/
DIST_SUBDIR= ${PORTNAME:S/wx//}
MAINTAINER= acm@FreeBSD.org
COMMENT= A Mupen64Plus 2.0 GUI frontend written using wxWidgets
-LIB_DEPENDS= mupen64plus.2:${PORTSDIR}/emulators/mupen64plus-core
+LIB_DEPENDS= mupen64plus:${PORTSDIR}/emulators/mupen64plus-core
RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:${PORTSDIR}/emulators/mupen64plus-core \
${LOCALBASE}/lib/mupen64plus/mupen64plus-audio-sdl.so:${PORTSDIR}/emulators/mupen64plus-audio-sdl \
${LOCALBASE}/lib/mupen64plus/mupen64plus-input-sdl.so:${PORTSDIR}/emulators/mupen64plus-input-sdl \
@@ -19,18 +20,24 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:${PORTSDIR}/emulators/mupen64p
${LOCALBASE}/lib/mupen64plus/mupen64plus-video-rice.so:${PORTSDIR}/emulators/mupen64plus-video-rice \
mupen64plus:${PORTSDIR}/emulators/mupen64plus-ui-console
-USE_ZIP= yes
+PROJECTHOST= bsdistfiles
USE_SDL= yes
USE_WX= 2.9
WX_UNICODE= yes
USE_PYTHON= yes
-
WAF_SCRIPT= waf
NO_STAGE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g' -e 's|%%CXX%%|${CXX}|g' ${WRKSRC}/wscript
+
do-configure:
@cd ${WRKSRC} && \
- ${PYTHON_CMD} ${WAF_SCRIPT} configure --mupenapi=${LOCALBASE}/include/${PORTNAME:S/wx//} \
+ ${SETENV} CC="${CC}" CPP="${CPP}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" ${PYTHON_CMD} ${WAF_SCRIPT} \
+ configure --mupenapi=${LOCALBASE}/include/${PORTNAME:S/wx//} \
--wxconfig=${WX_CONFIG} \
--sdlconfig=${SDL_CONFIG} \
--datadir=${DATADIR} \
diff --git a/emulators/wxmupen64plus/distinfo b/emulators/wxmupen64plus/distinfo
index 5afedad48b16..322b7e72951f 100644
--- a/emulators/wxmupen64plus/distinfo
+++ b/emulators/wxmupen64plus/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mupen64plus/wxmupen64plus-0.2.zip) = c6cc2a3d63a3d8d81d2d4635efd1f180aac9442dec2abd3943fc5eee6ef3f4c4
-SIZE (mupen64plus/wxmupen64plus-0.2.zip) = 310793
+SHA256 (mupen64plus/wxmupen64plus-0.3.tar.gz) = 123d4edb9652f8effac239a317d58084a48dec85e0a746d19865509298837a12
+SIZE (mupen64plus/wxmupen64plus-0.3.tar.gz) = 280316
diff --git a/emulators/wxmupen64plus/files/patch-wscript b/emulators/wxmupen64plus/files/patch-wscript
index ace8f57cb4c5..9bb0a4a2d6ce 100644
--- a/emulators/wxmupen64plus/files/patch-wscript
+++ b/emulators/wxmupen64plus/files/patch-wscript
@@ -1,27 +1,41 @@
---- wscript 2011-10-17 09:27:26.000000000 -0500
-+++ wscript 2011-12-17 22:26:58.000000000 -0500
-@@ -153,15 +153,21 @@
- data_dir = bld.path.find_dir('data')
- bld.install_files('wxMupen64Plus.app/Contents/Resources', data_dir.ant_glob('*'))
- bin_install_path = "wxMupen64Plus.app/Contents/MacOS"
--
-+ elif os.uname()[0] == 'FreeBSD':
-+ if 'LOCALBASE' in os.environ:
-+ LOCALBASE = os.environ['LOCALBASE']
-+ else:
-+ LOCALBASE = '/usr/local/'
-+
-+ build_flags += ['-I'+ LOCALBASE +'/include/X11']
-+ osal_src += ['mupen64plusplus/osal_dynamiclib_unix.c', 'mupen64plusplus/osal_files_unix.c']
-+ link_flags += ['-lGL','-lX11']
+--- wscript.orig 2012-03-18 17:28:41.000000000 -0500
++++ wscript 2013-10-04 20:56:33.000000000 -0500
+@@ -83,14 +83,13 @@
+ ctx.env['datadir'] = Options.options.datadir
+ ctx.env['libdir'] = Options.options.libdir
+
+- ctx.find_program('gcc', var='GCC', mandatory=True)
+- ctx.find_program('g++', var='GPP', mandatory=True)
++ ctx.find_program('%%CC%%', var='GCC', mandatory=True)
++ ctx.find_program('%%CXX%%', var='GPP', mandatory=True)
+ ctx.check_cc(header_name="stdio.h", function_name='printf', msg='Checking C compiler works', errmsg="No")
+ ctx.check_cxx(header_name="cstdio", function_name='printf', msg='Checking C++ compiler works', errmsg="No")
+ ctx.check_cc(header_name="m64p_frontend.h", includes=[api_path])
+ ctx.check_cc(header_name="m64p_config.h", includes=[api_path])
+ ctx.check_cc(header_name="m64p_types.h", includes=[api_path])
+- ctx.check_cc(header_name="../main/version.h", includes=[api_path])
+
+ ctx.check_cfg(path=sdl_config, args='--cflags --libs', package='', uselib_store='SDL')
+
+@@ -99,20 +98,7 @@
+ ctx.fatal("On Windows, the --wxhome argument is mandatory")
+ ctx.check_cfg(msg="Checking for wxWidgets 2.9.x", path=wx_config, args='--version=2.9 --cxxflags --prefix=' + wxhome + ' ' + wxconfig_args + ' --libs core,base,gl,html', package='', uselib_store='wxWidgets')
else:
- # For other unices
- build_flags += ['-I/usr/include/X11']
- osal_src += ['mupen64plusplus/osal_dynamiclib_unix.c', 'mupen64plusplus/osal_files_unix.c']
- link_flags += ['-lGL', '-ldl', '-lX11']
-
-- link_flags += ['-ldl']
--
- # install target
- data_dir = bld.path.find_dir('data')
- if len(bld.env['datadir']) > 0:
+- ctx.check_cfg(msg="Checking for wxWidgets 2.9.x", path=wx_config, args='--version=2.9 --cxxflags --libs core,base,gl,html ' + wxconfig_args, package='', uselib_store='wxWidgets')
+-
+- ctx.check_cc(compile_filename='test.c', execute=False, cflags=["-I"+api_path], msg="Checking mupen64plus is recent enough...", fragment=
+-"""#include "../main/version.h"
+- #if FRONTEND_API_VERSION < 0x020001
+- #error Your mupen64plus build is too old, please upgrade
+- #endif
+- #if CONFIG_API_VERSION < 0x020000
+- #error Your mupen64plus build is too old, please upgrade
+- #endif
+- #if VIDEXT_API_VERSION < 0x020000
+- #error Your mupen64plus build is too old, please upgrade
+- #endif
+- int main(int argc, char** argv) {}""")
++ ctx.check_cfg(msg="Checking for wxWidgets 2.9.x", path=wx_config, args='--version=2.9 --cxxflags --libs adv,core,base,gl,html ' + wxconfig_args, package='', uselib_store='wxWidgets')
+
+ # --------------------------------------------------------------------------------------------
+ # BUILD
diff --git a/emulators/wxmupen64plus/files/patch-wxvidext.cpp b/emulators/wxmupen64plus/files/patch-wxvidext.cpp
new file mode 100644
index 000000000000..7725f0153bb3
--- /dev/null
+++ b/emulators/wxmupen64plus/files/patch-wxvidext.cpp
@@ -0,0 +1,11 @@
+--- wxvidext.cpp 2013-10-04 20:22:46.000000000 -0500
++++ wxvidext.cpp 2013-10-04 20:24:08.000000000 -0500
+@@ -455,7 +455,7 @@
+ #endif
+ */
+
+-m64p_error VidExt_SetVideoMode(int Width, int Height, int BitsPerPixel, /*m64p_video_mode*/ int ScreenMode)
++m64p_error VidExt_SetVideoMode(int Width, int Height, int BitsPerPixel, /*m64p_video_mode*/ int ScreenMode, int Flags)
+ {
+ gWidth = Width;
+ gHeight = Height;
diff --git a/emulators/wxmupen64plus/files/patch-wxvidext.h b/emulators/wxmupen64plus/files/patch-wxvidext.h
new file mode 100644
index 000000000000..98c6aeb30c52
--- /dev/null
+++ b/emulators/wxmupen64plus/files/patch-wxvidext.h
@@ -0,0 +1,11 @@
+--- wxvidext.h 2013-10-04 20:22:58.000000000 -0500
++++ wxvidext.h 2013-10-04 20:23:12.000000000 -0500
+@@ -29,7 +29,7 @@
+ m64p_error VidExt_Init(void);
+ m64p_error VidExt_Quit(void);
+ m64p_error VidExt_ListFullscreenModes(m64p_2d_size *SizeArray, int *NumSizes);
+-m64p_error VidExt_SetVideoMode(int Width, int Height, int BitsPerPixel, /*m64p_video_mode*/ int ScreenMode);
++m64p_error VidExt_SetVideoMode(int Width, int Height, int BitsPerPixel, /*m64p_video_mode*/ int ScreenMode, int Flags);
+ m64p_error VidExt_SetCaption(const char *Title);
+ m64p_error VidExt_ToggleFullScreen(void);
+ void* VidExt_GL_GetProcAddress(const char* Proc);
diff --git a/emulators/wxmupen64plus/pkg-descr b/emulators/wxmupen64plus/pkg-descr
index cd6ff9b891e5..dfb110e46854 100644
--- a/emulators/wxmupen64plus/pkg-descr
+++ b/emulators/wxmupen64plus/pkg-descr
@@ -1,3 +1,3 @@
wxMupen64plus is A Mupen64Plus v2 frontend written with wxWidgets
-WWW: http://bitbucket.org/auria/wxmupen64plus
+WWW: http://bitbucket.org/auria/wxmupen64plus