aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-02-11 13:51:48 +0000
committerSatoshi Asami <asami@FreeBSD.org>1995-02-11 13:51:48 +0000
commit86793c984d6929b0d9d6e2f283fa7a6e24ad8846 (patch)
tree514f831b9b79e6406f53b572ee92815f71d23bd0 /emulators
parent9f2b60a3787262636d15fcbbb497df01fcfce1c5 (diff)
downloadports-86793c984d6929b0d9d6e2f283fa7a6e24ad8846.tar.gz
ports-86793c984d6929b0d9d6e2f283fa7a6e24ad8846.zip
Converted Makefiles as much as I could.
(1) Took out INSTALL_MANPAGES (not necessary anymore, porter should set NO_INSTALL_MANPAGES for not calling "make install.man") (2) Replaced most of DEPENDS with EXEC_DEPENDS and LIB_DEPENDS. These are the entries I used: EXEC_DEPENDS: unzip:${PORTSDIR}/archivers/unzip gmake:${PORTSDIR}/devel/gmake wishx:${PORTSDIR}/lang/tclX xli:${PORTSDIR}/graphics/xli gs:${PORTSDIR}/print/ghostscript gunshar:${PORTSDIR}/archivers/gshar+gunshar hfs:${PORTSDIR}/utils/hfs rman:${PORTSDIR}/utils/rman LIB_DEPENDS: tiff\\.3\\.:${PORTSDIR}/graphics/tiff jpeg\\.5\\.:${PORTSDIR}/graphics/jpeg Xpm\\.4\\.:${PORTSDIR}/graphics/xpm tcl\\.7\\.:${PORTSDIR}/lang/tcl tk\\.3\\.:${PORTSDIR}/x11/tk xview\\.1\\.:${PORTSDIR}/x11/xview-lib Xaw3d\\.:${PORTSDIR}/x11/Xaw3d mpeg\\.1\\.:${PORTSDIR}/graphics/mpeg-lib xview\\.3\\.:${PORTSDIR}/x11/xview-lib BLT\\.1\\.:${PORTSDIR}/x11/blt There are still some dependencies I can't figure out what exactly is needed. If your port still has DEPENDS in it, please check it out!
Notes
Notes: svn path=/head/; revision=935
Diffstat (limited to 'emulators')
-rw-r--r--emulators/tkhfs/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/emulators/tkhfs/Makefile b/emulators/tkhfs/Makefile
index 945e6d39538c..dfeb90b429db 100644
--- a/emulators/tkhfs/Makefile
+++ b/emulators/tkhfs/Makefile
@@ -1,5 +1,6 @@
DISTNAME= tkhfs
MASTER_SITES= ftp://ftp.obs-besancon.fr/pub/outgoing/
-DEPENDS= ${PORTSDIR}/utils/hfs ${PORTSDIR}/x11/tk
+EXEC_DEPENDS= hfs:${PORTSDIR}/utils/hfs
+LIB_DEPENDS= tk\\.3\\.:${PORTSDIR}/x11/tk
.include <bsd.port.mk>