aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-04-24 20:57:27 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-04-24 20:57:27 +0000
commit4a25b8241fd5da80077792783d8c466095af39f2 (patch)
treee0a6723b07f2463e24aacd53bd75f35e22b9e663 /emulators
parentd36dea0f04290d625a2496db0edab90416ed9e62 (diff)
downloadports-4a25b8241fd5da80077792783d8c466095af39f2.tar.gz
ports-4a25b8241fd5da80077792783d8c466095af39f2.zip
- Remove USE_REINPLACE.
- Remove '@' from installation commands. - Format tabs and put targets at the end. Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=160372
Diffstat (limited to 'emulators')
-rw-r--r--emulators/osmose/Makefile29
1 files changed, 13 insertions, 16 deletions
diff --git a/emulators/osmose/Makefile b/emulators/osmose/Makefile
index 00c4f4b43929..b0e5ba44692e 100644
--- a/emulators/osmose/Makefile
+++ b/emulators/osmose/Makefile
@@ -18,12 +18,9 @@ COMMENT= Sega Master System emulator
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
ONLY_FOR_ARCHS= i386
-
USE_ZIP= yes
USE_GMAKE= yes
USE_SDL= sdl
-USE_REINPLACE= yes
-
NO_WRKSUBDIR= yes
OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
@@ -31,13 +28,6 @@ OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
PLIST_FILES= bin/osmose
PORTDOCS= readme.txt
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
-.endif
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
@@ -45,18 +35,25 @@ EXTRA_PATCHES= ${FILESDIR}/extra-patch-freebsd4
.endif
post-patch:
-# Fix Makefile
+# Fix Makefile.
@${REINPLACE_CMD} -e 's|\(-Dlinux\)|${CFLAGS} \1| ; \
- s|sdl-config|${SDL_CONFIG}|' \
- ${WRKSRC}/${MAKEFILE}
+ s|sdl-config|${SDL_CONFIG}|' \
+ ${WRKSRC}/${MAKEFILE}
-# Fix SDL include statement
+# Fix SDL include statement.
@${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|' \
- ${WRKSRC}/*.h
+ ${WRKSRC}/*.h
-# Enable/disable compilation optimizations
+# Enable/disable compilation optimizations.
.if defined(WITHOUT_OPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/${MAKEFILE}
.endif
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+.endif
+
.include <bsd.port.post.mk>