aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-13 09:16:23 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-13 09:16:23 +0000
commite43af4f8368973dc85aba55a9e14cc3dcf04ce0e (patch)
tree5c525dfc69201cf974803542fe0b450ebf37fe8b /emulators
parent9045d474fd6de1cd7a1382b8338bb14457e83266 (diff)
downloadports-e43af4f8368973dc85aba55a9e14cc3dcf04ce0e.tar.gz
ports-e43af4f8368973dc85aba55a9e14cc3dcf04ce0e.zip
Add linux-padjoy.
padJoy is a PSEmu Pro joystick plugin. This is the Linux version, tested with emulators/linux-ePSXe. WWW: http://download.ammoq.com/ Hint by: Timothy Beyer <beyert@cs.ucr.edu>
Notes
Notes: svn path=/head/; revision=159410
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/linux-padjoy/Makefile51
-rw-r--r--emulators/linux-padjoy/distinfo3
-rw-r--r--emulators/linux-padjoy/pkg-descr8
-rw-r--r--emulators/linux-padjoy/pkg-message6
-rw-r--r--emulators/linux-padjoy/pkg-plist8
6 files changed, 77 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index c864100725b9..29c2dbf45a29 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -53,6 +53,7 @@
SUBDIR += libvm68k
SUBDIR += linux-ePSXe
SUBDIR += linux-geepee32
+ SUBDIR += linux-padjoy
SUBDIR += linux-peops-softgpu
SUBDIR += linux-peops-spu
SUBDIR += linux-pete-mesagpu
diff --git a/emulators/linux-padjoy/Makefile b/emulators/linux-padjoy/Makefile
new file mode 100644
index 000000000000..97a01d3dfbe8
--- /dev/null
+++ b/emulators/linux-padjoy/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: linux-padjoy
+# Date created: 13 Apr 2006
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= padjoy
+PORTVERSION= 0.8.1
+CATEGORIES= emulators linux
+MASTER_SITES= http://members.chello.at/erich.kitzmueller/ammoq/
+PKGNAMEPREFIX= linux-
+DISTNAME= padJoy${MAJOR}${MINOR}${MICRO}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= A PSEmu Pro joystick plugin (Linux version)
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk \
+ /boot/modules/linux_js.ko:${PORTSDIR}/devel/linux-js
+
+WRKSRC= ${WRKDIR}/padJoy
+NO_BUILD= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
+
+ONLY_FOR_ARCHS= i386 amd64
+
+MAJOR= ${PORTVERSION:R:R}
+MINOR= ${PORTVERSION:R:E}
+MICRO= ${PORTVERSION:E}
+PLIST_SUB= MAJOR=${MAJOR} MINOR=${MINOR}
+
+PSEMUPRO_PLUGINS_DIR= ${PREFIX}/lib/psemupro/plugins
+PSEMUPRO_CFGBINS_DIR= ${PREFIX}/libexec/psemupro/cfg
+
+do-install:
+ ${MKDIR} ${PSEMUPRO_PLUGINS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/libpadJoy-${MAJOR}.${MINOR}.so ${PSEMUPRO_PLUGINS_DIR}
+
+ ${MKDIR} ${PSEMUPRO_CFGBINS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/cfgPadJoy ${PSEMUPRO_CFGBINS_DIR}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+.endif
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/emulators/linux-padjoy/distinfo b/emulators/linux-padjoy/distinfo
new file mode 100644
index 000000000000..2aee37b463b7
--- /dev/null
+++ b/emulators/linux-padjoy/distinfo
@@ -0,0 +1,3 @@
+MD5 (padJoy081.tgz) = 19940dedd33d76255375cfd1ba14fd9a
+SHA256 (padJoy081.tgz) = 5b964eee36eb9a8ba7e389b4b148a98e7b69112e4b6d797578ab13261881f1ae
+SIZE (padJoy081.tgz) = 48344
diff --git a/emulators/linux-padjoy/pkg-descr b/emulators/linux-padjoy/pkg-descr
new file mode 100644
index 000000000000..9adec3208c63
--- /dev/null
+++ b/emulators/linux-padjoy/pkg-descr
@@ -0,0 +1,8 @@
+padJoy is a PSEmu Pro joystick plugin.
+
+This is the Linux version, tested with emulators/linux-ePSXe.
+
+WWW: http://download.ammoq.com/
+
+- Jean-Yves Lefort
+jylefort@FreeBSD.org
diff --git a/emulators/linux-padjoy/pkg-message b/emulators/linux-padjoy/pkg-message
new file mode 100644
index 000000000000..a278c249c544
--- /dev/null
+++ b/emulators/linux-padjoy/pkg-message
@@ -0,0 +1,6 @@
+===============================================================================
+
+This plugin requires the linux_js kernel module. For more details, consult the
+linux_js(4) manual page.
+
+===============================================================================
diff --git a/emulators/linux-padjoy/pkg-plist b/emulators/linux-padjoy/pkg-plist
new file mode 100644
index 000000000000..894304a4f2ad
--- /dev/null
+++ b/emulators/linux-padjoy/pkg-plist
@@ -0,0 +1,8 @@
+lib/psemupro/plugins/libpadJoy-%%MAJOR%%.%%MINOR%%.so
+libexec/psemupro/cfg/cfgPadJoy
+@dirrmtry lib/psemupro/plugins
+@dirrmtry lib/psemupro
+@dirrmtry libexec/psemupro/cfg
+@dirrmtry libexec/psemupro
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%