aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-20 14:26:46 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-20 14:26:46 +0000
commit8ad9fd338e18c7333c669841ecb1cc31204644a7 (patch)
tree25054be32b29718b65e819a2890693238a4558b5 /emulators
parent10b8e2ee8d14c6f2b4d637a39e3c03d891a0217a (diff)
downloadports-8ad9fd338e18c7333c669841ecb1cc31204644a7.tar.gz
ports-8ad9fd338e18c7333c669841ecb1cc31204644a7.zip
Reset maintainership at maitainer request [1] and while I'm here:
- convert to new options, USES, etc. - pet portlint - trim Makefile header - mark emulators/fuse as BROKEN: doesn't build (presumably after recent glib update) Submitted by: Yuri Pankov (via mail) [1]
Notes
Notes: svn path=/head/; revision=314736
Diffstat (limited to 'emulators')
-rw-r--r--emulators/fuse/Makefile33
-rw-r--r--emulators/libspectrum/Makefile24
2 files changed, 27 insertions, 30 deletions
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index 0266ed326d99..1ecac2750648 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fuse
-# Date created: 2003-10-28
-# Whom: Alexey V. Antipovsky <kemm@in-line.ru>
-#
+# Created by: Alexey V. Antipovsky <kemm@in-line.ru>
# $FreeBSD$
-#
PORTNAME= fuse
PORTVERSION= 1.0.0.1
@@ -11,16 +7,15 @@ PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}-emulator/${PORTNAME}/${PORTVERSION}
-MAINTAINER= yuri.pankov@gmail.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Free Unix (Sinclair ZX-)Spectrum Emulator
+LICENSE= GPLv2
+
LIB_DEPENDS= spectrum.8:${PORTSDIR}/emulators/libspectrum \
png15:${PORTSDIR}/graphics/png \
gcrypt.18:${PORTSDIR}/security/libgcrypt
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-
GNU_CONFIGURE= yes
USE_GNOME= libxml2 glib20 gtk20
@@ -30,27 +25,33 @@ CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
MAN1= fuse.1
-OPTIONS= AO "Use libao for audio output" off \
- SAMPLERATE "Support for better beeper sound quality" on
+OPTIONS_DEFINE= AO SAMPLERATE
+OPTIONS_DEFAULT= SAMPLERATE
+AO_DESC= Use libao for audio output
+SAMPLERATE_DESC= Better beeper sound quality
+
+BROKEN= does not build (presumably after recent glib update)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_AO)
+.if ${PORT_OPTIONS:MAO}
CONFIGURE_ARGS+=--with-libao
LIB_DEPENDS+= ao.4:${PORTSDIR}/audio/libao
+.else
+CONFIGURE_ARGS+=--without-libao
.endif
-.if !defined(WITHOUT_SAMPLERATE)
+.if ${PORT_OPTIONS:MSAMPLERATE}
LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
.else
CONFIGURE_ARGS+=--without-libsamplerate
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS ChangeLog README THANKS \
${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/libspectrum/Makefile b/emulators/libspectrum/Makefile
index 5d64a3c6f326..48ed2f2bc917 100644
--- a/emulators/libspectrum/Makefile
+++ b/emulators/libspectrum/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libspectrum
-# Date created: 2003-10-27
-# Whom: Alexey V. Antipovsky <kemm@in-line.ru>
-#
+# Created by: Alexey V. Antipovsky <kemm@in-line.ru>
# $FreeBSD$
-#
PORTNAME= libspectrum
PORTVERSION= 1.0.0
@@ -11,13 +7,12 @@ PORTREVISION= 1
CATEGORIES= emulators devel
MASTER_SITES= SF/fuse-emulator/${PORTNAME}/${PORTVERSION}
-MAINTAINER= yuri.pankov@gmail.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= Handling of ZX-Spectrum emulator files formats
-LIB_DEPENDS= gcrypt.18:${PORTSDIR}/security/libgcrypt
-
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= gcrypt.18:${PORTSDIR}/security/libgcrypt
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -26,21 +21,22 @@ USE_LDCONFIG= yes
MAN3= libspectrum.3
-OPTIONS= AUDIOFILE "Support loading from .wav files" on
+OPTIONS_DEFINE= AUDIOFILE
+AUDIOFILE_DESC= Support loading from .wav files
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_AUDIOFILE)
+.if ${PORT_OPTIONS:MAUDIOFILE}
LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
.else
CONFIGURE_ARGS+=--without-libaudiofile
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} \
AUTHORS ChangeLog README THANKS doc/libspectrum.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>