aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-09-05 22:35:55 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-09-05 22:35:55 +0000
commit018f022d33b7824556c386272a9e5ac4cb1f9bee (patch)
tree67b9739b6e717dde5659e20b799bd0e4dee86b83 /emulators
parentfea6eb7255147a9a804336a9c37fc652f93b79a0 (diff)
downloadports-018f022d33b7824556c386272a9e5ac4cb1f9bee.tar.gz
ports-018f022d33b7824556c386272a9e5ac4cb1f9bee.zip
- Update to version 0.118.
- Binaries are now installed in a subdirectory (libexec/sdlmess). - The wrapper script addtional output was removed (problematic for programs which parse the output). Submitted by: nikow <madleser@gmx.de> (private e-mail)
Notes
Notes: svn path=/head/; revision=198873
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mess/Makefile11
-rw-r--r--emulators/mess/distinfo6
-rw-r--r--emulators/mess/files/patch-makefile.sdl193
-rw-r--r--emulators/mess/files/sdlmess.in7
-rw-r--r--emulators/mess/pkg-plist31
-rw-r--r--emulators/sdlmess/Makefile11
-rw-r--r--emulators/sdlmess/distinfo6
-rw-r--r--emulators/sdlmess/files/patch-makefile.sdl193
-rw-r--r--emulators/sdlmess/files/sdlmess.in7
-rw-r--r--emulators/sdlmess/pkg-plist31
10 files changed, 160 insertions, 336 deletions
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index 7bfdef8b90e1..fcabbdd9caa5 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sdlmess
-PORTVERSION= 0.116
+PORTVERSION= 0.118
CATEGORIES= emulators
MASTER_SITES= http://rbelmont.mameworld.info/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
@@ -24,10 +24,11 @@ SUB_FILES= ${PORTNAME} pkg-message
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
-.for f in obj/sdlmess/file2str sdlmess testkeys dat2html messtest messdocs \
- imgtool romcmp chdman jedutil makemeta regrep srcclean
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/${f:T:S/sdl//}
+ ${MKDIR} ${PREFIX}/libexec/sdlmess
+.for f in obj/sdl/mess/build/file2str obj/sdl/mess/build/png2bdc mess \
+ testkeys dat2html messtest messdocs imgtool romcmp chdman jedutil \
+ makemeta regrep srcclean
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/sdlmess
.endfor
${MKDIR} ${DATADIR}
.for f in artwork hash keymaps sysinfo.dat
diff --git a/emulators/mess/distinfo b/emulators/mess/distinfo
index 156f73102be9..a625137f116b 100644
--- a/emulators/mess/distinfo
+++ b/emulators/mess/distinfo
@@ -1,3 +1,3 @@
-MD5 (sdlmess0116.zip) = 84bac8eb07e188d6933b6c8ee36bec88
-SHA256 (sdlmess0116.zip) = 9d933553c329d51b669d6368ace19859c5150e2a8b7a7be6a5d511b64c5ead8d
-SIZE (sdlmess0116.zip) = 26268018
+MD5 (sdlmess0118.zip) = 7919bf94b29e617bb38dc5dd4d515763
+SHA256 (sdlmess0118.zip) = ac1be217433a9c3cfd869d1f7b9425b433ce5cf88bfb5f229e976a8fc3d289b3
+SIZE (sdlmess0118.zip) = 26621588
diff --git a/emulators/mess/files/patch-makefile.sdl b/emulators/mess/files/patch-makefile.sdl
index 3c10642277e0..d892918261fd 100644
--- a/emulators/mess/files/patch-makefile.sdl
+++ b/emulators/mess/files/patch-makefile.sdl
@@ -1,9 +1,9 @@
---- makefile.sdl.orig Thu Apr 12 22:23:24 2007
-+++ makefile.sdl Sat Apr 21 13:35:00 2007
-@@ -63,11 +63,13 @@
+--- makefile.sdl.orig Fri Aug 31 10:41:30 2007
++++ makefile.sdl Fri Aug 31 11:22:15 2007
+@@ -66,11 +66,13 @@
# uncomment next line to include the debugger
- # DEBUG = 1
-
+ # DEBUG = 1
+
+ifeq ($(ARCH),i386)
# uncomment next line to use DRC MIPS3 engine
X86_MIPS3_DRC = 1
@@ -12,164 +12,73 @@
X86_PPC_DRC = 1
+endif
- #-------------------------------------------------
- # specify build options; see each option below
-@@ -128,17 +130,6 @@
- PPC = 1
- endif
+ # uncomment next line to use DRC Voodoo rasterizers
+ # X86_VOODOO_DRC = 1
+@@ -96,7 +98,9 @@
+ # CELL = 1
--ifdef PPC
--X86_MIPS3_DRC =
--X86_PPC_DRC =
--endif
--
--# disable DRC cores for 64-bit builds
--ifdef PTR64
--X86_MIPS3_DRC =
--X86_PPC_DRC =
--endif
--
- # Mac builds always need EXPAT and ZLIB built
- ifeq ($(SUBARCH),macosx)
+ # uncomment next line if you are building for a 64-bit target
+-# PTR64 = 1
++ifeq ($(ARCH),amd64)
++PTR64 = 1
++endif
+
+ # uncomment next line to build expat as part of MAME build
BUILD_EXPAT = 1
-@@ -174,8 +165,8 @@
+@@ -160,8 +164,8 @@
# compiler, linker and utilities
AR = @ar
-CC = @gcc
-LD = @gcc
+CC := @$(CC)
-+LD = $(CC)
- MD = -mkdir
++LD = @$(CC)
+ HHC = @-hhc
+ MD = -mkdir$(EXE)
RM = @rm -f
-
-@@ -191,49 +182,8 @@
+@@ -258,8 +262,8 @@
endif
- # by default, don't compile for a specific target CPU
--NAME = $(PREFIX)$(TARGET)
--ARCH =
--
--# architecture-specific builds get extra options
--ifdef ATHLON
--NAME = $(PREFIX)$(TARGET)at
--ARCH = -march=athlon
--endif
--
--ifdef I686
--NAME = $(PREFIX)$(TARGET)pp
--ARCH = -march=pentiumpro
--endif
--
--ifdef P4
--NAME = $(PREFIX)$(TARGET)p4
--ARCH = -march=pentium4
--endif
--
--ifdef AMD64
--NAME = $(PREFIX)$(TARGET)64
--ARCH = -march=athlon64
--endif
--
--ifdef PM
--NAME = $(PREFIX)$(TARGET)pm
--ARCH = -march=pentium3 -msse2
--endif
--
--ifdef G4
--NAME = $(PREFIX)$(TARGET)g4
--ARCH = -mcpu=G4
--endif
--
--ifdef G5
--NAME = $(PREFIX)$(TARGET)g5
--ARCH = -mcpu=G5
--endif
--
--ifdef CELL
--NAME = $(PREFIX)$(TARGET)cbe
-+NAME = sdl$(TARGET)
- ARCH =
--endif
+ # fullname is prefix+name+suffix
+-FULLNAME = $(PREFIX)$(NAME)$(SUFFIX)
+-FULLGUINAME = $(PREFIX)$(NAME)gui$(SUFFIX)
++FULLNAME = $(NAME)
++FULLGUINAME = $(NAME)gui
- # debug builds just get the 'd' suffix and nothing more
- ifdef DEBUG
-@@ -253,18 +203,22 @@
- # compile-time definitions
+ # add an EXE suffix to get the final emulator name
+ EMULATORCLI = $(FULLNAME)$(EXE)
+@@ -325,7 +329,7 @@
#-------------------------------------------------
--ifdef PPC
--DEFS = -DPPC_ASM -DINLINE="static __inline__" -Dasm=__asm__ -DPI=M_PI -Dstrnicmp=strncasecmp -D_scalb=scalb -DCRLF=2 -DGL_GLEXT_PROTOTYPES=1 -Dbool=int
--else
--ifdef PTR64
- DEFS = -DLSB_FIRST -DINLINE="static __inline__" -Dasm=__asm__ -DPI=M_PI -Dstrnicmp=strncasecmp -D_scalb=scalb -DCRLF=2 -DGL_GLEXT_PROTOTYPES=1
--else
--DEFS = -DX86_ASM -DLSB_FIRST -DINLINE="static __inline__" -Dasm=__asm__ -DPI=M_PI -Dstrnicmp=strncasecmp -D_scalb=scalb -DCRLF=2 -DGL_GLEXT_PROTOTYPES=1
-+
-+ifeq ($(ARCH),i386)
-+DEFS += -DX86_ASM
- endif
-+
-+ifeq ($(ARCH),powerpc)
-+DEFS += -DPPC_ASM -Dbool=int
-+endif
-+
-+ifneq ($(shell echo $(ARCH) | grep -v 64),)
-+PTR64 = yes
- endif
+ # we compile to C89 standard with GNU extensions
+-CFLAGS = -std=gnu89
++CFLAGS += -std=gnu89
- ifdef PTR64
--DEFS += -DPTR64
-+DEFS += -DLSB_FIRST -DPTR64
- endif
-
- ifdef DEBUG
-@@ -275,7 +229,7 @@
- # compile and linking flags
- #-------------------------------------------------
+ # add -g if we need symbols
+ ifdef SYMBOLS
+@@ -356,7 +360,7 @@
+ # and make all errors into warnings
+ # but not on 64-bit or debug builds
+ ifneq ($(OPTIMIZE),0)
+-CFLAGS += $(ARCH) -fno-strict-aliasing
++CFLAGS += -fno-strict-aliasing
--CFLAGS = \
-+CFLAGS += \
- $(OPT_FLAGS) \
- -std=gnu89 \
- -I$(SRC)/$(TARGET) \
-@@ -287,6 +241,7 @@
+ # only -Werror if not PTR64 and not DEBUG
+ ifndef PTR64
+@@ -397,6 +401,7 @@
-I$(SRC)/lib/util \
-I$(SRC)/osd \
- -I$(SRC)/osd/$(MAMEOS) \
-+ -I$(LOCALBASE)/include -I$(X11BASE)/include
+ -I$(SRC)/osd/$(OSD) \
++ -I$(LOCALBASE)/include
ifdef MESS
CFLAGS += \
-@@ -305,7 +260,7 @@
- endif # PPC
- endif # SYMBOLS
-
--CFLAGS += $(ARCH) \
-+CFLAGS += \
- -Wall \
- -Wpointer-arith \
- -Wbad-function-cast \
-@@ -317,7 +272,7 @@
- -Wdeclaration-after-statement
-
- ifneq ($(OPTIMIZE),0)
--CFLAGS += -DNDEBUG $(ARCH) -fno-strict-aliasing
-+CFLAGS += -DNDEBUG -fno-strict-aliasing
- endif
-
- CFLAGS += -O$(OPTIMIZE)
-@@ -325,11 +280,9 @@
- # extra options needed *only* for the osd files
- CFLAGSOSDEPEND = $(CFLAGS)
+@@ -412,7 +417,7 @@
--LDFLAGS = -WO
-+LDFLAGS = -WO -L$(LOCALBASE)/lib -L$(X11BASE)/lib
-
--ifdef SYMBOLS
+ # LDFLAGS are used generally; LDFLAGSEMULATOR are additional
+ # flags only used when linking the core emulator
-LDFLAGS =
--else
-+ifndef SYMBOLS
- LDFLAGS += -s
- endif
++LDFLAGS += -L$(LOCALBASE)/lib
+ LDFLAGSEMULATOR =
+ # strip symbols and other metadata in non-symbols builds
diff --git a/emulators/mess/files/sdlmess.in b/emulators/mess/files/sdlmess.in
index df44e1bf27fd..f0d97316d6f3 100644
--- a/emulators/mess/files/sdlmess.in
+++ b/emulators/mess/files/sdlmess.in
@@ -2,14 +2,11 @@
#
# The executable needs to be run from its data directory, and needs to store
# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.cube, and create symlinks to the data files.
+# ~/.sdlmess, and create symlinks to the data files.
#
-if [ -d ~/.sdlmess ]
+if [ ! -d ~/.sdlmess ]
then
- echo "Using existing ~/.sdlmess directory."
-else
- echo "Creating ~/.sdlmess directory."
cd %%DATADIR%% || exit 1
find * -type d -exec mkdir -p ~/.sdlmess/{} \;
find * -type f -exec ln -s %%DATADIR%%/{} ~/.sdlmess/{} \; 2>/dev/null
diff --git a/emulators/mess/pkg-plist b/emulators/mess/pkg-plist
index 0e87801aca3d..800f6ab08640 100644
--- a/emulators/mess/pkg-plist
+++ b/emulators/mess/pkg-plist
@@ -1,18 +1,20 @@
bin/sdlmess
-libexec/chdman
-libexec/dat2html
-libexec/file2str
-libexec/imgtool
-libexec/jedutil
-libexec/makemeta
-libexec/mess
-libexec/messdocs
-libexec/messtest
-libexec/regrep
-libexec/romcmp
-libexec/srcclean
-libexec/testkeys
+libexec/sdlmess/chdman
+libexec/sdlmess/dat2html
+libexec/sdlmess/file2str
+libexec/sdlmess/png2bdc
+libexec/sdlmess/imgtool
+libexec/sdlmess/jedutil
+libexec/sdlmess/makemeta
+libexec/sdlmess/mess
+libexec/sdlmess/messdocs
+libexec/sdlmess/messtest
+libexec/sdlmess/regrep
+libexec/sdlmess/romcmp
+libexec/sdlmess/srcclean
+libexec/sdlmess/testkeys
%%PORTDOCS%%%%DOCSDIR%%/SDLMESS.txt
+%%PORTDOCS%%%%DOCSDIR%%/whatsnew.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/credits.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/faq.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/images/logo.gif
@@ -20,6 +22,7 @@ libexec/testkeys
%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/messnew.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/config.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/newvideo.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/windows.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/choice.htm
@@ -53,6 +56,7 @@ libexec/testkeys
%%DATADIR%%/artwork/floppyr.png
%%DATADIR%%/artwork/floppyw.png
%%DATADIR%%/artwork/kim1.zip
+%%DATADIR%%/artwork/aim65.zip
%%DATADIR%%/artwork/ledoff.png
%%DATADIR%%/artwork/ledon.png
%%DATADIR%%/artwork/mk1.zip
@@ -137,6 +141,7 @@ libexec/testkeys
%%DATADIR%%/hash/vic20.hsi
%%DATADIR%%/hash/wswan.hsi
%%DATADIR%%/keymaps/km-ch.txt
+%%DATADIR%%/keymaps/km-de.txt
%%DATADIR%%/keymaps/km-fr-OSX.txt
%%DATADIR%%/keymaps/km-fr.txt
%%DATADIR%%/sysinfo.dat
diff --git a/emulators/sdlmess/Makefile b/emulators/sdlmess/Makefile
index 7bfdef8b90e1..fcabbdd9caa5 100644
--- a/emulators/sdlmess/Makefile
+++ b/emulators/sdlmess/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sdlmess
-PORTVERSION= 0.116
+PORTVERSION= 0.118
CATEGORIES= emulators
MASTER_SITES= http://rbelmont.mameworld.info/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
@@ -24,10 +24,11 @@ SUB_FILES= ${PORTNAME} pkg-message
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
-.for f in obj/sdlmess/file2str sdlmess testkeys dat2html messtest messdocs \
- imgtool romcmp chdman jedutil makemeta regrep srcclean
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/${f:T:S/sdl//}
+ ${MKDIR} ${PREFIX}/libexec/sdlmess
+.for f in obj/sdl/mess/build/file2str obj/sdl/mess/build/png2bdc mess \
+ testkeys dat2html messtest messdocs imgtool romcmp chdman jedutil \
+ makemeta regrep srcclean
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/sdlmess
.endfor
${MKDIR} ${DATADIR}
.for f in artwork hash keymaps sysinfo.dat
diff --git a/emulators/sdlmess/distinfo b/emulators/sdlmess/distinfo
index 156f73102be9..a625137f116b 100644
--- a/emulators/sdlmess/distinfo
+++ b/emulators/sdlmess/distinfo
@@ -1,3 +1,3 @@
-MD5 (sdlmess0116.zip) = 84bac8eb07e188d6933b6c8ee36bec88
-SHA256 (sdlmess0116.zip) = 9d933553c329d51b669d6368ace19859c5150e2a8b7a7be6a5d511b64c5ead8d
-SIZE (sdlmess0116.zip) = 26268018
+MD5 (sdlmess0118.zip) = 7919bf94b29e617bb38dc5dd4d515763
+SHA256 (sdlmess0118.zip) = ac1be217433a9c3cfd869d1f7b9425b433ce5cf88bfb5f229e976a8fc3d289b3
+SIZE (sdlmess0118.zip) = 26621588
diff --git a/emulators/sdlmess/files/patch-makefile.sdl b/emulators/sdlmess/files/patch-makefile.sdl
index 3c10642277e0..d892918261fd 100644
--- a/emulators/sdlmess/files/patch-makefile.sdl
+++ b/emulators/sdlmess/files/patch-makefile.sdl
@@ -1,9 +1,9 @@
---- makefile.sdl.orig Thu Apr 12 22:23:24 2007
-+++ makefile.sdl Sat Apr 21 13:35:00 2007
-@@ -63,11 +63,13 @@
+--- makefile.sdl.orig Fri Aug 31 10:41:30 2007
++++ makefile.sdl Fri Aug 31 11:22:15 2007
+@@ -66,11 +66,13 @@
# uncomment next line to include the debugger
- # DEBUG = 1
-
+ # DEBUG = 1
+
+ifeq ($(ARCH),i386)
# uncomment next line to use DRC MIPS3 engine
X86_MIPS3_DRC = 1
@@ -12,164 +12,73 @@
X86_PPC_DRC = 1
+endif
- #-------------------------------------------------
- # specify build options; see each option below
-@@ -128,17 +130,6 @@
- PPC = 1
- endif
+ # uncomment next line to use DRC Voodoo rasterizers
+ # X86_VOODOO_DRC = 1
+@@ -96,7 +98,9 @@
+ # CELL = 1
--ifdef PPC
--X86_MIPS3_DRC =
--X86_PPC_DRC =
--endif
--
--# disable DRC cores for 64-bit builds
--ifdef PTR64
--X86_MIPS3_DRC =
--X86_PPC_DRC =
--endif
--
- # Mac builds always need EXPAT and ZLIB built
- ifeq ($(SUBARCH),macosx)
+ # uncomment next line if you are building for a 64-bit target
+-# PTR64 = 1
++ifeq ($(ARCH),amd64)
++PTR64 = 1
++endif
+
+ # uncomment next line to build expat as part of MAME build
BUILD_EXPAT = 1
-@@ -174,8 +165,8 @@
+@@ -160,8 +164,8 @@
# compiler, linker and utilities
AR = @ar
-CC = @gcc
-LD = @gcc
+CC := @$(CC)
-+LD = $(CC)
- MD = -mkdir
++LD = @$(CC)
+ HHC = @-hhc
+ MD = -mkdir$(EXE)
RM = @rm -f
-
-@@ -191,49 +182,8 @@
+@@ -258,8 +262,8 @@
endif
- # by default, don't compile for a specific target CPU
--NAME = $(PREFIX)$(TARGET)
--ARCH =
--
--# architecture-specific builds get extra options
--ifdef ATHLON
--NAME = $(PREFIX)$(TARGET)at
--ARCH = -march=athlon
--endif
--
--ifdef I686
--NAME = $(PREFIX)$(TARGET)pp
--ARCH = -march=pentiumpro
--endif
--
--ifdef P4
--NAME = $(PREFIX)$(TARGET)p4
--ARCH = -march=pentium4
--endif
--
--ifdef AMD64
--NAME = $(PREFIX)$(TARGET)64
--ARCH = -march=athlon64
--endif
--
--ifdef PM
--NAME = $(PREFIX)$(TARGET)pm
--ARCH = -march=pentium3 -msse2
--endif
--
--ifdef G4
--NAME = $(PREFIX)$(TARGET)g4
--ARCH = -mcpu=G4
--endif
--
--ifdef G5
--NAME = $(PREFIX)$(TARGET)g5
--ARCH = -mcpu=G5
--endif
--
--ifdef CELL
--NAME = $(PREFIX)$(TARGET)cbe
-+NAME = sdl$(TARGET)
- ARCH =
--endif
+ # fullname is prefix+name+suffix
+-FULLNAME = $(PREFIX)$(NAME)$(SUFFIX)
+-FULLGUINAME = $(PREFIX)$(NAME)gui$(SUFFIX)
++FULLNAME = $(NAME)
++FULLGUINAME = $(NAME)gui
- # debug builds just get the 'd' suffix and nothing more
- ifdef DEBUG
-@@ -253,18 +203,22 @@
- # compile-time definitions
+ # add an EXE suffix to get the final emulator name
+ EMULATORCLI = $(FULLNAME)$(EXE)
+@@ -325,7 +329,7 @@
#-------------------------------------------------
--ifdef PPC
--DEFS = -DPPC_ASM -DINLINE="static __inline__" -Dasm=__asm__ -DPI=M_PI -Dstrnicmp=strncasecmp -D_scalb=scalb -DCRLF=2 -DGL_GLEXT_PROTOTYPES=1 -Dbool=int
--else
--ifdef PTR64
- DEFS = -DLSB_FIRST -DINLINE="static __inline__" -Dasm=__asm__ -DPI=M_PI -Dstrnicmp=strncasecmp -D_scalb=scalb -DCRLF=2 -DGL_GLEXT_PROTOTYPES=1
--else
--DEFS = -DX86_ASM -DLSB_FIRST -DINLINE="static __inline__" -Dasm=__asm__ -DPI=M_PI -Dstrnicmp=strncasecmp -D_scalb=scalb -DCRLF=2 -DGL_GLEXT_PROTOTYPES=1
-+
-+ifeq ($(ARCH),i386)
-+DEFS += -DX86_ASM
- endif
-+
-+ifeq ($(ARCH),powerpc)
-+DEFS += -DPPC_ASM -Dbool=int
-+endif
-+
-+ifneq ($(shell echo $(ARCH) | grep -v 64),)
-+PTR64 = yes
- endif
+ # we compile to C89 standard with GNU extensions
+-CFLAGS = -std=gnu89
++CFLAGS += -std=gnu89
- ifdef PTR64
--DEFS += -DPTR64
-+DEFS += -DLSB_FIRST -DPTR64
- endif
-
- ifdef DEBUG
-@@ -275,7 +229,7 @@
- # compile and linking flags
- #-------------------------------------------------
+ # add -g if we need symbols
+ ifdef SYMBOLS
+@@ -356,7 +360,7 @@
+ # and make all errors into warnings
+ # but not on 64-bit or debug builds
+ ifneq ($(OPTIMIZE),0)
+-CFLAGS += $(ARCH) -fno-strict-aliasing
++CFLAGS += -fno-strict-aliasing
--CFLAGS = \
-+CFLAGS += \
- $(OPT_FLAGS) \
- -std=gnu89 \
- -I$(SRC)/$(TARGET) \
-@@ -287,6 +241,7 @@
+ # only -Werror if not PTR64 and not DEBUG
+ ifndef PTR64
+@@ -397,6 +401,7 @@
-I$(SRC)/lib/util \
-I$(SRC)/osd \
- -I$(SRC)/osd/$(MAMEOS) \
-+ -I$(LOCALBASE)/include -I$(X11BASE)/include
+ -I$(SRC)/osd/$(OSD) \
++ -I$(LOCALBASE)/include
ifdef MESS
CFLAGS += \
-@@ -305,7 +260,7 @@
- endif # PPC
- endif # SYMBOLS
-
--CFLAGS += $(ARCH) \
-+CFLAGS += \
- -Wall \
- -Wpointer-arith \
- -Wbad-function-cast \
-@@ -317,7 +272,7 @@
- -Wdeclaration-after-statement
-
- ifneq ($(OPTIMIZE),0)
--CFLAGS += -DNDEBUG $(ARCH) -fno-strict-aliasing
-+CFLAGS += -DNDEBUG -fno-strict-aliasing
- endif
-
- CFLAGS += -O$(OPTIMIZE)
-@@ -325,11 +280,9 @@
- # extra options needed *only* for the osd files
- CFLAGSOSDEPEND = $(CFLAGS)
+@@ -412,7 +417,7 @@
--LDFLAGS = -WO
-+LDFLAGS = -WO -L$(LOCALBASE)/lib -L$(X11BASE)/lib
-
--ifdef SYMBOLS
+ # LDFLAGS are used generally; LDFLAGSEMULATOR are additional
+ # flags only used when linking the core emulator
-LDFLAGS =
--else
-+ifndef SYMBOLS
- LDFLAGS += -s
- endif
++LDFLAGS += -L$(LOCALBASE)/lib
+ LDFLAGSEMULATOR =
+ # strip symbols and other metadata in non-symbols builds
diff --git a/emulators/sdlmess/files/sdlmess.in b/emulators/sdlmess/files/sdlmess.in
index df44e1bf27fd..f0d97316d6f3 100644
--- a/emulators/sdlmess/files/sdlmess.in
+++ b/emulators/sdlmess/files/sdlmess.in
@@ -2,14 +2,11 @@
#
# The executable needs to be run from its data directory, and needs to store
# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.cube, and create symlinks to the data files.
+# ~/.sdlmess, and create symlinks to the data files.
#
-if [ -d ~/.sdlmess ]
+if [ ! -d ~/.sdlmess ]
then
- echo "Using existing ~/.sdlmess directory."
-else
- echo "Creating ~/.sdlmess directory."
cd %%DATADIR%% || exit 1
find * -type d -exec mkdir -p ~/.sdlmess/{} \;
find * -type f -exec ln -s %%DATADIR%%/{} ~/.sdlmess/{} \; 2>/dev/null
diff --git a/emulators/sdlmess/pkg-plist b/emulators/sdlmess/pkg-plist
index 0e87801aca3d..800f6ab08640 100644
--- a/emulators/sdlmess/pkg-plist
+++ b/emulators/sdlmess/pkg-plist
@@ -1,18 +1,20 @@
bin/sdlmess
-libexec/chdman
-libexec/dat2html
-libexec/file2str
-libexec/imgtool
-libexec/jedutil
-libexec/makemeta
-libexec/mess
-libexec/messdocs
-libexec/messtest
-libexec/regrep
-libexec/romcmp
-libexec/srcclean
-libexec/testkeys
+libexec/sdlmess/chdman
+libexec/sdlmess/dat2html
+libexec/sdlmess/file2str
+libexec/sdlmess/png2bdc
+libexec/sdlmess/imgtool
+libexec/sdlmess/jedutil
+libexec/sdlmess/makemeta
+libexec/sdlmess/mess
+libexec/sdlmess/messdocs
+libexec/sdlmess/messtest
+libexec/sdlmess/regrep
+libexec/sdlmess/romcmp
+libexec/sdlmess/srcclean
+libexec/sdlmess/testkeys
%%PORTDOCS%%%%DOCSDIR%%/SDLMESS.txt
+%%PORTDOCS%%%%DOCSDIR%%/whatsnew.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/credits.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/faq.htm
%%PORTDOCS%%%%DOCSDIR%%/docs/images/logo.gif
@@ -20,6 +22,7 @@ libexec/testkeys
%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/messnew.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/config.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/newvideo.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/windows.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/windows/choice.htm
@@ -53,6 +56,7 @@ libexec/testkeys
%%DATADIR%%/artwork/floppyr.png
%%DATADIR%%/artwork/floppyw.png
%%DATADIR%%/artwork/kim1.zip
+%%DATADIR%%/artwork/aim65.zip
%%DATADIR%%/artwork/ledoff.png
%%DATADIR%%/artwork/ledon.png
%%DATADIR%%/artwork/mk1.zip
@@ -137,6 +141,7 @@ libexec/testkeys
%%DATADIR%%/hash/vic20.hsi
%%DATADIR%%/hash/wswan.hsi
%%DATADIR%%/keymaps/km-ch.txt
+%%DATADIR%%/keymaps/km-de.txt
%%DATADIR%%/keymaps/km-fr-OSX.txt
%%DATADIR%%/keymaps/km-fr.txt
%%DATADIR%%/sysinfo.dat