aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMakoto Matsushita <matusita@FreeBSD.org>2004-06-25 13:04:03 +0000
committerMakoto Matsushita <matusita@FreeBSD.org>2004-06-25 13:04:03 +0000
commit04117250712ec1222db2c22e8d161f02ee448ea9 (patch)
tree8c5faae7eebba6d78fb39b23c51889504a1661e0 /emulators
parent1fbdbf5006cbe0fa798840e9d19a5be5bc0cda91 (diff)
downloadports-04117250712ec1222db2c22e8d161f02ee448ea9.tar.gz
ports-04117250712ec1222db2c22e8d161f02ee448ea9.zip
Fix kernel module build.
Since 'OBJS=' line is inserted _after_ bsd.kmod.mk, OBJS value is overridden by the line (ahh...) Hopefully, 'OBJS=' line is inserted after 'SRCS=' line, but there's no handy way I suppose (sed's command 'i' requires to follow a newline, but how can I put a newline within a one line?) Since the contents (actually, kernel module) are changed, bump PORTREVISION. Submitted by: sobomax
Notes
Notes: svn path=/head/; revision=112237
Diffstat (limited to 'emulators')
-rw-r--r--emulators/vmware-guestd4/Makefile4
-rw-r--r--emulators/vmware-guestd5/Makefile4
-rw-r--r--emulators/vmware-guestd6/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/emulators/vmware-guestd4/Makefile b/emulators/vmware-guestd4/Makefile
index ef50692e2a9a..a16399b41fff 100644
--- a/emulators/vmware-guestd4/Makefile
+++ b/emulators/vmware-guestd4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vmware
PORTVERSION= ${VMWARE_VER}.${BUILD_VER}
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= # bundled with VMware itself
PKGNAMESUFFIX?= -guestd
@@ -114,7 +114,7 @@ post-extract:
post-patch:
.if defined(WITH_VMWARE_VMMEMCTL)
${REINPLACE_CMD} -e 's|vmmemctl1.o||' ${WRKDIR}/vmmemctl-only/Makefile
- ${ECHO_CMD} "OBJS=vmmemctl1.o" >> ${WRKDIR}/vmmemctl-only/Makefile
+ ${ECHO_CMD} "OBJS+=vmmemctl1.o" >> ${WRKDIR}/vmmemctl-only/Makefile
.endif
.if defined(VMWARE_X_PORTS)
diff --git a/emulators/vmware-guestd5/Makefile b/emulators/vmware-guestd5/Makefile
index ef50692e2a9a..a16399b41fff 100644
--- a/emulators/vmware-guestd5/Makefile
+++ b/emulators/vmware-guestd5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vmware
PORTVERSION= ${VMWARE_VER}.${BUILD_VER}
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= # bundled with VMware itself
PKGNAMESUFFIX?= -guestd
@@ -114,7 +114,7 @@ post-extract:
post-patch:
.if defined(WITH_VMWARE_VMMEMCTL)
${REINPLACE_CMD} -e 's|vmmemctl1.o||' ${WRKDIR}/vmmemctl-only/Makefile
- ${ECHO_CMD} "OBJS=vmmemctl1.o" >> ${WRKDIR}/vmmemctl-only/Makefile
+ ${ECHO_CMD} "OBJS+=vmmemctl1.o" >> ${WRKDIR}/vmmemctl-only/Makefile
.endif
.if defined(VMWARE_X_PORTS)
diff --git a/emulators/vmware-guestd6/Makefile b/emulators/vmware-guestd6/Makefile
index ef50692e2a9a..a16399b41fff 100644
--- a/emulators/vmware-guestd6/Makefile
+++ b/emulators/vmware-guestd6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vmware
PORTVERSION= ${VMWARE_VER}.${BUILD_VER}
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= # bundled with VMware itself
PKGNAMESUFFIX?= -guestd
@@ -114,7 +114,7 @@ post-extract:
post-patch:
.if defined(WITH_VMWARE_VMMEMCTL)
${REINPLACE_CMD} -e 's|vmmemctl1.o||' ${WRKDIR}/vmmemctl-only/Makefile
- ${ECHO_CMD} "OBJS=vmmemctl1.o" >> ${WRKDIR}/vmmemctl-only/Makefile
+ ${ECHO_CMD} "OBJS+=vmmemctl1.o" >> ${WRKDIR}/vmmemctl-only/Makefile
.endif
.if defined(VMWARE_X_PORTS)