aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2012-09-20 14:09:31 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2012-09-20 14:09:31 +0000
commit0a2565bf3cf042b4e49b0800a2e68419d8a71c54 (patch)
treee4723749f10a4a375742f4ad7b58a092a1d54aea /emulators
parent3dc8841bc4b464cda0e89104b3db63f98cfbdb27 (diff)
downloadports-0a2565bf3cf042b4e49b0800a2e68419d8a71c54.tar.gz
ports-0a2565bf3cf042b4e49b0800a2e68419d8a71c54.zip
- Update to 20120912
- Now requires wxGtk 2.9+ (with unicode support) - Force ENCODE_FRAMEDUMPS to OFF (this option would need newer ffmpeg) - Fix debug flags for clang - Fix portaudio detection (requires portaudio 2)
Notes
Notes: svn path=/head/; revision=304577
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dolphin-emu-devel/Makefile19
-rw-r--r--emulators/dolphin-emu-devel/distinfo4
-rw-r--r--emulators/dolphin-emu-devel/files/patch-CMakeLists.txt14
-rw-r--r--emulators/dolphin-emu-devel/files/patch-Source-Core-Common-Src-MemArena.cpp11
-rw-r--r--emulators/dolphin-emu-devel/files/patch-Source-Core-Common-Src-MemoryUtil.cpp6
-rw-r--r--emulators/dolphin-emu-devel/files/patch-Source-Core-Core-Src-HW-BBA-TAP-TAP_Unix.cpp18
-rw-r--r--emulators/dolphin-emu-devel/pkg-plist28
7 files changed, 84 insertions, 16 deletions
diff --git a/emulators/dolphin-emu-devel/Makefile b/emulators/dolphin-emu-devel/Makefile
index 7b1f015a689f..d9ff014128dd 100644
--- a/emulators/dolphin-emu-devel/Makefile
+++ b/emulators/dolphin-emu-devel/Makefile
@@ -7,7 +7,6 @@
PORTNAME= dolphin-emu
PORTVERSION= 3.0.r${REVDATE}
-PORTREVISION= 3
CATEGORIES= emulators
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
LOCAL/martymac
@@ -25,16 +24,20 @@ LIB_DEPENDS= avformat:${PORTSDIR}/multimedia/ffmpeg \
lzo2:${PORTSDIR}/archivers/lzo2 \
sfml-network:${PORTSDIR}/devel/sfml
-REVDATE= 20120307
+REVDATE= 20120912
USE_ICONV= yes
USE_GNOME= pkgconfig
USE_SDL= sdl
USE_OPENAL= yes
USE_XORG= ice xext x11 xrandr
-USE_WX= 2.8
+USE_WX= 2.9+
+WX_UNICODE= yes
USE_GL= gl glew glu
+USE_DOS2UNIX= yes
+DOS2UNIX_REGEX= .*\.(h|c|cpp)
+
# XXX Has only been tested with clang and gcc
.if ${CC} != "clang" && ${CXX} != "clang++"
USE_GCC= 4.6+
@@ -43,9 +46,13 @@ USE_GCC= 4.6+
USE_CMAKE= yes
CMAKE_BUILD_TYPE= Release
# Disable ao (seems buggy) and ALSA (emulated)
+# XXX ENCODE_FRAMEDUMPS is activated but will fail detecting required libs
+# (libavcodec, libavformat, libswscale, libavutil) as our version of ffmpeg is currently
+# too old
CMAKE_ARGS+= -DDISABLE_AO:BOOL=ON \
-DDISABLE_ALSA:BOOL=ON \
-DDISABLE_BLUEZ:BOOL=ON \
+ -DENCODE_FRAMEDUMPS:BOOL=ON \
-DCMAKE_INSTALL_RPATH_USE_LINK_PATH:BOOL=ON
SUB_FILES= pkg-message
@@ -68,8 +75,8 @@ PLIST_SUB+= NLS="@comment "
.if ${PORT_OPTIONS:MDEBUG}
CMAKE_ARGS+= -DFASTLOG:BOOL=ON
INSTALL_TARGET= install
-CFLAGS+= -ggdb
-CXXFLAGS+= -ggdb
+CFLAGS+= -g
+CXXFLAGS+= -g
MAKE_ENV+= VERBOSE=yes
.endif
@@ -88,7 +95,7 @@ CMAKE_ARGS+= -DDISABLE_PULSEAUDIO:BOOL=ON
.endif
.if ${PORT_OPTIONS:MPORTAUDIO}
-LIB_DEPENDS+= portaudio:${PORTSDIR}/audio/portaudio2
+LIB_DEPENDS+= portaudio.2:${PORTSDIR}/audio/portaudio2
.else
CMAKE_ARGS+= -DDISABLE_PORTAUDIO:BOOL=ON
.endif
diff --git a/emulators/dolphin-emu-devel/distinfo b/emulators/dolphin-emu-devel/distinfo
index 367519f873f6..7aa120e690fd 100644
--- a/emulators/dolphin-emu-devel/distinfo
+++ b/emulators/dolphin-emu-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dolphin-emu-3.0.r20120307.tgz) = ed8e16a60d3ba8d8e25f0d171fa8425647a698498576fcb3095a39230817854e
-SIZE (dolphin-emu-3.0.r20120307.tgz) = 28153474
+SHA256 (dolphin-emu-3.0.r20120912.tgz) = af7a14c6d6ab2e07786dc2d6652d874bf2ebddbf1cb72c8640af2dfebbbcc4a6
+SIZE (dolphin-emu-3.0.r20120912.tgz) = 26154876
diff --git a/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt b/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
index 0e43bf44abcf..6b675cf31b7f 100644
--- a/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
+++ b/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2012-03-07 15:35:35.714613728 +0100
-+++ CMakeLists.txt 2012-03-07 15:46:51.665626357 +0100
-@@ -228,51 +228,81 @@
+--- CMakeLists.txt.orig 2012-09-11 12:52:22.000000000 +0200
++++ CMakeLists.txt 2012-09-18 06:49:30.000000000 +0200
+@@ -249,51 +249,81 @@
message("OpenMP parallelization disabled")
endif()
@@ -113,7 +113,7 @@
# Note: We do not need to explicitly check for X11 as it is done in the cmake
# FindOpenGL module on linux.
-@@ -302,22 +332,29 @@
+@@ -323,22 +353,33 @@
check_libav()
endif()
@@ -131,6 +131,10 @@
+option(DISABLE_PORTAUDIO "Disable PortAudio (mic) support" OFF)
+if(NOT DISABLE_PORTAUDIO)
+ include(CheckCXXSourceRuns)
++ include_directories(${CMAKE_INSTALL_PREFIX}/include/portaudio2)
++ link_directories(${CMAKE_INSTALL_PREFIX}/lib/portaudio2)
++ set(CMAKE_REQUIRED_INCLUDES ${CMAKE_INSTALL_PREFIX}/include/portaudio2)
++ set(CMAKE_REQUIRED_FLAGS -L${CMAKE_INSTALL_PREFIX}/lib/portaudio2)
+ set(CMAKE_REQUIRED_LIBRARIES portaudio)
+ CHECK_CXX_SOURCE_RUNS(
+ "#include <portaudio.h>
@@ -156,7 +160,7 @@
option(OPROFILING "Enable profiling" OFF)
if(OPROFILING)
-@@ -563,10 +600,13 @@
+@@ -602,10 +643,13 @@
install(DIRECTORY Data/User/ DESTINATION ${datadir}/user PATTERN)
install(DIRECTORY Data/Sys/ DESTINATION ${datadir}/sys PATTERN)
endif()
diff --git a/emulators/dolphin-emu-devel/files/patch-Source-Core-Common-Src-MemArena.cpp b/emulators/dolphin-emu-devel/files/patch-Source-Core-Common-Src-MemArena.cpp
new file mode 100644
index 000000000000..402e31464540
--- /dev/null
+++ b/emulators/dolphin-emu-devel/files/patch-Source-Core-Common-Src-MemArena.cpp
@@ -0,0 +1,11 @@
+--- Source/Core/Common/Src/MemArena.cpp.orig 2012-09-13 15:55:31.000000000 +0200
++++ Source/Core/Common/Src/MemArena.cpp 2012-09-13 15:55:51.000000000 +0200
+@@ -29,7 +29,7 @@
+ #include <cstring>
+ #endif
+
+-#if defined(__APPLE__)
++#if defined(__APPLE__) || defined (__FreeBSD__)
+ static const char* ram_temp_file = "/tmp/gc_mem.tmp";
+ #elif !defined(_WIN32) // non OSX unixes
+ static const char* ram_temp_file = "/dev/shm/gc_mem.tmp";
diff --git a/emulators/dolphin-emu-devel/files/patch-Source-Core-Common-Src-MemoryUtil.cpp b/emulators/dolphin-emu-devel/files/patch-Source-Core-Common-Src-MemoryUtil.cpp
index 3a7bfe39a88a..e5029af2c308 100644
--- a/emulators/dolphin-emu-devel/files/patch-Source-Core-Common-Src-MemoryUtil.cpp
+++ b/emulators/dolphin-emu-devel/files/patch-Source-Core-Common-Src-MemoryUtil.cpp
@@ -1,5 +1,5 @@
---- Source/Core/Common/Src/MemoryUtil.cpp.orig 2011-12-20 19:12:51.735175478 +0100
-+++ Source/Core/Common/Src/MemoryUtil.cpp 2011-12-20 19:22:47.010407665 +0100
+--- Source/Core/Common/Src/MemoryUtil.cpp.orig 2012-09-20 13:12:50.000000000 +0200
++++ Source/Core/Common/Src/MemoryUtil.cpp 2012-09-20 13:12:43.000000000 +0200
@@ -33,6 +33,13 @@
#define round_page(x) ((((unsigned long)(x)) + PAGE_MASK) & ~(PAGE_MASK))
#endif
@@ -31,7 +31,7 @@
+ limit.rlim_cur = 0x10000000; // 256 MB
+ limit.rlim_max = 0x10000000;
+ if(setrlimit(RLIMIT_DATA, &limit) != 0) {
-+ PanicAlert("Failed to lower maximum data segment size");
++ PanicAlert("Failed to lower maximum data segment size");
+ }
+#endif
+ }
diff --git a/emulators/dolphin-emu-devel/files/patch-Source-Core-Core-Src-HW-BBA-TAP-TAP_Unix.cpp b/emulators/dolphin-emu-devel/files/patch-Source-Core-Core-Src-HW-BBA-TAP-TAP_Unix.cpp
new file mode 100644
index 000000000000..a5da29207fef
--- /dev/null
+++ b/emulators/dolphin-emu-devel/files/patch-Source-Core-Core-Src-HW-BBA-TAP-TAP_Unix.cpp
@@ -0,0 +1,18 @@
+--- Source/Core/Core/Src/HW/BBA-TAP/TAP_Unix.cpp.orig 2012-09-12 15:47:40.000000000 +0200
++++ Source/Core/Core/Src/HW/BBA-TAP/TAP_Unix.cpp 2012-09-12 15:52:09.000000000 +0200
+@@ -119,6 +119,7 @@
+ #endif
+ }
+
++#ifdef __linux__
+ void ReadThreadHandler(CEXIETHERNET* self)
+ {
+ while (true)
+@@ -149,6 +150,7 @@
+ }
+ }
+ }
++#endif
+
+ bool CEXIETHERNET::RecvInit()
+ {
diff --git a/emulators/dolphin-emu-devel/pkg-plist b/emulators/dolphin-emu-devel/pkg-plist
index c0c1d824b63d..dae9e1d0dd73 100644
--- a/emulators/dolphin-emu-devel/pkg-plist
+++ b/emulators/dolphin-emu-devel/pkg-plist
@@ -1384,6 +1384,34 @@ bin/dolphin-emu
%%DATADIR%%/user/GameConfig/RXXE4Q.ini
%%DATADIR%%/user/GameConfig/SX4J01.ini
%%DATADIR%%/user/GameConfig/SX4P01.ini
+%%DATADIR%%/user/GameConfig/SSQE01.ini
+%%DATADIR%%/user/GameConfig/RODJ01.ini
+%%DATADIR%%/user/GameConfig/SX3J01.ini
+%%DATADIR%%/user/GameConfig/RODK01.ini
+%%DATADIR%%/user/GameConfig/SSQP01.ini
+%%DATADIR%%/user/GameConfig/RSFJ99.ini
+%%DATADIR%%/user/GameConfig/GWPJG2.ini
+%%DATADIR%%/user/GameConfig/R3DPS5.ini
+%%DATADIR%%/user/GameConfig/RODE01.ini
+%%DATADIR%%/user/GameConfig/GRYE41.ini
+%%DATADIR%%/user/GameConfig/SSQJ01.ini
+%%DATADIR%%/user/GameConfig/R3DES5.ini
+%%DATADIR%%/user/GameConfig/SX3P01.ini
+%%DATADIR%%/user/GameConfig/R8AE01.ini
+%%DATADIR%%/user/GameConfig/S2LJ01.ini
+%%DATADIR%%/user/GameConfig/SC8E01.ini
+%%DATADIR%%/user/GameConfig/R7XP69.ini
+%%DATADIR%%/user/GameConfig/R7XJ13.ini
+%%DATADIR%%/user/GameConfig/GAXE5D.ini
+%%DATADIR%%/user/GameConfig/SLSP01.ini
+%%DATADIR%%/user/GameConfig/SC8P01.ini
+%%DATADIR%%/user/GameConfig/R7XE69.ini
+%%DATADIR%%/user/GameConfig/SNDE20.ini
+%%DATADIR%%/user/GameConfig/S2LP01.ini
+%%DATADIR%%/user/GameConfig/GWPP78.ini
+%%DATADIR%%/user/GameConfig/SC8J01.ini
+%%DATADIR%%/user/GameConfig/S2LE01.ini
+%%DATADIR%%/user/GameConfig/SLSJ01.ini
%%DATADIR%%/user/Wii/shared2/sys/SYSCONF
%%DATADIR%%/user/Wii/shared2/ec/shopsetu.log
%%DATADIR%%/user/Wii/shared2/succession/shop.log