aboutsummaryrefslogtreecommitdiff
path: root/finance/cbb
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1997-10-11 04:13:39 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1997-10-11 04:13:39 +0000
commitc9c4dc97cb412b3872ebc101314d23a11cda18a1 (patch)
tree92825c0603b0b103839e6d92a64c46a358daafe5 /finance/cbb
parent3dcaa95f728308469b47f0dc01e190b5ff49aa6d (diff)
downloadports-c9c4dc97cb412b3872ebc101314d23a11cda18a1.tar.gz
ports-c9c4dc97cb412b3872ebc101314d23a11cda18a1.zip
CBB is a personal check book balancing utility for Unix/X.
PR: ports/4543 Submitted by: Gary Kline <kline@thought.org> (w/mucho changes by me)
Notes
Notes: svn path=/head/; revision=8210
Diffstat (limited to 'finance/cbb')
-rw-r--r--finance/cbb/Makefile27
-rw-r--r--finance/cbb/distinfo1
-rw-r--r--finance/cbb/files/patch-0120
-rw-r--r--finance/cbb/pkg-comment1
-rw-r--r--finance/cbb/pkg-descr7
-rw-r--r--finance/cbb/pkg-plist98
6 files changed, 154 insertions, 0 deletions
diff --git a/finance/cbb/Makefile b/finance/cbb/Makefile
new file mode 100644
index 000000000000..f6b7e846336f
--- /dev/null
+++ b/finance/cbb/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cbb
+# Version required: 0.73
+# Date created: 14 September, 1997
+# Whom: kline
+#
+# $Id: Makefile,v 1.1 1997/09/03 22:56:51 kline Exp kline $
+#
+
+DISTNAME= cbb-0.73
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.me.umn.edu/pub/finance/ \
+ ftp://ftp.fifi.org/pub/cbb/
+
+MAINTAINER= kline@thought.org
+
+RUN_DEPENDS= wish4.2:${PORTSDIR}/x11/tk42
+LIB_DEPENDS= tk42\\.1\\.:${PORTSDIR}/x11/tk42
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+pre-configure:
+ @${MV} ${WRKSRC}/install.pl ${WRKSRC}/install.pl.in
+ @${SED} -e "s:/usr/local:${PREFIX}:" -e "s:lib/cbb:share/cbb:" \
+ ${WRKSRC}/install.pl.in > ${WRKSRC}/install.pl
+
+.include <bsd.port.mk>
diff --git a/finance/cbb/distinfo b/finance/cbb/distinfo
new file mode 100644
index 000000000000..3fd51da29a74
--- /dev/null
+++ b/finance/cbb/distinfo
@@ -0,0 +1 @@
+MD5 (cbb-0.73.tar.gz) = 44136bed0611b0d629d920fcfcc0e82c
diff --git a/finance/cbb/files/patch-01 b/finance/cbb/files/patch-01
new file mode 100644
index 000000000000..2cdc0f6e8e39
--- /dev/null
+++ b/finance/cbb/files/patch-01
@@ -0,0 +1,20 @@
+--- Makefile.orig Thu Jun 12 14:57:50 1997
++++ Makefile Fri Oct 10 20:52:22 1997
+@@ -26,14 +26,15 @@
+
+ CBB_ROOT = cbb-0.73
+ TAR = tar
+-PERL = perl
++PERL = ${PREFIX}/bin/perl
+
+
+ all:
+ @echo "Nothing is needed to build in advance of 'make install'"
+
+ install:
+- $(PERL) install.pl
++ $(PERL) install.pl --prefix ${PREFIX} --libdir ${PREFIX}/share/cbb \
++ --perlpath ${PREFIX}/bin/perl --wishpath ${PREFIX}/bin/
+
+ docs/cbb-man.dvi: docs/cbb-man.tex
+ (cd docs; \
diff --git a/finance/cbb/pkg-comment b/finance/cbb/pkg-comment
new file mode 100644
index 000000000000..8ee1b295aa62
--- /dev/null
+++ b/finance/cbb/pkg-comment
@@ -0,0 +1 @@
+Checkbook balancing tool
diff --git a/finance/cbb/pkg-descr b/finance/cbb/pkg-descr
new file mode 100644
index 000000000000..0ebcf22f0fe6
--- /dev/null
+++ b/finance/cbb/pkg-descr
@@ -0,0 +1,7 @@
+CBB is a personal check book balancing utility for Unix/X.
+
+CBB is intended to be an open, extensible program. It utilizes a
+simple (tab delimited) data file format and is written entirely in
+Tcl/Tk and Perl and contains no compiled code. It provides a simple
+interface for users to add their own reports, graphs, and external
+modules without having to modify any of the CBB source.
diff --git a/finance/cbb/pkg-plist b/finance/cbb/pkg-plist
new file mode 100644
index 000000000000..6b186dbc8869
--- /dev/null
+++ b/finance/cbb/pkg-plist
@@ -0,0 +1,98 @@
+bin/cbb
+share/cbb/wrapper.pl
+share/cbb/categories.pl
+share/cbb/common.pl
+share/cbb/engine.pl
+share/cbb/export.pl
+share/cbb/file.pl
+share/cbb/import.pl
+share/cbb/log.pl
+share/cbb/memorized.pl
+share/cbb/reports.pl
+share/cbb/default.cat
+share/cbb/extern.conf
+share/cbb/reports/reports.conf
+share/cbb/reports/ave-by-cat.pl
+share/cbb/reports/by-cat.pl
+share/cbb/reports/miss-check.pl
+share/cbb/reports/shrt-by-cat.pl
+share/cbb/reports/txn-list.pl
+share/cbb/graphs/graphs.conf
+share/cbb/graphs/cat-col.pl
+share/cbb/graphs/cat-pie.pl
+share/cbb/graphs/cat2-col.pl
+share/cbb/graphs/txn-list.pl
+share/cbb/graphs/graphbal
+share/cbb/graphs/graphcol
+share/cbb/graphs/graphcolpos
+share/cbb/graphs/graphpie
+share/cbb/balloon.tcl
+share/cbb/balance.tcl
+share/cbb/bindings.tcl
+share/cbb/categories.tcl
+share/cbb/common.tcl
+share/cbb/file.tcl
+share/cbb/filebox.tcl
+share/cbb/help.tcl
+share/cbb/init.tcl
+share/cbb/main.tcl
+share/cbb/menu.tcl
+share/cbb/prefs.tcl
+share/cbb/reports.tcl
+share/cbb/splits.tcl
+share/cbb/undo.tcl
+share/cbb/images/author.xbm
+share/cbb/images/cbb.xbm
+share/cbb/images/mini-cross.gif
+share/cbb/images/mini-exclam.gif
+share/cbb/images/splash-32.gif
+share/cbb/contrib/fetch-latest.pl
+share/cbb/contrib/importcat.README
+share/cbb/contrib/importcat.pl
+share/cbb/contrib/invest.pl
+share/cbb/contrib/loan.gnuplot
+share/cbb/contrib/loan.pl
+share/cbb/contrib/recur.pl
+share/cbb/contrib/term.pl
+share/cbb/contrib/trimold.pl
+share/cbb/contrib/txn.README
+share/cbb/contrib/txn
+share/cbb/contrib/upgrade-splits.pl
+share/cbb/contrib/yearend.pl
+share/cbb/docs/cbb-man.txt
+share/cbb/docs/cbb-man/cbb-man.html
+share/cbb/docs/cbb-man/index.html
+share/cbb/docs/cbb-man/img1.gif
+share/cbb/docs/cbb-man/img2.gif
+share/cbb/docs/cbb-man/img3.gif
+share/cbb/docs/cbb-man/img4.gif
+share/cbb/docs/cbb-man/icons/00Contents
+share/cbb/docs/cbb-man/icons/blank.pbm
+share/cbb/docs/cbb-man/icons/change_begin.gif
+share/cbb/docs/cbb-man/icons/change_delete.gif
+share/cbb/docs/cbb-man/icons/change_end.gif
+share/cbb/docs/cbb-man/icons/contents.xbm
+share/cbb/docs/cbb-man/icons/contents_motif.gif
+share/cbb/docs/cbb-man/icons/cross_ref_motif.gif
+share/cbb/docs/cbb-man/icons/foot_motif.gif
+share/cbb/docs/cbb-man/icons/icons.html
+share/cbb/docs/cbb-man/icons/index_motif.gif
+share/cbb/docs/cbb-man/icons/invis_anchor.xbm
+share/cbb/docs/cbb-man/icons/next_group_motif.gif
+share/cbb/docs/cbb-man/icons/next_group_motif_gr.gif
+share/cbb/docs/cbb-man/icons/next_motif.gif
+share/cbb/docs/cbb-man/icons/next_motif_gr.gif
+share/cbb/docs/cbb-man/icons/previous_group_motif.gif
+share/cbb/docs/cbb-man/icons/previous_group_motif_gr.gif
+share/cbb/docs/cbb-man/icons/previous_motif.gif
+share/cbb/docs/cbb-man/icons/previous_motif_gr.gif
+share/cbb/docs/cbb-man/icons/up_motif.gif
+share/cbb/docs/cbb-man/icons/up_motif_gr.gif
+@dirrm share/cbb/contrib
+@dirrm share/cbb/docs/cbb-man/icons
+@dirrm share/cbb/docs/cbb-man
+@dirrm share/cbb/docs
+@dirrm share/cbb/graphs
+@dirrm share/cbb/images
+@dirrm share/cbb/reports
+@dirrm share/cbb