aboutsummaryrefslogtreecommitdiff
path: root/finance/gnofin
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-12 13:23:55 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-12 13:23:55 +0000
commitc41898f938862be5a8da46ff8018e190ab444e21 (patch)
tree2d322ab0c5b1053d9e554e36b53945e412025b9e /finance/gnofin
parent159f3a6c41e010d94bf7a7306fe51fa0fb66a756 (diff)
downloadports-c41898f938862be5a8da46ff8018e190ab444e21.tar.gz
ports-c41898f938862be5a8da46ff8018e190ab444e21.zip
- Reaarange USE_GNOME
PR: 57886 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=90929
Diffstat (limited to 'finance/gnofin')
-rw-r--r--finance/gnofin/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/finance/gnofin/Makefile b/finance/gnofin/Makefile
index c9f08a8a9217..dbc82f25fd3b 100644
--- a/finance/gnofin/Makefile
+++ b/finance/gnofin/Makefile
@@ -14,25 +14,21 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Light-weight GNOME based financial management program
-USE_REINPLACE= yes
USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnomelibs gnomeprefix
USE_GMAKE= yes
-USE_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= gnofin.1
-pre-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
- -e 's|DATADIRNAME=lib|DATADIRNAME=share|g' \
- -e 's|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|' \
- -e 's|$$(top_builddir)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
- -e 's|$$(datadir)/gnome/|$$(datadir)/|g' \
- -e ' s|$$(datadir)/locale|$$(prefix)/share/locale|g'
- @{FIND} ${WRKSRC}/plugins -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
- -e 's|_la_LDFLAGS =|_la_LDFLAGS = -avoid-version|g'
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
+ s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' \
+ ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|_la_LDFLAGS =|_la_LDFLAGS = -avoid-version|g'
.include <bsd.port.mk>