aboutsummaryrefslogtreecommitdiff
path: root/finance/gnucash-docs/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-18 03:39:02 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-18 03:39:02 +0000
commit58d06cebae1b671f9d1c06e56bab2144d33fff33 (patch)
tree5b95169627720d97ef7ad7e2cb771dbf1f4400ea /finance/gnucash-docs/Makefile
parenta5fb3fec35195bcab4ec0eede530c647b7110180 (diff)
downloadports-58d06cebae1b671f9d1c06e56bab2144d33fff33.tar.gz
ports-58d06cebae1b671f9d1c06e56bab2144d33fff33.zip
Add gnucash-docs, the documentation for GnuCash.
PR: 48403 Submitted by: Glenn Johnson <glennpj@charter.net>
Notes
Notes: svn path=/head/; revision=75767
Diffstat (limited to 'finance/gnucash-docs/Makefile')
-rw-r--r--finance/gnucash-docs/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/finance/gnucash-docs/Makefile b/finance/gnucash-docs/Makefile
new file mode 100644
index 000000000000..1f0464ee3ba3
--- /dev/null
+++ b/finance/gnucash-docs/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: gnucash-doc
+# Date created: Sun Feb 16 2003
+# Whom: Glenn Johnson <glennpj@charter.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnucash-docs
+PORTVERSION= 1.8.0
+CATEGORIES= finance gnome
+MASTER_SITES= http://www.gnucash.org/pub/gnucash/sources/stable/ \
+ ftp://ftp.gnucash.org/pub/gnucash/sources/stable/ \
+ http://www.linas.org/pub/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gnucash
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Documentation for gnucash
+
+BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
+RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+
+.include <bsd.port.mk>