aboutsummaryrefslogtreecommitdiff
path: root/finance/kmymoney2
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-07-05 22:18:54 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-07-05 22:18:54 +0000
commit182e80d9da831153539540cdafcc29a5fc571281 (patch)
tree8b962638f581faed75799a9d9bdecd3f9b8a777e /finance/kmymoney2
parent7b0351f2199019babe106fc5345b282768b4bfc7 (diff)
downloadports-182e80d9da831153539540cdafcc29a5fc571281.tar.gz
ports-182e80d9da831153539540cdafcc29a5fc571281.zip
Use LTMAIN and LIBTOOL instead of hardcore.
Notes
Notes: svn path=/head/; revision=237196
Diffstat (limited to 'finance/kmymoney2')
-rw-r--r--finance/kmymoney2/Makefile4
-rw-r--r--finance/kmymoney2/files/patch-configure4
2 files changed, 6 insertions, 2 deletions
diff --git a/finance/kmymoney2/Makefile b/finance/kmymoney2/Makefile
index 2fc43f53954c..c89e43397c66 100644
--- a/finance/kmymoney2/Makefile
+++ b/finance/kmymoney2/Makefile
@@ -53,4 +53,8 @@ BUILD_DEPENDS+= jade:${PORTSDIR}/textproc/jade \
dsssl-docbook-modular>=0:${PORTSDIR}/textproc/dsssl-docbook-modular
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LIBTOOL%%|${LIBTOOL}|g ; \
+ s|%%LTMAIN%%|${LTMAIN}|g' ${WRKSRC}/configure
+
.include <bsd.port.post.mk>
diff --git a/finance/kmymoney2/files/patch-configure b/finance/kmymoney2/files/patch-configure
index 0a0e7ebd5da6..b6b8cab44977 100644
--- a/finance/kmymoney2/files/patch-configure
+++ b/finance/kmymoney2/files/patch-configure
@@ -11,11 +11,11 @@
# This can be used to rebuild libtool when needed
-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS=" /usr/local/share/libtool/ltmain.sh"
++LIBTOOL_DEPS=" %%LTMAIN%%"
# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool --silent'
-+LIBTOOL='$(SHELL) /usr/local/bin/libtool --silent'
++LIBTOOL='$(SHELL) %%LIBTOOL%% --silent'
# Prevent multiple expansion