aboutsummaryrefslogtreecommitdiff
path: root/finance/libofx/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-08-31 22:16:42 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-08-31 22:16:42 +0000
commitf26157f4d56dd2286df1824fd0174f55a0d62576 (patch)
tree3362d4f3015c85136260cd00c634cc4ff4803cc1 /finance/libofx/Makefile
parent3c50cd2490c4b209293bccbd4d7c857a3b46b695 (diff)
downloadports-f26157f4d56dd2286df1824fd0174f55a0d62576.tar.gz
ports-f26157f4d56dd2286df1824fd0174f55a0d62576.zip
- Update to 0.8.0
PR: ports/85532 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=141642
Diffstat (limited to 'finance/libofx/Makefile')
-rw-r--r--finance/libofx/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/finance/libofx/Makefile b/finance/libofx/Makefile
index e8ed11cb50bd..54824f827c22 100644
--- a/finance/libofx/Makefile
+++ b/finance/libofx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libofx
-PORTVERSION= 0.7.0
+PORTVERSION= 0.8.0
CATEGORIES= finance
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,18 +14,21 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenSource implementation of the OFX (Open Financial eXchange)
-LIB_DEPENDS= osp.3:${PORTSDIR}/textproc/opensp
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
+ osp.3:${PORTSDIR}/textproc/opensp
USE_GMAKE= yes
USE_GNOME= gnometarget
-USE_LIBTOOL_VER= 15
USE_GETOPT_LONG= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-doxygen --disable-dot \
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --disable-doxygen --disable-dot --disable-gengetopt \
--with-opensp-includes=${LOCALBASE}/include/OpenSP
INSTALLS_SHLIB= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}