aboutsummaryrefslogtreecommitdiff
path: root/finance/opale
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-03-01 04:24:38 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-03-01 04:24:38 +0000
commit310e2360062dc3a7085884ded390f531313eefad (patch)
tree5f77875044ab7a4fcaca7e4ab667dc9cbd3980ce /finance/opale
parent42f4ab2b1c895fd08c0ac68d6011c0d0df31c717 (diff)
downloadports-310e2360062dc3a7085884ded390f531313eefad.tar.gz
ports-310e2360062dc3a7085884ded390f531313eefad.zip
New port opale version 0.5: A very simple personal bank account
manager for KDE and KOffice
Notes
Notes: svn path=/head/; revision=102594
Diffstat (limited to 'finance/opale')
-rw-r--r--finance/opale/Makefile38
-rw-r--r--finance/opale/distinfo2
-rw-r--r--finance/opale/files/patch-opale::opale_record.cc55
-rw-r--r--finance/opale/pkg-descr13
-rw-r--r--finance/opale/pkg-plist56
5 files changed, 164 insertions, 0 deletions
diff --git a/finance/opale/Makefile b/finance/opale/Makefile
new file mode 100644
index 000000000000..edd99517eab7
--- /dev/null
+++ b/finance/opale/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: opale
+# Date created: Wed Feb 25 00:43:37 UTC 2004
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opale
+PORTVERSION= 0.5
+CATEGORIES= finance kde
+MASTER_SITES= http://orzel.freehackers.org/download/ \
+ ftp://ftp.freehackers.org/pub/opale/
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= A very simple personal bank account manager for KDE and KOffice
+
+LIB_DEPENDS= kofficecore.2:${PORTSDIR}/editors/koffice-kde3
+
+USE_KDELIBS_VER=3
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_REINPLACE= yes
+USE_SIZE= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ARGS= --with-koffice-includes=${LOCALBASE}/include \
+ --with-koffice-libs=${LOCALBASE}/lib \
+ --program-prefix=''
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's|-O2||g' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/finance/opale/distinfo b/finance/opale/distinfo
new file mode 100644
index 000000000000..891285974a8f
--- /dev/null
+++ b/finance/opale/distinfo
@@ -0,0 +1,2 @@
+MD5 (opale-0.5.tar.bz2) = 331dc07ba5c00b088c6b3f17419a0fe5
+SIZE (opale-0.5.tar.bz2) = 550138
diff --git a/finance/opale/files/patch-opale::opale_record.cc b/finance/opale/files/patch-opale::opale_record.cc
new file mode 100644
index 000000000000..60df79700b99
--- /dev/null
+++ b/finance/opale/files/patch-opale::opale_record.cc
@@ -0,0 +1,55 @@
+--- opale/opale_record.cc.orig Thu Nov 20 12:00:53 2003
++++ opale/opale_record.cc Sun Feb 29 22:18:25 2004
+@@ -270,7 +270,7 @@
+ QString("%1 %2").arg( QString().sprintf("%12.2f", m_amount/100.)).arg(currency),
+ checked()?"X":"",
+ howlist[type],
+- isFutur()?i18n("Future"):"",
++ isFutur()?i18n("Future"):QString(""),
+ QString("%1 %2").arg( QString().sprintf("%12.2f", t->global/100.)).arg(currency),
+ categorylist[category] );
+
+@@ -324,10 +324,19 @@
+
+ #ifndef USE_BUGGY_STRTOD
+
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <math.h>
++
++#if (defined(BSD) && (BSD >= 199306))
++#include <limits.h>
++#else
+ #include <values.h> // MAXLONG
++#endif
+
+ amount_t
+ atoprice (const char *buf)
+@@ -347,7 +356,11 @@
+ a = atol (buf);
+
+ /* provisoire */
++#if (defined(BSD) && (BSD >= 199306))
++ if (a > ((LONG_MAX) / 100))
++#else
+ if (a > MAXLONG / 100)
++#endif
+ kdDebug(OPALE_DEBUG_STREAM) << "Price out of limits(1)" << endl;
+
+ return (a >= 0) ? 100 * a + b : 100 * a - b;
+@@ -356,7 +369,11 @@
+ {
+ /* provisoire */
+ a = atol (buf);
++#if (defined(BSD) && (BSD >= 199306))
++ if (a > ((LONG_MAX) / 100))
++#else
+ if (a > ((MAXLONG) / 100))
++#endif
+ kdDebug(OPALE_DEBUG_STREAM) << "Price out of limits(2)" << endl;
+ return (100 * a);
+ }
diff --git a/finance/opale/pkg-descr b/finance/opale/pkg-descr
new file mode 100644
index 000000000000..b404ff90fdee
--- /dev/null
+++ b/finance/opale/pkg-descr
@@ -0,0 +1,13 @@
+[ excerpt from developer's www site ]
+
+Opale is a very simple personal bank account manager for KDE and
+KOffice. The precise specifications are opale should do what I
+need.
+
+I'm not releasing Opale in the hope it will be useful for anybody.
+Of course I'll be glad if it ever is, but I'm mostly expecting you
+to find Opale quite limited. It should be easy to improve , though,
+with new filters for example. And I can help you if needed.
+
+Author: Thomas Capricelli
+WWW: http://orzel.freehackers.org/opale/
diff --git a/finance/opale/pkg-plist b/finance/opale/pkg-plist
new file mode 100644
index 000000000000..94984630cad6
--- /dev/null
+++ b/finance/opale/pkg-plist
@@ -0,0 +1,56 @@
+bin/opale
+lib/kde3/libcashimport.la
+lib/kde3/libcashimport.so
+lib/libopalepart.la
+lib/libopalepart.so
+lib/libopalepart.so.0
+lib/opale.la
+lib/opale.so
+share/applnk/Office/opale.desktop
+share/apps/opale/opale.rc
+share/icons/crystalsvg/32x32/apps/opale.png
+share/icons/crystalsvg/48x48/apps/opale.png
+share/icons/crystalsvg/scalable/apps/opale.svg
+share/icons/locolor/16x16/apps/opale.png
+share/icons/locolor/32x32/apps/opale.png
+share/locale/de/LC_MESSAGES/opale-0.5.mo
+share/locale/et/LC_MESSAGES/opale-0.5.mo
+share/locale/fr/LC_MESSAGES/opale-0.5.mo
+share/locale/it/LC_MESSAGES/opale-0.5.mo
+share/locale/ru/LC_MESSAGES/opale-0.5.mo
+share/mimelnk/application/x-cash-be.desktop
+share/mimelnk/application/x-cash-le.desktop
+share/mimelnk/application/x-opale.desktop
+share/services/opale_cash_import.desktop
+@unexec rmdir %D/share/services 2>/dev/null || true
+@unexec rmdir %D/share/mimelnk/application 2>/dev/null || true
+@unexec rmdir %D/share/mimelnk 2>/dev/null || true
+@unexec rmdir %D/share/locale/ru/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/ru 2>/dev/null || true
+@unexec rmdir %D/share/locale/it/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/it 2>/dev/null || true
+@unexec rmdir %D/share/locale/fr/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/fr 2>/dev/null || true
+@unexec rmdir %D/share/locale/et/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/et 2>/dev/null || true
+@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/de 2>/dev/null || true
+@unexec rmdir %D/share/locale 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/32x32/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/32x32 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/16x16/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/16x16 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor 2>/dev/null || true
+@unexec rmdir %D/share/icons/crystalsvg/scalable/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/crystalsvg/scalable 2>/dev/null || true
+@unexec rmdir %D/share/icons/crystalsvg/48x48/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/crystalsvg/48x48 2>/dev/null || true
+@unexec rmdir %D/share/icons/crystalsvg/32x32/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/crystalsvg/32x32 2>/dev/null || true
+@unexec rmdir %D/share/icons/crystalsvg 2>/dev/null || true
+@unexec rmdir %D/share/icons 2>/dev/null || true
+@unexec rmdir %D/share/apps/opale 2>/dev/null || true
+@unexec rmdir %D/share/apps 2>/dev/null || true
+@unexec rmdir %D/share/applnk/Office 2>/dev/null || true
+@unexec rmdir %D/share/applnk 2>/dev/null || true
+@unexec rmdir %D/lib/kde3 2>/dev/null || true