aboutsummaryrefslogtreecommitdiff
path: root/finance/p5-Business-MaxMind-CreditCardFraudDetection
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2008-01-23 01:50:29 +0000
committerXin LI <delphij@FreeBSD.org>2008-01-23 01:50:29 +0000
commit20e79e8c3bbdf1e4926bdea8f72ec1aedc069539 (patch)
treea42d7fa33cbcd20156b381a237c68138398f314a /finance/p5-Business-MaxMind-CreditCardFraudDetection
parent80223c60cf1612604f83fb7d2353d07a0a883c4b (diff)
downloadports-20e79e8c3bbdf1e4926bdea8f72ec1aedc069539.tar.gz
ports-20e79e8c3bbdf1e4926bdea8f72ec1aedc069539.zip
New port: p5-Bussiness-MaxMind-CreditCardFraudDetection.
This module queries the MaxMind minFraud service and returns the result. PR: ports/119544 Submitted by: Vivek Khera
Notes
Notes: svn path=/head/; revision=206045
Diffstat (limited to 'finance/p5-Business-MaxMind-CreditCardFraudDetection')
-rw-r--r--finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile51
-rw-r--r--finance/p5-Business-MaxMind-CreditCardFraudDetection/distinfo3
-rw-r--r--finance/p5-Business-MaxMind-CreditCardFraudDetection/pkg-descr13
3 files changed, 67 insertions, 0 deletions
diff --git a/finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile b/finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile
new file mode 100644
index 000000000000..6e83ea1054df
--- /dev/null
+++ b/finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: p5-Business-MaxMind-CreditCardFraudDetection
+# Date created: Thu Jan 10 16:13:05 EST 2008
+# Whom: Vivek Khera <vivek@khera.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-MaxMind-CreditCardFraudDetection
+PORTVERSION= 1.46
+CATEGORIES= finance perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/T/TJ/TJMATHER
+PKGNAMEPREFIX= p5-
+DISTNAME= ccfd_perl_1.46
+
+MAINTAINER= vivek@khera.org
+COMMENT= Interface to MaxMind minFraud service
+
+RUN_DEPENDS+= p5-libwww>0.0:${PORTSDIR}/www/p5-libwww \
+ p5-Crypt-SSLeay>0.0:${PORTSDIR}/security/p5-Crypt-SSLeay
+BUILD_DEPENDS+= p5-libwww>0.0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Business::MaxMind::CreditCardFraudDetection.3 \
+ Business::MaxMind::HTTPBase.3 \
+ Business::MaxMind::LocationVerification.3 \
+ Business::MaxMind::TelephoneVerification.3 \
+
+PLIST_FILES= \
+ %%SITE_PERL%%/Business/MaxMind/CreditCardFraudDetection.pm \
+ %%SITE_PERL%%/Business/MaxMind/HTTPBase.pm \
+ %%SITE_PERL%%/Business/MaxMind/LocationVerification.pm \
+ %%SITE_PERL%%/Business/MaxMind/TelephoneVerification.pm \
+ %%SITE_PERL%%/Business/MaxMind/example.pl \
+ %%SITE_PERL%%/Business/MaxMind/example_locv.pl \
+ %%SITE_PERL%%/Business/MaxMind/example_telv.pl \
+ %%SITE_PERL%%/auto/Business/MaxMind/HTTPBase/autosplit.ix \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/MaxMind/HTTPBase/.packlist
+
+PLIST_DIRS= \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/MaxMind/HTTPBase \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/MaxMind \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business \
+ %%SITE_PERL%%/auto/Business/MaxMind/HTTPBase \
+ %%SITE_PERL%%/auto/Business/MaxMind \
+ %%SITE_PERL%%/auto/Business \
+ %%SITE_PERL%%/Business/MaxMind \
+ %%SITE_PERL%%/Business \
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Business-MaxMind-CreditCardFraudDetection/distinfo b/finance/p5-Business-MaxMind-CreditCardFraudDetection/distinfo
new file mode 100644
index 000000000000..4459d78c91de
--- /dev/null
+++ b/finance/p5-Business-MaxMind-CreditCardFraudDetection/distinfo
@@ -0,0 +1,3 @@
+MD5 (ccfd_perl_1.46.tar.gz) = 3ca1180be7d6349c8d33545f6ee5e79f
+SHA256 (ccfd_perl_1.46.tar.gz) = ab7890b8dc53bfb0430f97d92cebd69a8e1364433fe0d41fc9468e2dc469ec7c
+SIZE (ccfd_perl_1.46.tar.gz) = 13450
diff --git a/finance/p5-Business-MaxMind-CreditCardFraudDetection/pkg-descr b/finance/p5-Business-MaxMind-CreditCardFraudDetection/pkg-descr
new file mode 100644
index 000000000000..a304531344e3
--- /dev/null
+++ b/finance/p5-Business-MaxMind-CreditCardFraudDetection/pkg-descr
@@ -0,0 +1,13 @@
+NAME
+ Business::MaxMind::CreditCardFraudDetection - Access MaxMind minFraud
+ services
+
+ABSTRACT
+ This module queries the MaxMind minFraud service and returns the
+ results. The service uses a free e-mail database, an IP address geog-
+ raphy database, a bank identification number, and proxy checks to
+ return a risk factor score representing the likelihood that the credit
+ card transaction is fraudulent.
+
+WWW: http://www.maxmind.com/app/ccv_overview
+