aboutsummaryrefslogtreecommitdiff
path: root/finance/qhacc
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-08-22 14:09:47 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-08-22 14:09:47 +0000
commit288af27a1779c81e1083963f82fd411230d97cdc (patch)
tree40ae4222a2154ba283f62d98a4e109dc56f04311 /finance/qhacc
parent41407446e2ae8df49f85cf5522636c4ae67129ca (diff)
downloadports-288af27a1779c81e1083963f82fd411230d97cdc.tar.gz
ports-288af27a1779c81e1083963f82fd411230d97cdc.zip
- software author added new headers to tarball
- tarball was rerolled, hence new checksum - bump PORTREVISION PR: 55825 Submitted by: Ruslan Babayev <ruslan@babayev.com> KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=87504
Diffstat (limited to 'finance/qhacc')
-rw-r--r--finance/qhacc/Makefile4
-rw-r--r--finance/qhacc/distinfo2
-rw-r--r--finance/qhacc/files/xmlplugin.h52
3 files changed, 2 insertions, 56 deletions
diff --git a/finance/qhacc/Makefile b/finance/qhacc/Makefile
index 0032c432e630..c56a04d58c89 100644
--- a/finance/qhacc/Makefile
+++ b/finance/qhacc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qhacc
PORTVERSION= 2.9.1
+PORTREVISION= 1
CATEGORIES= finance
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -29,9 +30,6 @@ INSTALLS_SHLIB= yes
STRIP= # none
-post-extract:
- @${CP} -f ${FILESDIR}/xmlplugin.h ${WRKSRC}/plugins/xml
-
post-patch:
@${REINPLACE_CMD} 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|#! /bin/sh|#!${LOCALBASE}/bin/bash|g ; \
diff --git a/finance/qhacc/distinfo b/finance/qhacc/distinfo
index 988296f98f87..479f6939c765 100644
--- a/finance/qhacc/distinfo
+++ b/finance/qhacc/distinfo
@@ -1 +1 @@
-MD5 (qhacc-2.9.1.tar.gz) = 67ddb65c89424bf684b1dca998d0a212
+MD5 (qhacc-2.9.1.tar.gz) = 1e8b88a7ee1978bdcc7915ca9915a945
diff --git a/finance/qhacc/files/xmlplugin.h b/finance/qhacc/files/xmlplugin.h
deleted file mode 100644
index d6b7f22dbc7e..000000000000
--- a/finance/qhacc/files/xmlplugin.h
+++ /dev/null
@@ -1,52 +0,0 @@
-/************************* * * * * * * * * * * * * ***************************
- Copyright (c) 1999-2003 Ryan Bobko
- ryan@ostrich-emulators.com
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-************************** * * * * * * * * * * * * **************************/
-
-#ifndef XMLIMPORTER_H
-#define XMLIMPORTER_H
-
-#include "localfileplugin.h"
-
-#include <stdlib.h>
-#include <tree.h>
-#include <xmlmemory.h>
-#include <parser.h>
-
-class XMLDBPlugin : public LocalFileDBPlugin {
- public:
- XMLDBPlugin();
- virtual ~XMLDBPlugin();
-
- virtual bool load( QHacc * eng, const QString& home, QString& error );
- virtual bool save( const QString&, bool, QString& );
-
- virtual QString description() const;
- static QString sdescription();
-
- virtual QString understands() const; // what QHACC_HOME keywords do I know?
- static QString sunderstands(); // what QHACC_HOME keywords do I know?
-
- protected:
- void writeTable( QHaccResultSet& data, const char ** lbls, uint lblcnt,
- xmlDocPtr tree, xmlNsPtr ns, const QString& label ) const;
- void readTable( QHaccResultSet& data, const char ** lbls,
- uint lblcnt, xmlNodePtr cur, xmlDocPtr doc,
- const QString& label ) const;
-};
-
-#endif