aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-08-05 22:42:24 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-08-05 22:42:24 +0000
commit158df60054c9cd25413091670f34dab40584017a (patch)
tree746e052641003e0645da246146e849687dd2f6b1 /finance
parentf45d77036211d2417cb95b630d0b4eb631e38b8f (diff)
downloadports-158df60054c9cd25413091670f34dab40584017a.tar.gz
ports-158df60054c9cd25413091670f34dab40584017a.zip
Fix install after DESTDIR patch.
Submitted by: gabor
Notes
Notes: svn path=/head/; revision=169783
Diffstat (limited to 'finance')
-rw-r--r--finance/cbb/Makefile12
-rw-r--r--finance/cbb/files/patch-0114
-rw-r--r--finance/cbb/files/patch-0320
3 files changed, 11 insertions, 35 deletions
diff --git a/finance/cbb/Makefile b/finance/cbb/Makefile
index a4daec6644ca..60db6609bdde 100644
--- a/finance/cbb/Makefile
+++ b/finance/cbb/Makefile
@@ -18,7 +18,17 @@ RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
NO_BUILD= yes
USE_PERL5= yes
-MAKE_ENV= PERL5=${PERL5}
GNU_CONFIGURE= yes
+post-patch:
+ @${REINPLACE_CMD} -e "s|PERL = /usr/bin/perl|PERL = ${PERL5}|" \
+ -e "s|WISH = /usr/bin/wish|WISH = ${LOCALBASE}/bin/wish8.2|" \
+ -e "s|DESTDIR =||" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} "s|DESTDIR =||" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|$$destdir/bin|$$destdir/$$prefix/bin|' \
+ -e 's|$$destdir/lib/cbb|$$destdir/$$prefix/lib/cbb|' \
+ ${WRKSRC}/install.pl
+ @${REINPLACE_CMD} -e "s|=wish|=wish8.2|" -e 's|=""wish""|=""wish8.2""|' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/finance/cbb/files/patch-01 b/finance/cbb/files/patch-01
deleted file mode 100644
index 924d43de64b2..000000000000
--- a/finance/cbb/files/patch-01
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile.orig Wed Jan 5 14:43:28 2000
-+++ Makefile Sun Jan 23 00:58:16 2000
-@@ -60,9 +60,9 @@
- LN_S = ln -s
- MAKEINFO = makeinfo
- PACKAGE = cbb
--PERL = /usr/bin/perl
-+PERL = ${PERL5}
- VERSION = 0.8.1
--WISH = /usr/bin/wish
-+WISH = ${LOCALBASE}/bin/wish8.2
- language = english
-
- SUBDIRS = contrib demo docs graphs images languages reports
diff --git a/finance/cbb/files/patch-03 b/finance/cbb/files/patch-03
deleted file mode 100644
index 389de827cd9f..000000000000
--- a/finance/cbb/files/patch-03
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.orig Sun Jan 23 01:41:45 2000
-+++ configure Sun Jan 23 01:42:10 2000
-@@ -798,7 +798,7 @@
- fi
-
- if test "x$with_wish" = "x" ; then
-- with_wish=wish
-+ with_wish=wish8.2
- fi
-
- # Check whether --with-wish or --without-wish was given.
-@@ -988,7 +988,7 @@
- fi
- done
- IFS="$ac_save_ifs"
-- test -z "$ac_cv_path_WISH" && ac_cv_path_WISH=""wish""
-+ test -z "$ac_cv_path_WISH" && ac_cv_path_WISH=""wish8.2""
- ;;
- esac
- fi